Results 1 to 3 of 3

Thread: Avoiding conflicts when updating software

  1. #1
    Join Date
    Oct 2015
    Location
    Glasgow
    Posts
    18

    Default Avoiding conflicts when updating software

    I have recently noticed error messages indicating a conflict when running an update. I wonder if this is something to do with my repository selection. I have pasted below and would be good to know what is good to have, including worthy repos I have not yet added, and what is not necessary. Grateful for your advice:

    1 | All_of_Packman | All of Packman | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/misc/pa...SE_Tumbleweed/ |
    2 | Science_&_Engineering | Science & Engineering | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    3 | Updated_KDE_Apps | Updated KDE extras | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    4 | Updated_KDE_Apps_1 | Updated KDE Apps | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    5 | VLC | VLC | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/vid...vlc/SuSE/13.1/ |
    6 | WINE | WINE | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    7 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    8 | download.opensuse.org-oss | Main Repository (OSS) | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss/ |
    9 | download.opensuse.org-oss_1 | Main Repository (DEBUG) | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
    10 | download.opensuse.org-tumbleweed | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
    11 | google-earth | google-earth | Yes | ( p) Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64 |
    12 | http-download.opensuse.org-2a83ef1a | KDE:Extra | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    13 | http-download.opensuse.org-8ab63f55 | openSUSE:13.2:Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/ports/update/13.2/ |
    14 | http-download.videolan.org-60056f97 | SuSE | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.videolan.org/SuSE/Tumbleweed/ |
    15 | http-ftp.gwdg.de-c2647950 | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...SE_Tumbleweed/ |
    16 | http-opensuse-guide.org-133e26c9 | libdvdcss repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ |
    17 | repo-debug | openSUSE-Tumbleweed-Debug | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
    18 | repo-source | openSUSE-Tumbleweed-Source | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/...weed/repo/oss/

  2. #2

    Default Re: Avoiding conflicts when updating software

    Quote Originally Posted by Webheadjunky View Post
    I have recently noticed error messages indicating a conflict when running an update. I wonder if this is something to do with my repository selection.
    Most likely, yes.

    Remove those at least:
    Code:
     4 | Updated_KDE_Apps_1                  | Updated KDE Apps           | Yes | (r ) Yes | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/     |         
     5 | VLC                                 | VLC                        | Yes | (r ) Yes | Yes     |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/13.1/                       |         
     6 | WINE                                | WINE                       | Yes | (r ) Yes | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_Tumbleweed/ |         
     7 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)  | Yes | (r ) Yes | Yes     |   99     | yast2  | 
    12 | http-download.opensuse.org-2a83ef1a | KDE:Extra | Yes | (r ) Yes | Yes | 99 | rpm-md   | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/ | 
    13 | http-download.opensuse.org-8ab63f55 | openSUSE:13.2:Update       | Yes | (r ) Yes | Yes     |   99     | rpm-md |  http://download.opensuse.org/ports/update/13.2/                                | 
    14 | http-download.videolan.org-60056f97 | SuSE | Yes | (r ) Yes | Yes | 99 | rpm-md |http://download.videolan.org/SuSE/Tumbleweed/ |
    You don't need them with Tumbleweed. The point of Tumbleweed is to get the latest versions via the *main* repo.

    Also, #4, #7, #12 and #13 are for openSUSE 13.2, and #5 is even for 13.1. So it's actually no wonder that you get conflicts...

    #14 is for Tumbleweed, but you shouldn't use the VLC repo together with Packman, they are incompatible (and everything from the VLC repo is available in Packman too anyway).

    The Packman repo is in your list twice, #1 and #15, better remove one of them.
    This shouldn't cause any problem, but takes up unnecessary diskspace (for the caches) and time (when refreshing the repos).
    Last edited by wolfi323; 14-Nov-2015 at 07:30.

  3. #3
    Join Date
    Oct 2015
    Location
    Glasgow
    Posts
    18

    Default SOLVED: Avoiding conflicts when updating software

    Thanks
    Works a treat now
    Just use the software updater icon now every day, whereas before I was getting conflicts
    Update process on this distro is the slickest I have come across so far
    Cheers
    R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •