Results 1 to 10 of 10

Thread: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

  1. #1
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    I had no problem updating an oSUSE 13.1 Gnome installation using the Leap 42.1 DVD iso burned to a usb flash drive, but now prefer Xfce as my default Desktop Environment (although the current Gnome is very nice, I am now more familiar with Xfce).

    Instead of doing a fresh installation, I would prefer to install Xfce on the current oSUSE installation and use it as the default DE.

    I recall viewing instructions to that effect but have had no luck in finding them today, so any pointers or suggestions to that end would be welcome.

    TIA

  2. #2

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    I would start here > https://en.opensuse.org/Portalfce

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,790
    Blog Entries
    3

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Quote Originally Posted by d_hinds View Post
    Instead of doing a fresh installation, I would prefer to install Xfce on the current oSUSE installation and use it as the default DE.
    Yast --> Software Management

    If there is a tab labeled "Patterns" click on that.
    If you cannot find that tab, then click "View" and select "Patterns"

    On the next screen, check the boxes "XFCE Base System" and "XFCE Desktop Environment".

    Click "Accept" near the bottom right corner. And you are done. Well, it might take a few minutes to download and install the packages, but you can just drink some coffee while that is going on.

    After you are finished, you might want to change the display manager to "lightdm", although it is not necessary to do that. (Ask if you need directions).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Thank you EmpireITech an nrickert for your responses.

    Since I have already installed oSUSE Xfce on other computers from the DVD and Net install isos, and I felt that nrickert's suggestion was closer to what I wanted to do at this time. (Although being in touch with the oSUSE Xfce Team is certainly an asset).

    nrickert: I had no problem following your clear instructions and after closing YAST's Software management I rebooted - into Gnome. Which is not what I wanted.

    I'll reboot again, being more attentive to the choices I'm given.

    Thanks again - I'm sure I'm on the right track.

    Done. Unfortunately, no choices were presented. The system boots automatically into Gnome. While Gnome is a very visually attractive system and the update resulted in a very responsive one also, I feel I can get more done using Xfce, which is what I've been using on other systems (even with Openbox, I use the Xfce4-panel and a number of Xfce4-widgets).

    I went into settings and am looking at the Tweak Tool.

  5. #5
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    All I could do was tweak Gnome so that it functions more like Xfce. (i.e. have a set number of desktops and a window menu at the bottom).

    What I have NOT been able to do is determine how to switch Desktop Environments - yet.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Do you have autologin on? you can choose the desktop from the log in screen look along the bottom. If you have autologin then you could log out to get to the login screen then login to th desktop you want.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,790
    Blog Entries
    3

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Quote Originally Posted by d_hinds View Post
    Done. Unfortunately, no choices were presented. The system boots automatically into Gnome.
    This mostly a repeat of what gogalthorp has already posted.

    I don't use "autologin" so it didn't occur to me to explain how to escape from Gnome.

    When you are in Gnome, logout. I think you know how, because it is similar to shutting down. But if you can't work it out, the CTRL-ALT-BACKSPACE (twice) will crash your session.

    That gets you back to the login manager. It is probably "gdm". On the login screen, there's a place where you can select the desktop. Off the top of my head, I think you select the user, and hit enter. Then the next screen lists the desktop. And you can change that to XFCE.

    Once you have logged into XFCE, the next time you boot, then I'm pretty sure that you will go straight into XFCE. That is to say, it remembers your last session.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default [SOLVED] Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Thanks to both gogalthorp and nrickert for your helpful orientations.

    Although I don't normally choose autologin this installation has it, so I logged out and on clicking on the user, a sun icon appears below and to the right of the password box, which shows Gnome, Gnome Classic, IceWM and Xfce Session in a vertical list.

    Furthermore, apparently the last choice selected remains as the default for the next login.

    Another reason I wanted to use Xfce is that I did a new Leap 42.1 Xfce installation on another computer and was able to get youtube videos working in most of the browsers after installing some of the community repositories, but I haven't been able to accomplish that yet in Gnome. (Which is not my main reason for wanting to install Xfce).

    I consider openSUSE Forums to be among the best of all distros and I have found Leap 42.1 to be a solid performer, so far. (I had lost a working 13.1 installation when the 50 Gb btrfs / partition filled up doing a zypper dup to 13.2 and I was unable to either rescue or reinstall either one. So I was glad to be able to get it working on that machine, again).

    Thanks again

    When installing the Xfce Base System and DE I noticed that lightdm was included, if that would allow me to turnoff the autologin.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    You can turn autologin off in Yast-/etc/sysconf editor - Displaymanager-DISPLAYMANAGER-Autologin just put a blank string to replace name of autologin user

  10. #10
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Updated from 13.1 > Leap 42.1 - Now want to Change DE to Xfce from Gnome

    Quote Originally Posted by gogalthorp View Post
    You can turn autologin off in Yast-/etc/sysconf editor - Displaymanager-DISPLAYMANAGER-Autologin just put a blank string to replace name of autologin user
    Perfect. I'll do that.

    Thanks, gogalthorpe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •