Results 1 to 6 of 6

Thread: Plasma 5 Problems

  1. #1

    Angry Plasma 5 Problems

    Hello,
    I installed this new distribution either in my workstation (hp 6300 pro microtower) or on my laptop (Toshiba Satellite T130) and I'm having issues with kde plasma 5. From time to time the display flashes, the windows I have open tremble. Sometimes when changing virtual desktop, the resfresh is too slow.
    The problem is most severe in Workstation, I do not know if is because i have dual monitor.
    I think this happens regardless of the applications that have open, but is most noticeable when I have some flash app running in the browser.
    In other graphs environments (Mate, cinnamom, gnome) all works well.

    My graphics card is an asus eah4350.

    Is there anything I can do ?! The kde is my reference to the destop many years, and others, no matter how good they may be, do not reach the kde heels (except the plasma 5)

    Best regards,
    Vitor

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Plasma 5 Problems

    Maybe the window compositor has issues with your HW. Go to:

    System settings > Display and monitor > Compositor > Rendering backend

    try XRender or OpenGL 2.0 ; OpenGL 3.0 has problems on some HW, apparently.
    Or try to switch off effects or the whole compositor as a last resort.
    And check CPU load when you have such problems, maybe there are background jobs competing for resources...
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Talking Re: Plasma 5 Problems

    Thanks for the tip.
    By default, the rendering backend was set to OpenGL 2.0, and when I changed to XRender or OpenGL 3.1, the issue is resolved.
    Now, a second question arises, what is better, XRender or OpenGL 3.1!

    Again, thank you for your (fast) tip.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,044
    Blog Entries
    14

    Default Re: Plasma 5 Problems

    Quote Originally Posted by eng_vmc View Post
    Thanks for the tip.
    By default, the rendering backend was set to OpenGL 2.0, and when I changed to XRender or OpenGL 3.1, the issue is resolved.
    Now, a second question arises, what is better, XRender or OpenGL 3.1!

    Again, thank you for your (fast) tip.
    AFAIK OpenGL is preferred over XRender.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Plasma 5 Problems

    Not running openGL could cause issues with some games

  6. #6

    Default Re: Plasma 5 Problems

    Quote Originally Posted by gogalthorp View Post
    Not running openGL could cause issues with some games
    That setting only affects what kwin uses to draw the screen. It doesn't influence whether games do or do not use OpenGL, or other parts of the software stack.

    And actually running kwin with OpenGL could cause issues with some games, depending on your card/driver.

    But OpenGL in kwin is required for certain desktop effects, and especially on modern GPUs it probably also performs better. (current cards are 3D-only internally, while XRender is 2D)
    Last edited by wolfi323; 12-Nov-2015 at 08:51.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •