Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: LEAP automatic software updater

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,284

    Default LEAP automatic software updater

    What is the name of the software updater that pops up, and how do I disable it?

    Thanks in advance.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,478
    Blog Entries
    3

    Default Re: LEAP automatic software updater

    If you are using Plasma 5, then you can disable it in the tray settings.

    I don't know the name.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,478
    Blog Entries
    3

    Default Re: LEAP automatic software updater

    Searching for "update" in Yast software manager, I see that there is something called "plasma5-pk-updates" which seems to fit the description.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,972

    Default Re: LEAP automatic software updater

    Quote Originally Posted by ionmich View Post
    What is the name of the software updater that pops up, and how do I disable it?

    Thanks in advance.
    Plaese always tell from the beginning which desktop you are using. Specialy when your question/problem is a bout a typical desktop feature.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: LEAP automatic software updater

    Quote Originally Posted by nrickert View Post
    If you are using Plasma 5, then you can disable it in the tray settings.

    I don't know the name.
    actually I don't think it can be disabled in the tray settings.
    Going to systray settings and unchecking "software updates" removes the icon but does not stop the popups from occurring hourly.
    Doesn't appear to be any setting within the updater itself to disable it - only to change the frequency (haven't checked to see if this works yet.)
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: LEAP automatic software updater

    Quote Originally Posted by farcusnz View Post
    actually I don't think it can be disabled in the tray settings.
    Going to systray settings and unchecking "software updates" removes the icon but does not stop the popups from occurring hourly.
    Yes - partly. For authentication nonsense I won't go into again, the updater says my system is offline (it isn't - wifi is connected). So icon is not showing in tray, but it is showing in "Status and Notifications". I uncheck in systray settings, and the entry for the updater disappears from Status and Notifications. Re-checking the setting brings it back with the same phony status of "Your system is offline". I'm guessing it does remove from systray. Maybe a separate authentication process is causing the three messages to appear...

    If you are on a wired connection, this issue may not occur(?).
    Leap 42.3 (ext4, KDE Plasma 5.8.7) ~ stable
    Manjaro (ext4, Xfce) ~ rolling updates
    Tumbleweed (ext4, KDE Plasma5) ~ managed updates via "Tumbleweed Snapshots" service.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,478
    Blog Entries
    3

    Default Re: LEAP automatic software updater

    Quote Originally Posted by farcusnz View Post
    Going to systray settings and unchecking "software updates" removes the icon but does not stop the popups from occurring hourly.
    I have not had any update popups since unchecking that.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,284

    Default Re: LEAP automatic software updater

    Quote Originally Posted by hcvv View Post
    Plaese always tell from the beginning which desktop you are using. Specialy when your question/problem is a bout a typical desktop feature.
    Sorry, I was careless. It's KDE 4.14.10.

  9. #9
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: LEAP automatic software updater

    Quote Originally Posted by nrickert View Post
    I have not had any update popups since unchecking that.
    Now the wifi authentication nonsense is hopefully gone here - just had the first reboot without kwallet interfering or being asked for the passkey. After editing NM's connection, I avoided logout/in this time round which seemed to cause authorization issues before (polkit related I suppose).

    The updater immediately presented me with six updates that installed ok. I will wait on Leap to see if the hourly three notifications appear again. After that I can test disabling the updater, etc.

    It doesn't help to have this unstable Plasma 5 system tray where icons disappear leaving blank spaces e.g in the case of KMix and other sound volume icon randomly appearing or not. Now KMix won't start and I have no volume icons in the tray (sound is ok though).
    Leap 42.3 (ext4, KDE Plasma 5.8.7) ~ stable
    Manjaro (ext4, Xfce) ~ rolling updates
    Tumbleweed (ext4, KDE Plasma5) ~ managed updates via "Tumbleweed Snapshots" service.

  10. #10

    Default Re: LEAP automatic software updater

    Quote Originally Posted by farcusnz View Post
    actually I don't think it can be disabled in the tray settings.
    Going to systray settings and unchecking "software updates" removes the icon but does not stop the popups from occurring hourly.
    Doesn't appear to be any setting within the updater itself to disable it - only to change the frequency (haven't checked to see if this works yet.)
    I get the same thing: Software Updates is unchecked in the systray settings. Icon no longer shows in the tray, but I'm still getting a more-or-less hourly notification that I have updates waiting.

    As for the frequency setting, I had it on "Daily", and judging by the occasional changes in the number of updates waiting, it's checking several times a day. I just now changed it to "Monthly" and will see if that makes any difference.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •