Results 1 to 2 of 2

Thread: Slow Printing speed in openSUSE 42.1 compared to Win 10

  1. #1
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Slow Printing speed in openSUSE 42.1 compared to Win 10

    Hi all
    I am getting very slow printing speed in openSUSE as compared to Win 10. After experimenting in openSUSE, I installed hplip and some how able to print the pages. But the speed is very slow as compared to Win. There is a blue colored icon 'hp' icon in the lower panel. Right clicking gives me an option of "HP Device Manager". Within this Device> 'Diagnose HPLIP Driver' opens hp-doctor.
    The output of hp-doctor is giving errors.

    Please guide me in this. What should I do now.

    Code:
    HP Linux Imaging and Printing System (ver. 3.14.6)
    Self Diagnse Utility and Healing Utility ver. 1.0
    
    Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
     
    
    Checking for Deprecated items....
    error: This distro (i.e suse  42.1) is either deprecated or not yet supported.
    The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y
    
    
    Checking for HPLIP updates....
    error: HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.
    
    Done.
    error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?
    
    
    Checking for Dependencies....
    warning: suse-42.1 version is not supported. Using suse-13.1 versions dependencies to verify and install...
    
    ---------------
    | SYSTEM INFO |
    ---------------
    
     Kernel: 4.1.12-1-default #1 SMP PREEMPT Thu Oct 29 06:43:42 UTC 2015 (e24bad1) GNU/Linux
     Host: linux-lfiu
     Proc: 4.1.12-1-default #1 SMP PREEMPT Thu Oct 29 06:43:42 UTC 2015 (e24bad1) GNU/Linux
     Distribution: suse 42.1
     Bitness: 64 bit
    
    
    -----------------------
    | HPLIP CONFIGURATION |
    -----------------------
    
    HPLIP-Version: HPLIP 3.14.6
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for suse distro  42.1 version 
    
    Current contents of '/etc/hp/hplip.conf' file:
    # hplip.conf.  Generated from hplip.conf.in by configure.
    
    [hplip]
    version=3.14.6
    
    [dirs]
    home=/usr/share/hplip
    run=/var/run
    ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
    ppdbase=/usr/share/cups/model/manufacturer-PPDs
    doc=/usr/share/doc/packages/hplip
    html==/usr/share/doc/packages/hplip
    icon=/usr/share/applications
    cupsbackend=/usr/lib/cups/backend
    cupsfilter=/usr/lib/cups/filter
    drv=/usr/lib/cups/driver
    bin=/usr/bin
    
    # Following values are determined at configure time and cannot be changed.
    [configure]
    network-build=yes
    libusb01-build=no
    pp-build=yes
    gui-build=yes
    scanner-build=yes
    fax-build=yes
    dbus-build=yes
    cups11-build=no
    doc-build=yes
    shadow-build=no
    hpijs-install=yes
    foomatic-drv-install=no
    foomatic-ppd-install=yes
    foomatic-rip-hplip-install=no
    hpcups-install=yes
    cups-drv-install=no
    cups-ppd-install=yes
    internal-tag=3.14.6
    restricted-build=no
    ui-toolkit=qt4
    qt3=no
    qt4=yes
    policy-kit=no
    lite-build=no
    udev_sysfs_rules=no
    hpcups-only-build=no
    hpijs-only-build=no
    
    
    Current contents of '/var/lib/hp/hplip.state' file:
    Plugins are not installed. Could not access file: No such file or directory
    
    Current contents of '~/.hplip/hplip.conf' file:
    [settings]
    systray_visible = 0
    systray_messages = 0
    
    [last_used]
    device_uri = 
    printer_name = 
    working_dir = .
    
    [commands]
    scan = 
    
    [refresh]
    rate = 30
    enable = true
    type = 1
    
    [polling]
    enable = false
    interval = 5
    device_list = 
    
    [fax]
    voice_phone = 
    email_address = 
    
    [upgrade]
    notify_upgrade = true
    last_upgraded_time = 1447680412.82345
    pending_upgrade_time = 0
    
    [installation]
    date_time = ���������������������: 16 ������������������ 2015 19:27:03
    version = 3.14.6
    
    
     <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
    
    --------------------------
    |  External Dependencies |
    --------------------------
    
     policykit            Admin-Policy-framework    OPTIONAL        -               0.113           OK         -
     gs                   Ghostscript               REQUIRED        7.05            9.15            OK         -
     network              Network-wget              OPTIONAL        -               1.14            OK         -
     scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.24          OK         -
     avahi-utils          avahi-utils               OPTIONAL        -               0.6.31          OK         -
     dbus                 DBus                      REQUIRED        -               1.8.16          OK         -
     cups                 CUPS                      REQUIRED        1.1             1.7.5           OK         'CUPS Scheduler is running'
     xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -
    
    -------------------------
    |  General Dependencies |
    -------------------------
    
     error: reportlab     Python-PDF-Lib            OPTIONAL        2.0             -               MISSING    'reportlab needs to be installed'
     libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
     pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
     pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.11.4          OK         -
     libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
     libpthread           POSIX-Threads-Lib         REQUIRED        -               2.19            OK         -
     python-dbus          Python-DBUS               REQUIRED        0.80.0          1.2.0           OK         -
     python-devel         Python-SDK                REQUIRED        2.2             2.7.9           OK         -
     pyqt4                Python-Qt4                REQUIRED        4.0             4.11.4          OK         -
     cups-devel           CUPS-SDK                  REQUIRED        -               1.7.5           OK         -
     sane-devel           SANE-SDK                  REQUIRED        -               1.0.24          OK         -
     libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
     sane                 Scan-Lib                  REQUIRED        -               1.0.24          OK         -
     cups-image           CUPS-Image-Lib            REQUIRED        -               1.7.5           OK         -
     libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.7.3           OK         -
     python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
     python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -
    
    ------------------------------
    |  Compile Time Dependencies |
    ------------------------------
    
     gcc                  gcc-Compiler              REQUIRED        -               4.8.5           OK         -
     libtool              Build-tools               REQUIRED        -               2.4.2           OK         -
     make                 GNU-Build-tools           REQUIRED        3.0             4.0             OK         -
    
    ----------------------
    |  Python Extentions |
    ----------------------
    
     cupsext              CUPS-Extension            REQUIRED        -               3.14.6          OK         -
     pcardext             PhotoCard-Extension       REQUIRED        -               3.14.6          OK         -
     hpmudext             IO-Extension              REQUIRED        -               3.14.6          OK         -
    
    -----------------------
    |  Scan Configuration |
    -----------------------
    
     hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.14.6          OK         'hpaio found in /etc/sane.d/dll.conf'
     scanext              Scan-SANE-Extension       REQUIRED        -               3.14.6          OK         -
    
    ------------------------------
    | DISCOVERED SCANNER DEVICES |
    ------------------------------
    
    device `hpaio:/usb/Deskjet_Ink_Adv_2060_K110?serial=CN11C33J0H05M9' is a Hewlett-Packard Deskjet_Ink_Adv_2060_K110 all-in-one
    
    
    --------------------------
    | DISCOVERED USB DEVICES |
    --------------------------
    
      Device URI                                            Model                       
      ----------------------------------------------------  ----------------------------
      hp:/usb/Deskjet_Ink_Adv_2060_K110?serial=CN11C33J0H0  HP Deskjet Ink Adv 2060 K110
      5M9                                                                               
    
    ---------------------------------
    | INSTALLED CUPS PRINTER QUEUES |
    ---------------------------------
    
     
    HP_Deskjet_Ink_Adv_2060_K110
    ----------------------------
    Type: Unknown
    Device URI: usb://HP/Deskjet%20Ink%20Adv%202060%20K110?serial=CN11C33J0H05M9&interface=1
    PPD: /etc/cups/ppd/HP_Deskjet_Ink_Adv_2060_K110.ppd
    PPD Description: HP Deskjet Ink Adv 2060 k110 hpijs, 3.14.6
    Printer status: printer HP_Deskjet_Ink_Adv_2060_K110 is idle.  enabled since ���������������������: 15 ������������������ 2015 09:30:42 ��������������������� IST
    warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
    
    
    --------------
    | PERMISSION |
    --------------
    
    USB             None                           Required        -        -        OK       Node:'/dev/bus/usb/001/030' Perm:'  root  lp rw- rw- rw- rw- r--'
     
    
    Checking Permissions....
    Permissions are correct.
    
    
    Checking for Configured Queues....
    warning: Device HP_Deskjet_Ink_Adv_2060_K110 is not HPLIP installed. Device must use the hp: or hpfax: to function in HPLIP.
    
    error: 'HP_Deskjet_Ink_Adv_2060_K110' is not configured using HPLIP. Need to remove and re-cofigure using hp-setup.
    Do you want to remove and re-configure? (y=yes*, n=no, q=quit) ? y
    
    
    You do not have permission to delete a printer. You need authentication.
    Username: yagya
    Password: 
    error: Could not connect to CUPS Server due to insufficient privileges.Try with valid user
    
    
    You do not have permission to delete a printer. You need authentication.
    Username:
    This is not accepting my username and password.

    Please guide.

  2. #2
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    438

    Default Re: Slow Printing speed in openSUSE 42.1 compared to Win 10

    It appears you need to be root to run hp-setup. Maybe a "sudo hp-setup" (without quotation marks) might help you.
    "Making rich people richer doesn't make the rest of us richer."
    Ha-Joon Chang

    openSUSE 15.0 4.12.14-lp150.12.45-default x64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •