Results 1 to 3 of 3

Thread: Baloo re-indexing ?

  1. #1

    Default Baloo re-indexing ?

    kde 4.14.10 (from kde sc current)

    i updated nepomuk-core-ffmpegindexer and kfilemetadata-ffmpgextractor fro wofi323 kde sc current for 13.1 , thanks to him , according to get duration and other details about movies . in dolphin data panel .

    but i must re-create the index according to record and display those additionnal properties .

    how to re-indexing my home or just one folder .

    i already tries this with no success :
    - uncheck "activate desktop search" then check "activate desktop search"
    - add a folder in exclude list then delete it in the exclude list

    but no re-indexing.

    i found this surfing internet :

    stop baloo service
    then
    delete ~/.local/share/baloo/file/
    then
    start baloo service
    then
    in a textconsole execute :

    qdbus org.kde.baloo.file /indexer updateAllFolders false

    can an expert confirm this ?

    thanks
    OpenSuse Argon 15.1 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, HP LaserJet 1220, Headset bluetooth 3.0 Philips SHQ7300

  2. #2

    Default Re: Baloo re-indexing ?

    Quote Originally Posted by promeneur View Post
    i already tries this with no success :
    - uncheck "activate desktop search" then check "activate desktop search"
    Did you click on OK or Apply in between?

    i found this surfing internet :

    stop baloo service
    then
    delete ~/.local/share/baloo/file/
    then
    start baloo service
    then
    in a textconsole execute :

    qdbus org.kde.baloo.file /indexer updateAllFolders false

    can an expert confirm this ?
    Should work.
    But the last step shouldn't be necessary.
    If you delete the index, Baloo will re-index everything automatically.

    But be aware that reindexing everything will take a while, especially if you have many (and/or large) files in your HOME folder.
    And Baloo will only index when the system is idle, and not running on battery (in the case of Laptops).
    Last edited by wolfi323; 09-Nov-2015 at 04:00.

  3. #3

    Default Re : Baloo re-indexing ?

    the method wich works :

    - quit kontact
    - with akonadi server manager stop akonadi server (akonadi server uses baloo)

    as root in text console

    balooctl stop

    as user with dolphin delete ~/local/share/balloo/file/ folder

    as root in text console

    balooctl start

    unactivate desktop search

    activate desktop search

    since 5 mn baloo is re-indexing

    thanks
    OpenSuse Argon 15.1 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, HP LaserJet 1220, Headset bluetooth 3.0 Philips SHQ7300

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •