Results 1 to 7 of 7

Thread: Audacity + LAME = no work

  1. #1

    Default Audacity + LAME = no work

    Installed Audacity; went to convert mp4 to mp3 and forgot it doesn't have that plugin compiled into it, so went and got LAME from the repo and installed it, but it seems Audacity still doesn't recognise LAME as a plugin by default; and it looks like you might have to point Audacity to see it....I think, through; Edit >> Preferences >> Libraries >> Locate. But there is no working /usr/lib64/libmp3lame.so.0 when you select it.

    What's the missing step?

    Thanks.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: audacity+ LAME = no work

    Quote Originally Posted by david_banner View Post
    Installed Audacity; went to convert mp4 to mp3 and forgot it doesn't have that plugin compiled into it, so went and got LAME from the repo and installed it, but it seems Audacity still doesn't recognise LAME as a plugin by default; and it looks like you might have to point Audacity to see it....I think, through; Edit >> Preferences >> Libraries >> Locate. But there is no working /usr/lib64/libmp3lame.so.0 when you select it.

    What's the missing step?

    Thanks.
    if you have lame you probably got packman's repo but from what repo is audacity as both packman and the oss have it
    http://packman.links2linux.org/package/audacity
    https://software.opensuse.org/package/audacity
    packman haven't updated their site for leap links so the only way to get audacity from packman is with zypper or yast, post
    Code:
    zypper lr -d
    as dup to packman might be needed

  3. #3

    Default Re: Audacity + LAME = no work

    Also check that you actually installed the package libmp3lame0, this is what contains /usr/lib64/libmp3lame.so.0.

  4. #4

    Default Re: Audacity + LAME = no work

    Code:
    me@linux-ql9m:~> zypper lr -d
    #  | Alias                           | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | amd-fglrx                       | amd-fglrx                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Leap_42.1/               |        
     2 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/        |        
     3 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                   |        
     4 | download.opensuse.org-oss       | Main Repository (DEBUG)                 | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/      |        
     5 | download.opensuse.org-oss_1     | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/            |        
     6 | download.opensuse.org-oss_2     | Main Repository (Sources)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/     |        
     7 | download.opensuse.org-oss_3     | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                        |        
     8 | openSUSE-42.1-0                 | openSUSE-42.1-0                         | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-ASUS_DRW-24F1ST_a_S13A68ED700CTM      |        
     9 | packman                         | packman                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/       |        
    10 | repo-debug-non-oss              | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/  |        
    11 | repo-debug-update               | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                  |                                           
    12 | repo-debug-update-non-oss       | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/             |                                           
    13 | repo-source                     | openSUSE-Leap-42.1-Source-Non-Oss       | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss/ |        
    14 | repo-update                     | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                       |        
    me@linux-ql9m:~>
    Thanks, I haven't got round to sorting the repos out yet as I just grabbed them all during installation.

    The LAME is from Packman. The Audacity 2.1.1-94.1 I had instaled was from Packman (links2linux.de) I think (I removed it but the radio button devualts to it in Yast). There is one other from OSS (2.1.1-32) and another from 'openSUSE 42.1-0'
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  5. #5

    Default Re: Audacity + LAME = no work

    Quote Originally Posted by wolfi323 View Post
    Also check that you actually installed the package libmp3lame0, this is what contains /usr/lib64/libmp3lame.so.0.
    yeah , came in with LAME by the looks of it
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Audacity + LAME = no work

    Quote Originally Posted by david_banner View Post
    yeah , came in with LAME by the looks of it
    do a dup with packman
    Code:
    sudo zypper dup --from 9
    as a dup from packman is really a necessity after an opensuse install

  7. #7

    Default Re: Audacity + LAME = no work

    Thanks, that seems to have done it, didn't know about that.

    Now to start a new thread about: KDEInit could not launch '/usr/lib64/libexec/kf5/kioexec'
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •