Results 1 to 10 of 10

Thread: GTK font rendering

  1. #1

    Default GTK font rendering

    Hi,

    I am using KDE 5 desktop. All fonts in GTK apps are not rendered with hinting and sub-pixel. I tried configuring font setting in Yast, but still no luck.
    QT apps are looking fine. I attach screenshot of Libreoffice Calc, Firefox and Dolphin.

    http://pasteboard.co/1YMzniGd.png

  2. #2

    Default Re: GTK font rendering

    I have the same problem. Anyone know the reason? sub-pixel rendering of Qt-based program works and it cannot be a problem of the FreeType.

  3. #3

    Default Re: GTK font rendering

    I think it's not a problem, but a 'feature'. This was once brought up on a blog by someone very particular about fonts. Apparently, openSUSE has subpixel rendering off by default.

    EDIT: GTK themes and fonts can be adjusted via the lxappearance app. It's normally part of the LXDE desktop environment, but can be installed separately for GTK handling.

  4. #4
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: GTK font rendering

    Make sure and configure the GTK font settings with:

    Configure Desktop > Application Style > GNOME Application Style (GTK)

    Also, out of patent concerns, the standard OpenSUSE font rendering does not include true subpixel hinting and which is most noticeable with GTK apps. Nevertheless, you can implement true subpixel hinting with repos such as the namtrac repo. You can read more about this here:

    https://forums.opensuse.org/showthre...ndering+patent

    The namtrac repo is available here:

    https://software.opensuse.org/downlo...kage=freetype2

    Also, I maintain my own font repo here:

    https://build.opensuse.org/project/show/home:gldickens3

    FYI,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  5. #5

    Default Re: GTK font rendering

    Quote Originally Posted by gldickens3 View Post
    Make sure and configure the GTK font settings with:

    Configure Desktop > Application Style > GNOME Application Style (GTK)

    Also, out of patent concerns, the standard OpenSUSE font rendering does not include true subpixel hinting and which is most noticeable with GTK apps. Nevertheless, you can implement true subpixel hinting with repos such as the namtrac repo. You can read more about this here:

    https://forums.opensuse.org/showthre...ndering+patent

    The namtrac repo is available here:

    https://software.opensuse.org/downlo...kage=freetype2

    Also, I maintain my own font repo here:

    https://build.opensuse.org/project/show/home:gldickens3

    FYI,

    Gordon
    Thanks! I tried the repo and it worked! I also downloaded and checked the source RPM of freetype2 of Leap 42.1. The subpixel rendering was clearly disabled because in the .spec file, it's written as
    Code:
    %define enable_subpixel_rendering 0
    I found an instruction (https://wiki.centos.org/HowTos/RebuildSRPM) and rebuilt/installed the rpm locally with
    Code:
    %define enable_subpixel_rendering 1
    and the results are the same as your repo. Therefore it seems that the "real" problem/feature is, why can subpixel-rendering be enabled in Qt5 applications while the options are disabled in freetype2 ? Qt5 implemented its own subpixel-rendering mechanism without the help of freetype2? It's might be a Qt5-only feature because there is no sub-pixel rendering in Qt4 applications with the shipped freetype2 from Leap 42.1 in my experiments.

  6. #6

    Thumbs up Re: GTK font rendering

    Quote Originally Posted by AndyMender View Post
    I think it's not a problem, but a 'feature'. This was once brought up on a blog by someone very particular about fonts. Apparently, openSUSE has subpixel rendering off by default.

    EDIT: GTK themes and fonts can be adjusted via the lxappearance app. It's normally part of the LXDE desktop environment, but can be installed separately for GTK handling.
    lxappearance works like a charm. Thanks!

  7. #7

    Default Re: GTK font rendering

    Quote Originally Posted by stecue View Post
    lxappearance works like a charm. Thanks!
    Well, I found that sometime and for some applications lxappearance won't work, but mate-appearance-properties works almost all the times. It is included in the mate-control-center and "mate-themes", "mate-settings-daemon" and "marco" might be needed as well.

    Just don't understand why the gtk applications won't simply honor the settings in ~/.fonts.conf or ~/.config/fontconfig/fonts.conf. It seems that there are so many config programs for gtk and they override each other's settings randomly.

  8. #8

    Default Re: GTK font rendering

    To solve the problem with font rendering you have to install freetype2 (libfreetype6) from "namtrac" repository" :

    Namtrac repo:

    https://build.opensuse.org/project/s...mtrac:subpixel

    This is not a bug in openSUSE 42.1, it is standard behaviour, because of patents. Interesting that other popular distros can deal with the problem out of the box!

    Now wait for KDE Plasma 5 to stop crashing and (at least Plasma 5.7 ?) and openSUSE 42.1 can be nice distro.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,400

    Default Re: GTK font rendering

    Quote Originally Posted by kacernator View Post
    Interesting that other popular distros can deal with the problem out of the box!
    I guess that the same reasoning applies as with the multi-media codecs. Other distros seem not to be too worried to get sueded. Probably because they have no money. But openSUSE is strongly related to partners that have money.
    Henk van Velden

  10. #10

    Default Re: GTK font rendering

    Quote Originally Posted by hcvv View Post
    I guess that the same reasoning applies as with the multi-media codecs. Other distros seem not to be too worried to get sueded. Probably because they have no money. But openSUSE is strongly related to partners that have money.
    I understand that. But it would be nice, that user gets notified about the issue after install or after first boot. And provide possible solution to the problem. Better to make fonts look good manually than looking at horrible fonts for 6 months.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •