Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

  1. #1

    Default Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Hi. I am using opensuse 42.1. Having a devil of a time getting spotify to work. On most distros, I can either find it in a community repo or find a package I can install. I would be a very happy man if someone could show me how to get spotify working on openSUSE leap.

  2. #2
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    198

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by nbobbis View Post
    Hi. I am using opensuse 42.1. Having a devil of a time getting spotify to work. On most distros, I can either find it in a community repo or find a package I can install. I would be a very happy man if someone could show me how to get spotify working on openSUSE leap.
    Still not working here so far, since Leap is still relatively new I am sure they'll fix it
    Code:
    libgcrypt selftest: binary  (0): Selftest failed (/usr/lib64/.libgcrypt.so.11.hmac)Ohhhh jeeee: ... this is a bug (global.c:137:global_init)
    /usr/bin/spotify: line 11: 25387 Aborted LD_LIBRARY_PATH=/opt/spotify/spotify-client/lib ./spotify "$@"
    Intel G2020 (Ivy), Asus P8H77-M LE, Tumbleweed, Gnome 3.24 on 120GB SSD
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Tumbleweed, Gnome 3.24 on 120GB SSD

  3. #3

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Hi there!.

    I'm on the same problem with the Spotify client and Leap 42.1. I hope soon there will be a fix...

    Regards.

  4. #4

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Hey again, Friends!.

    Working on it, i found a provisional solution: install the package libgcrypt11 but not from the leap 42.1 repositories. Install the package from the 13.2 distribution. You can download it from here:

    https://software.opensuse.org/package/libgcrypt11

    Remember, choose the package from 13.2, not from Leap 42.1. You can install it from the command line with this instruction:

    # rpm -i --nodeps libgcrypt11-1.5.4-2.1.x86_64.rpm

    I hope this will be useful.

    Regards.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,509
    Blog Entries
    14

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Did this ( NB. Packman repo must be enabled ):
    Code:
    sudo zypper in spotify-installer
    next, as ordinary user:
    Code:
    install-spotiry
    after which
    Code:
    /usr/bin/spotify
    works as expected. You'll see that the proper libgcrypt will be included.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    198

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by jlas9 View Post
    Hey again, Friends!.

    Working on it, i found a provisional solution: install the package libgcrypt11 but not from the leap 42.1 repositories. Install the package from the 13.2 distribution. You can download it from here:

    https://software.opensuse.org/package/libgcrypt11

    Remember, choose the package from 13.2, not from Leap 42.1. You can install it from the command line with this instruction:

    # rpm -i --nodeps libgcrypt11-1.5.4-2.1.x86_64.rpm

    I hope this will be useful.

    Regards.
    ahh.. no wonder, now I am getting mine working. Knurpht's repo is a saviour Thanks
    Intel G2020 (Ivy), Asus P8H77-M LE, Tumbleweed, Gnome 3.24 on 120GB SSD
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Tumbleweed, Gnome 3.24 on 120GB SSD

  7. #7

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by powerw00t View Post
    ahh.. no wonder, now I am getting mine working. Knurpht's repo is a saviour Thanks
    How did you do so? I installed the package he said, but still getting dependencies error

  8. #8
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    198

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by axelms View Post
    How did you do so? I installed the package he said, but still getting dependencies error
    what dependencies error when you type spotify from the terminal?
    Intel G2020 (Ivy), Asus P8H77-M LE, Tumbleweed, Gnome 3.24 on 120GB SSD
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Tumbleweed, Gnome 3.24 on 120GB SSD

  9. #9

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by powerw00t View Post
    what dependencies error when you type spotify from the terminal?

    error: Error de dependencias:
    libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64
    libcurl.so.4(CURL_OPENSSL_3)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64
    libssl.so.1.0.0(OPENSSL_1.0.0)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64

  10. #10
    Join Date
    Jul 2010
    Location
    Malaysia +8 GMT
    Posts
    198

    Default Re: Has anyone been able to get spotify to work on opensuse (wine or otherwise)

    Quote Originally Posted by axelms View Post
    error: Error de dependencias:
    libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64
    libcurl.so.4(CURL_OPENSSL_3)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64
    libssl.so.1.0.0(OPENSSL_1.0.0)(64bit) es necesario por spotify-client-1.0.17.75.g8f111100-2.x86_64
    This is strange, my installation only lacked of libgrypt11 and not the others, I believe you can search the missing libs from the OBS.
    Intel G2020 (Ivy), Asus P8H77-M LE, Tumbleweed, Gnome 3.24 on 120GB SSD
    Intel i5 4590 (Haswell), MSI B85M-G43, MSI GTX750Ti, Tumbleweed, Gnome 3.24 on 120GB SSD

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •