Results 1 to 2 of 2

Thread: Bluetooth not working

  1. #1

    Exclamation Bluetooth not working

    I don't know how long this have been happening, but I noticed a couple days ago so I decided today to fix it so any help would be appreciated
    Whenever my laptop is booting, it says it couldn't load bluetooh and the bluetooh settings says there are no dongles found. However I do have an internal bluetooth card on my laptop, it's just the driver fails to load. Here's a copy of dmesg:

    Code:
    jc@linux-p4b9:~> dmesg | grep Bluetooth
    [    3.745119] Bluetooth: Core ver 2.20
    [    3.745136] Bluetooth: HCI device and connection manager initialized
    [    3.745139] Bluetooth: HCI socket layer initialized
    [    3.745141] Bluetooth: L2CAP socket layer initialized
    [    3.745146] Bluetooth: SCO socket layer initialized
    [    3.791250] Bluetooth: Patch file not found ar3k/AthrBT_0x00000200.dfu
    [    3.791285] Bluetooth: Loading patch file failed
    [   16.031994] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   16.031997] Bluetooth: BNEP filters: protocol multicast
    [   16.032001] Bluetooth: BNEP socket layer initialized
    rfkill doesn't even list the Bluetooth device, however YaST hardware information does show the device under Bluetooth category

    Code:
    44: USB 00.0: 11500 Bluetooth Device
      [Created at usb.122]
      Unique ID: dwDZ.tx4ZIeIPK4B
      Parent ID: ADDn.e2H5vPw9ceD
      SysFS ID: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0
      SysFS BusID: 1-1.3:1.0
      Hardware Class: bluetooth
      Model: "Atheros AR3012 Bluetooth 4.0"
      Hotplug: USB
      Vendor: usb 0x0cf3 "Atheros Communications, Inc."
      Device: usb 0x3004 "AR3012 Bluetooth 4.0"
      Revision: "0.01"
      Speed: 12 Mbps
      Module Alias: "usb:v0CF3p3004d0001dcE0dsc01dp01icE0isc01ip01in00"
      Driver Info #0:
        Driver Status: ath3k is active
        Driver Activation Cmd: "modprobe ath3k"
      Driver Info #1:
        Driver Status: btusb is active
        Driver Activation Cmd: "modprobe btusb"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #52 (Hub)
    I think the problem is around the "Patch file not found ar3k/AthrBT_0x00000200.dfu" and the fact bluetooth uses ath3k may be conflicting with the ath10k required for my wireless card maybe? If that's the problem I'm confused and I don't know what to do next, any help would be appreciated

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,149
    Blog Entries
    15

    Default Re: Bluetooth not working

    On Sat 07 Nov 2015 11:06:02 AM CST, SUSEpotato wrote:

    I don't know how long this have been happening, but I noticed a couple
    days ago so I decided today to fix it so any help would be appreciated

    Whenever my laptop is booting, it says it couldn't load bluetooh and the
    bluetooh settings says there are no dongles found. However I do have an
    internal bluetooth card on my laptop, it's just the driver fails to
    load. Here's a copy of dmesg:


    Code:
    --------------------

    jc@linux-p4b9:~> dmesg | grep Bluetooth
    [ 3.745119] Bluetooth: Core ver 2.20
    [ 3.745136] Bluetooth: HCI device and connection manager
    initialized [ 3.745139] Bluetooth: HCI socket layer initialized
    [ 3.745141] Bluetooth: L2CAP socket layer initialized
    [ 3.745146] Bluetooth: SCO socket layer initialized
    [ 3.791250] Bluetooth: Patch file not found
    ar3k/AthrBT_0x00000200.dfu [ 3.791285] Bluetooth: Loading patch file
    failed [ 16.031994] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 16.031997] Bluetooth: BNEP filters: protocol multicast
    [ 16.032001] Bluetooth: BNEP socket layer initialized

    --------------------


    rfkill doesn't even list the Bluetooth device, however YaST hardware
    information does show the device under Bluetooth category


    Code:
    --------------------

    44: USB 00.0: 11500 Bluetooth Device
    [Created at usb.122]
    Unique ID: dwDZ.tx4ZIeIPK4B
    Parent ID: ADDn.e2H5vPw9ceD
    SysFS ID: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0
    SysFS BusID: 1-1.3:1.0
    Hardware Class: bluetooth
    Model: "Atheros AR3012 Bluetooth 4.0"
    Hotplug: USB
    Vendor: usb 0x0cf3 "Atheros Communications, Inc."
    Device: usb 0x3004 "AR3012 Bluetooth 4.0"
    Revision: "0.01"
    Speed: 12 Mbps
    Module Alias: "usb:v0CF3p3004d0001dcE0dsc01dp01icE0isc01ip01in00"
    Driver Info #0:
    Driver Status: ath3k is active
    Driver Activation Cmd: "modprobe ath3k"
    Driver Info #1:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #52 (Hub)

    --------------------


    I think the problem is around the "Patch file not found
    ar3k/AthrBT_0x00000200.dfu" and the fact bluetooth uses ath3k may be
    conflicting with the ath10k required for my wireless card maybe? If
    that's the problem I'm confused and I don't know what to do next, any
    help would be appreciated

    Thanks!


    Hi
    Is the kernel-firmware package installed/updated?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •