Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: update doesn't work

  1. #1
    Join Date
    Nov 2015
    Posts
    14

    Exclamation update doesn't work

    Hello everyone, I've no idea why, but my suse isn't checking for updates :/
    it gives me such error.



    Please help

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: update doesn't work

    Well, and what about your network?
    Henk van Velden

  3. #3
    Join Date
    Nov 2015
    Posts
    14

    Default Re: update doesn't work

    Quote Originally Posted by hcvv View Post
    Well, and what about your network?
    Thank you for replly
    Sorry but what do you mean network ?
    internet is working, it is visible on the screen. or you mean something else ?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: update doesn't work

    Quote Originally Posted by Eru View Post
    Thank you for replly
    Sorry but what do you mean network ?
    internet is working, it is visible on the screen. or you mean something else ?
    Well, the application (which one btw?) says "Network is offline". The first action then is mostly to check that. And either post here prove that it is indeed not online (and then change your question to something like: My network is not online and I do not know how to cure that), or you prove it is online. Which helps others in assessing your problem.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,495
    Blog Entries
    2

    Default Re: update doesn't work

    Verify your networking is working for others...
    Post the results of your DG and ping it...
    Code:
    ip route
    ping result_of_above
    You might also try running the following which updates your system using the command line
    Code:
    zypper up
    You should also post which Desktop you are using (KDE?)

    TSU

  6. #6
    Join Date
    Nov 2015
    Posts
    14

    Default Re: update doesn't work

    Thank you for reply

    Quote Originally Posted by tsu2 View Post
    Verify your networking is working for others...
    Post the results of your DG and ping it...
    Code:
    ip route
    ping result_of_above
    I did what you sad and got this
    Code:
    eru@linux-npoo:~> ip route
    default via 192.168.0.1 dev wlan0  proto static  metric 600 
    192.168.0.0/24 dev wlan0  proto kernel  scope link  src 192.168.0.104  metric 600 
    eru@linux-npoo:~> ping 192.168.0.1
    PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
    64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=1.80 ms
    64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=1.36 ms
    64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=1.64 ms
    64 bytes from 192.168.0.1: icmp_seq=4 ttl=64 time=1.64 ms
    64 bytes from 192.168.0.1: icmp_seq=5 ttl=64 time=2.61 ms
    64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=4.19 ms
    64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=1.80 ms
    64 bytes from 192.168.0.1: icmp_seq=8 ttl=64 time=1.68 ms
    64 bytes from 192.168.0.1: icmp_seq=9 ttl=64 time=1.70 ms
    ^C
    Quote Originally Posted by tsu2 View Post
    You might also try running the following which updates your system using the command line
    Code:
    zypper up
    That worked fine, but I prefer to check system itself for updates, this will be backup plan

    Quote Originally Posted by tsu2 View Post
    You should also post which Desktop you are using (KDE?)

    TSU
    Yes I'm using KDE plasma5

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,568

    Default Re: update doesn't work

    I saw this when I first installed Leap 42.1 KDE.
    It was fixed up with a reboot after enabling wifi connection for the first time. I think I may also have had to remove the DVD installation media from the repository list.

    Also - are you operating on battery or power? By default the updater is disable when on battery. In updater settings you can set it to check for updates even when the power is unplugged.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: update doesn't work

    Quote Originally Posted by Eru View Post

    That worked fine, but I prefer to check system itself for updates, this will be backup plan
    As you saw, your network is not offline, you can ping your router.

    As you also saw the system can reach the internet (and run updates from the repos) because you say (but do not show, thus we have to believe you) that zypper up functioned as expected.

    That means that that application is talking nonsense by saying "Network is offline", because it isn't. Thus we have to concentrate on that application. Which application is it that shows you that black window with the silly message?
    Henk van Velden

  9. #9
    Join Date
    Nov 2015
    Posts
    14

    Default Re: update doesn't work

    Quote Originally Posted by farcusnz View Post
    I saw this when I first installed Leap 42.1 KDE.
    It was fixed up with a reboot after enabling wifi connection for the first time. I think I may also have had to remove the DVD installation media from the repository list.

    Also - are you operating on battery or power? By default the updater is disable when on battery. In updater settings you can set it to check for updates even when the power is unplugged.
    )
    it is on power. I even checked to update on battery box, nothing changed.

    Quote Originally Posted by hcvv View Post
    As you saw, your network is not offline, you can ping your router.

    As you also saw the system can reach the internet (and run updates from the repos) because you say (but do not show, thus we have to believe you) that zypper up functioned as expected.

    That means that that application is talking nonsense by saying "Network is offline", because it isn't. Thus we have to concentrate on that application. Which application is it that shows you that black window with the silly message?
    That window pop ups when I click on update icon.
    here is my update log, sorry.

    Code:
    eru@linux-npoo:~> sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following 102 package updates will NOT be installed:
      alsa-oss amarok amarok-lang cdrdao cdrecord dvd+rw-tools esound-daemon fdupes ffmpeg
      gdk-pixbuf-loader-libopenraw genisoimage gstreamer gstreamer-0_10 gstreamer-0_10-lang
      gstreamer-0_10-plugin-esd gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang
      gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang gstreamer-lang
      gstreamer-plugins-bad gstreamer-plugins-base-lang gstreamer-plugins-good
      gstreamer-plugins-good-lang gstreamer-plugins-ugly libao4 libao-plugins4 libaudiofile1
      libburn4 libcdda_interface0 libcdda_paranoia0 libcdio16 libcdio_cdda2 libcdio_paranoia2
      libcelt0-2 libdc1394-22 libdiscid0 libdv4 libdvdread4 libesd0 libfftw3-3 libFLAC++6
      libFLAC8 libGLEW1_13 libgpod4 libgpod-lang libgpod-tools libgsm1 libgstapp-0_10-0
      libgstinterfaces-0_10-0 libgstphotography-1_0-0 libgstreamer-0_10-0 libgstreamer-1_0-0
      libiso9660-10 libisoburn1 libisofs6 libjack0 libkate1 liblcms1 liblcms2-2 liblcms-devel
      libmatroska6 libmjpegutils-2_0-0 libmpcdec5 libmusicbrainz5-1 libogg0 liboggkate1
      libopenraw1 liborc-0_4-0 libquicktime0 libraptor2-0 librasqal3 libraw1394-11 libsbc1
      libscg1_0 libschily1_0 libschroedinger-1_0-0 libsox3 libsoxr0 libspeex1 libspeexdsp1
      libstreamanalyzer0 libtag1 libtag_c0 libtheoradec1 libtheoraenc1 libvcdinfo0
      libvigraimpex5 libvorbis0 libvorbisenc2 libvorbisfile3 libwavpack1
      libwebrtc_audio_processing0 mjpegtools mkisofs pulseaudio-lang sbc sox taglib vcdimager
      vorbis-tools vorbis-tools-lang
    
    The following 17 packages are going to be upgraded:
      k3b k3b-codecs k3b-lang libasound2-32bit libavcodec56 libavdevice56 libavfilter5
      libavformat56 libavresample2 libavutil54 libcaca0 libenca0 libpostproc53 libpulse0-32bit
      libsndfile1-32bit libswresample1 libswscale3
    
    17 packages to upgrade.
    Overall download size: 14.0 MiB. Already cached: 0 B. After the operation, 437.2 KiB will be
    freed.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package libavutil54-2.8.1-25.1.x86_64      (1/17), 135.9 KiB (314.8 KiB unpacked)
    Retrieving: libavutil54-2.8.1-25.1.x86_64.rpm ........................................[done]
    Retrieving package libcaca0-0.99.beta19-56.30.x86_64  (2/17), 312.8 KiB (  1.5 MiB unpacked)
    Retrieving: libcaca0-0.99.beta19-56.30.x86_64.rpm ......................[done (123.8 KiB/s)]
    Retrieving package libenca0-1.16-38.1.x86_64          (3/17),  57.2 KiB (222.7 KiB unpacked)
    Retrieving: libenca0-1.16-38.1.x86_64.rpm ............................................[done]
    Retrieving package libasound2-32bit-1.1.0-228.1.x86_64
                                                         (4/17), 345.3 KiB (1010.7 KiB unpacked)
    Retrieving: libasound2-32bit-1.1.0-228.1.x86_64.rpm ..................................[done]
    Retrieving package libsndfile1-32bit-1.0.25-71.1.x86_64
                                                          (5/17), 146.8 KiB (450.7 KiB unpacked)
    Retrieving: libsndfile1-32bit-1.0.25-71.1.x86_64.rpm .................................[done]
    Retrieving package libswscale3-2.8.1-25.1.x86_64      (6/17), 130.7 KiB (502.4 KiB unpacked)
    Retrieving: libswscale3-2.8.1-25.1.x86_64.rpm ........................................[done]
    Retrieving package libswresample1-2.8.1-25.1.x86_64   (7/17),  42.8 KiB (102.4 KiB unpacked)
    Retrieving: libswresample1-2.8.1-25.1.x86_64.rpm .....................................[done]
    Retrieving package libpostproc53-2.8.1-25.1.x86_64    (8/17),  45.8 KiB (118.3 KiB unpacked)
    Retrieving: libpostproc53-2.8.1-25.1.x86_64.rpm ......................................[done]
    Retrieving package libavresample2-2.8.1-25.1.x86_64   (9/17),  44.7 KiB (122.4 KiB unpacked)
    Retrieving: libavresample2-2.8.1-25.1.x86_64.rpm .....................................[done]
    Retrieving package libpulse0-32bit-7.1-3.2.x86_64    (10/17), 242.4 KiB (857.5 KiB unpacked)
    Retrieving: libpulse0-32bit-7.1-3.2.x86_64.rpm .......................................[done]
    Retrieving package libavcodec56-2.8.1-25.1.x86_64    (11/17),   1.3 MiB (  4.6 MiB unpacked)
    Retrieving: libavcodec56-2.8.1-25.1.x86_64.rpm ...........................[done (2.3 MiB/s)]
    Retrieving package libavformat56-2.8.1-25.1.x86_64   (12/17), 312.3 KiB (770.7 KiB unpacked)
    Retrieving: libavformat56-2.8.1-25.1.x86_64.rpm ......................................[done]
    Retrieving package libavfilter5-2.8.1-25.1.x86_64    (13/17), 456.3 KiB (  1.4 MiB unpacked)
    Retrieving: libavfilter5-2.8.1-25.1.x86_64.rpm .........................[done (557.0 KiB/s)]
    Retrieving package libavdevice56-2.8.1-25.1.x86_64   (14/17),  51.5 KiB (127.9 KiB unpacked)
    Retrieving: libavdevice56-2.8.1-25.1.x86_64.rpm ......................................[done]
    Retrieving package k3b-2.0.80+git20151026.2112-6.1.x86_64
                                                         (15/17),   6.5 MiB ( 14.3 MiB unpacked)
    Retrieving: k3b-2.0.80+git20151026.2112-6.1.x86_64.rpm ...................[done (1.1 MiB/s)]
    Retrieving package k3b-lang-2.0.80+git20151026.2112-6.1.noarch
                                                         (16/17),   3.9 MiB ( 15.8 MiB unpacked)
    Retrieving: k3b-lang-2.0.80+git20151026.2112-6.1.noarch.rpm ..............[done (1.8 MiB/s)]
    Retrieving package k3b-codecs-2.0.80+git20151026.2112-6.1.x86_64
                                                         (17/17),  50.8 KiB (182.3 KiB unpacked)
    Retrieving: k3b-codecs-2.0.80+git20151026.2112-6.1.x86_64.rpm ........................[done]
    Checking for file conflicts: .........................................................[done]
    ( 1/17) Installing: libavutil54-2.8.1-25.1 ...........................................[done]
    ( 2/17) Installing: libcaca0-0.99.beta19-56.30 .......................................[done]
    ( 3/17) Installing: libenca0-1.16-38.1 ...............................................[done]
    ( 4/17) Installing: libasound2-32bit-1.1.0-228.1 .....................................[done]
    ( 5/17) Installing: libsndfile1-32bit-1.0.25-71.1 ....................................[done]
    ( 6/17) Installing: libswscale3-2.8.1-25.1 ...........................................[done]
    ( 7/17) Installing: libswresample1-2.8.1-25.1 ........................................[done]
    ( 8/17) Installing: libpostproc53-2.8.1-25.1 .........................................[done]
    ( 9/17) Installing: libavresample2-2.8.1-25.1 ........................................[done]
    (10/17) Installing: libpulse0-32bit-7.1-3.2 ..........................................[done]
    (11/17) Installing: libavcodec56-2.8.1-25.1 ..........................................[done]
    (12/17) Installing: libavformat56-2.8.1-25.1 .........................................[done]
    (13/17) Installing: libavfilter5-2.8.1-25.1 ..........................................[done]
    (14/17) Installing: libavdevice56-2.8.1-25.1 .........................................[done]
    (15/17) Installing: k3b-2.0.80+git20151026.2112-6.1 ..................................[done]
    (16/17) Installing: k3b-lang-2.0.80+git20151026.2112-6.1 .............................[done]
    (17/17) Installing: k3b-codecs-2.0.80+git20151026.2112-6.1 ...........................[done]
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.

  10. #10

    Default Re: update doesn't work

    Hello. I had the same problem, and it looks like plasma5 updater needs an already running connection when it starts. Whenever I connect manually updater says I still am offline. But enabling an option to connect automatically gets it work ok. I mean, set the connection to start automatically, log off or restart X and voila.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •