Results 1 to 10 of 10

Thread: Shutter needs perl repo which wasn't found by the package search suse website

  1. #1
    Join Date
    Apr 2015
    Location
    Washington State
    Posts
    14

    Question Shutter needs perl repo which wasn't found by the package search suse website

    Using Tumbleweed, Was installing latest shutter from the X11:Utilities repo and it required perl2-gnome, which cant be found for tumbleweed via the package search website.
    I had to go manually find the tumbleweed repo, if you searched the directories @ at opensuse.org/repositories/devel/languages/perl/OpenSUSE_Tumbleweed

    Not sure how I open this as a bug, this should be an easier experience for users to find this software and its dependencies.

    Doing a zypper info --requires shutter, then seeing it needs perl-gnome2 then searching package website for perl-gnome2, then only finding leap and 13.2 not tumbleweed repo, but it did exist. Seems like an issue.

    Any thoughts on this from the suse experts.

    Thanks,
    -Brook


  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    try this
    https://software.opensuse.org/package/perl-Gnome2
    perl-Gnome2 seams to be part of the official distribution
    maybe you need to update your distribution

  3. #3
    Join Date
    Apr 2015
    Location
    Washington State
    Posts
    14

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    Quote Originally Posted by I_A View Post
    try this
    https://software.opensuse.org/package/perl-Gnome2
    perl-Gnome2 seams to be part of the official distribution
    maybe you need to update your distribution
    I have that repo installed, the perl-Gnome2 isnt actually there.

    http://download.opensuse.org/tumblew...s/suse/x86_64/ has only two files

    perl-Gnome2-GConf-1.044-13.4.x86_64.rpm 25-Aug-2015 13:27 68K Details
    perl-Gnome2-VFS-1.082-3.5.x86_64.rpm 08-Oct-2015 09:04 163K Details

    http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Tumbleweed/x86_64/ has all the files.

    perl-Gnome2-1.046-1.8.x86_64.rpm 19-Oct-2015 06:44 239K Details <-- this is the file I needed.
    perl-Gnome2-Canvas-1.002-8.8.x86_64.rpm 19-Oct-2015 01:27 78K Details
    perl-Gnome2-GConf-1.044-20.40.x86_64.rpm 19-Oct-2015 05:17 69K Details
    perl-Gnome2-VFS-1.082-22.44.x86_64.rpm 01-Nov-2015 03:35 168K Details
    perl-Gnome2-Vte-0.11-1.80.x86_64.rpm 30-Oct-2014 06:42 26K Details
    perl-Gnome2-Vte-devel-0.11-1.80.x86_64.rpm 30-Oct-2014 06:42 31K Details
    perl-Gnome2-Wnck-0.16-1.21.x86_64.rpm 19-Oct-2015 05:57 74K Details

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website


  5. #5
    Join Date
    Apr 2015
    Location
    Washington State
    Posts
    14

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website


  6. #6

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    Any luck yet with installing Shutter on Thumbleweed?

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,065

    Default AW: Shutter needs perl repo which wasn't found by the package search suse website

    Build it by yourself, needed packages are in my Repo:
    https://build.opensuse.org/project/show/home:Sauerland

    But you can also use spectacle which replaced ksnapshot.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,211
    Blog Entries
    15

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    Quote Originally Posted by Calinush View Post
    Any luck yet with installing Shutter on Thumbleweed?
    Hi
    At the moment perl-Gtk2-unique has not made it to Tumbleweed, hence shutter won't either...

    Works here with Tumbleweed, shutter from X11:Utilities and perl-Gtk2-unique from devel:languageserl

    [/CODE]
    wget -c http://download.opensuse.org/reposit...3.3.noarch.rpm
    wget -c http://download.opensuse.org/reposit...3.3.noarch.rpm
    wget -c http://download.opensuse.org/reposit...6.1.x86_64.rpm
    su -
    cd <download location for above files>
    zypper in shutter-0.93.1-63.3.noarch.rpm shutter-lang-0.93.1-63.3.noarch.rpm perl-Gtk2-Unique-0.05-6.1.x86_64.rpm
    [/CODE]
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,463
    Blog Entries
    2

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    Unless a package manifest is just plain broken,
    IMO it should be general knowledge that the special repo for that particular language (Perl in your case) should be installed.

    I've mentioned it many times in the Forums, and also in various Wiki pages I've created (the following describes this principle installing Ruby)
    https://en.opensuse.org/User:Tsu2/In...nstall_Ruby.3F
    and nodejs
    https://en.opensuse.org/User:Tsu2/nodejs#Using_nodeenv

    but the same conditions apply to other languages...
    - A library file or dependency is missing
    - You need later versions than what is in the main repos
    - You are either Developing or are building a very large application which requires recent versions of dependencies.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,211
    Blog Entries
    15

    Default Re: Shutter needs perl repo which wasn't found by the package search suse website

    Quote Originally Posted by tsu2 View Post
    Unless a package manifest is just plain broken,
    IMO it should be general knowledge that the special repo for that particular language (Perl in your case) should be installed.

    I've mentioned it many times in the Forums, and also in various Wiki pages I've created (the following describes this principle installing Ruby)
    https://en.opensuse.org/User:Tsu2/In...nstall_Ruby.3F
    and nodejs
    https://en.opensuse.org/User:Tsu2/nodejs#Using_nodeenv

    but the same conditions apply to other languages...
    - A library file or dependency is missing
    - You need later versions than what is in the main repos
    - You are either Developing or are building a very large application which requires recent versions of dependencies.

    TSU
    Hi
    In this case I think it's little different, shutter is/was part of Tumbleweed, in this case because perl-Gtk2-unique is required, this dependency has not made it to Tumbleweed (awaiting submit request to be accepted since 2 weeks ago) so shutter is not present in Tumbleweed, it will arrive once the perl package is accepted... My post was just a workaround....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •