Results 1 to 3 of 3

Thread: How to change lp command font

  1. #1

    Default How to change lp command font

    I have a Brother HL printer connected to a USB port. I'm printing a plain text file, no graphics.

    How do I change the font on the lp command?

    I've tried creating my own pcl file, called myfile.pcl with

    Some text lines...
    I used an editor that allows me to put x'1B' for the Esc character. Then I copied it with

    cat myfile.pcl > /dev/usb/lp0
    No joy.

    I tried

    lp -oraw myfile.pcl
    Nothing prints. If I leave off the -oraw it prints, but none of the pcl commands take effect.

    How can I change the font of the lp command?

  2. #2
    Join Date
    Jun 2008

    Default Re: How to change lp command font

    You filled in OTHER VERSION for the openSUSE version you use when you started this thread. The fact that we have such an entry to be filled in (as first and thus important item) shows imho that we are interested in what version you use. Thus when you have anOTHER VERSION then the options shown there, it is even more important that you tell which one.

    So please: which version of openSUSE are yo using?
    Henk van Velden

  3. #3

    Default Re: How to change lp command font

    I'm using 12.2 because bugzilla 810127 Starting YaST2 hangs is never going to get fixed. Sad.

    I tried to just print a plain file, and that doesn't work either.

    cat /etc/inittab >/dev/usb/lp0
    That just prints a blank page. And,

    cat -v /etc/inittab >/dev/usb/lp0
    prints two blank pages.

    I've even tried

    dd if=/etc/inittab of=/dev/usb/lp0
    Again, two blank pages.

    When I use the lp command, everything prints. But the escape characters don't seem to go through. Even with -oraw.

    BTW, its a Brother HL-2140.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts