Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to disable/mute event sounds?

  1. #1

    Default How to disable/mute event sounds?

    Trying to figure out where the proper place to disable or lower volume for event sounds is located? Leap 42.1 KDE user here, and trying to lower volume from lower taskbar doesn't seem to "stick" / work, I pull the tick down to bottom or click on speaker icon to disable it/mute it, and it doesn't "stick". It keeps going back up to full volume again...I right click on speaker icon, and choose "muted", and it doesn't check the box and make it "stick" / muted option enabled. Something isn't right here, and not sure where else to disable/mute it at?

  2. #2

    Default Re: How to disable/mute event sounds?

    That's the *master* volume.
    And PulseAudio by default likes to manage that itself and basically ignore what you set.

    You have two options:
    - To just turn off event sounds, run KMix (you probably have to install that first), its volume control has a dedicated "Event sounds" volume slider which you could drag down. Maybe there's a similar option in KDE's (now) default volume control applet, I'm not sure at the moment, try to right-click on it and choose "Volume Control Settings".
    - set "flat-volumes = no" in /etc/pulse/daemon.conf. This will force PulseAudio to not modify the master volume, so if you mute it, it stays muted.

  3. #3

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by wolfi323 View Post
    That's the *master* volume.
    And PulseAudio by default likes to manage that itself and basically ignore what you set.

    You have two options:
    - To just turn off event sounds, run KMix (you probably have to install that first), its volume control has a dedicated "Event sounds" volume slider which you could drag down. Maybe there's a similar option in KDE's (now) default volume control applet, I'm not sure at the moment, try to right-click on it and choose "Volume Control Settings".
    - set "flat-volumes = no" in /etc/pulse/daemon.conf. This will force PulseAudio to not modify the master volume, so if you mute it, it stays muted.
    So much work for something that shouldn't be so difficult to change with controllers installed by default lol. I'll have to try some stuff you suggested then, cause currently after fresh installation, I'm not even seeing the "Event Sounds" in the taskbar for speaker volume now, where it had been displayed before lol. Hmm..

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,789

    Default Re: How to disable/mute event sounds?

    Install pavulcontrol program it is much easer to use then kmix or/and you can install veromix which can live in the system tray. Any allows you to control each applications volume independent of any other app.

  5. #5

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by gogalthorp View Post
    Install pavulcontrol program it is much easer to use then kmix or/and you can install veromix which can live in the system tray. Any allows you to control each applications volume independent of any other app.
    Thanks Gogalthorp, will try one of those!

    Edit: Veromix doesn't appear to be released for Leap yet for one click installer, but first one suggested seems to have one click installer for Leap. I tried searching for both in Software Management and didn't show any results for either, weird lol

    Edit 2: Not sure where it's located? pavulcontrol, but can't seem to find for event sounds either any where... searching for "pavulcontrol" in menu search don't bring results.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,789

    Default Re: How to disable/mute event sounds?

    typo sorry is pavucontrol

    Should be available

    not sure about veromix in 42.1 but the full package name is plasmoid-veromix

    But the kmix in 42.1 seems to be improved from 13.2

  7. #7

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by gogalthorp View Post
    typo sorry is pavucontrol

    Should be available
    Ah okay, yeah, I searched google and found this one and installed it: https://software.opensuse.org/package/pavucontrol but searching in menu search for correct spelling one still don't show anything. I'll try searching in software manager once though, and see if it's showing up, and maybe reinstall from software manager instead of one click installer.

    Edit: When I open that up, it doesn't list "Event Sounds" in there either...? Lol.

    Quote Originally Posted by gogalthorp View Post
    not sure about veromix in 42.1 but the full package name is plasmoid-veromix
    Ok, I'll try searching software manager for that as well, cause after googling, the one here doesn't seem to list Tumbelweed nor Leap for compatibility, just opensuse 13.1 and 13.2 lol.
    https://software.opensuse.org/package/plasmoid-veromix

    Quote Originally Posted by gogalthorp View Post
    But the kmix in 42.1 seems to be improved from 13.2
    Nice, if the first two don't seem to help or whatever, I'll try that as last resort lol

    Actually, KMix seems to be installed already...when i open it up, move the thing to bottom to mute it, still doesn't "stick" off/muted..

  8. #8

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by gogalthorp View Post
    not sure about veromix in 42.1 but the full package name is plasmoid-veromix
    Veromix is a KDE4 plasmoid and hasn't been ported to Plasma5 yet AFAIK.
    IOW, it won't work.

    But the kmix in 42.1 seems to be improved from 13.2
    No, it's exactly the same.

    Quote Originally Posted by matteopa View Post
    Actually, KMix seems to be installed already...when i open it up, move the thing to bottom to mute it, still doesn't "stick" off/muted..
    Which thing do you move down?
    You should use the right-most slider, labelled "Event sounds"...
    If that doesn't help, you probably should mention what event sounds exactly you want to mute...

    For every application a slider should show up in KMix (and pavucontrol and the volume applet), with which you can control the volume for that application. But it only shows up while that application is actually playing a sound...

  9. #9

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by matteopa View Post
    cause currently after fresh installation, I'm not even seeing the "Event Sounds" in the taskbar for speaker volume now, where it had been displayed before lol. Hmm..
    Plasma5's new volume control applet only shows the master volume when you click on it.
    To get the full controls you have to right-click and choose "Volume Control Settings", as I wrote.
    Last edited by wolfi323; 02-Nov-2015 at 11:15.

  10. #10

    Default Re: How to disable/mute event sounds?

    Quote Originally Posted by wolfi323 View Post
    Which thing do you move down?
    You should use the right-most slider, labelled "Event sounds"...
    If that doesn't help, you probably should mention what event sounds exactly you want to mute...

    For every application a slider should show up in KMix (and pavucontrol and the volume applet), with which you can control the volume for that application. But it only shows up while that application is actually playing a sound...
    Well like you said, there's basically a second black speaker icon show up with "Event Sounds" in it to far right side when I click on speaker icon. Those annoying *BLINGS*/ *RINGS* when a small confirmation prompt pops up, like confirming when you want to move a file, delete file, or when there's new updates to install. I then go and move slider down, and minimize the speaker icon setting thing / click on taskbar some where and it's back up again full volume, it doesn't stay down to bottom / volume slider doesn't stay to bottom for it being muted, nor does it do anything when I right click on "Event Sounds" and choose "Muted". Also, when there's volume sliders for other things, clicking the little speaker icon under each one would mute it, but when I tried that with Event Sounds it doesn't work. This is probably a bug.


    Quote Originally Posted by wolfi323 View Post
    Plasma5's new volume control applet only shows the master volume when you click on it.
    To get the full controls you have to right-click and choose "Volume Control Settings", as I wrote.
    Yeah, right clicking on the main black speaker, I choose "Audio Volume Settings" and "Event Sounds" isn't listed in there any where. Nothing under "Applications" "Recording" "Output Devices" "Input Devices" "Configuration".

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •