Results 1 to 4 of 4

Thread: Always booting to KDE Plasma instead of last session

  1. #1

    Default Always booting to KDE Plasma instead of last session

    I installed Xfce alongside existing KDE Plasma installation. If I logout from KDE session, login to Xfce and then do a reboot, it will boot into KDE again. To my understanding it should boot to last session - Xfce. Why is this not working and how do I make it boot to Xfce by default?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,942

    Default Re: Always booting to KDE Plasma instead of last session

    Quote Originally Posted by cenarius View Post
    I installed Xfce alongside existing KDE Plasma installation. If I logout from KDE session, login to Xfce and then do a reboot, it will boot into KDE again. To my understanding it should boot to last session - Xfce. Why is this not working and how do I make it boot to Xfce by default?
    To make the discussion a bit more understandable: a Linux system does not "boot into a desktop session". It boots. And after boot, people can login (from local or remote) into a desktop session.

    That holds true, even if in your special case, there may most of the times only be maximal one session loged in at any time, every time by the same user. And even if you have set the system to automatic login after boot (but you did not say so).

    Using the last used desktop environment by a user again as default at login is a feature of the display manager (that manifests itslf by showing the login page). It may depend on the display manager you use (kdm, gdm, different) but there often is a configuration menu (kdm has a wrench icon IIRC) at that login screen. So look what is configured and change it when wanted. When you have automatic login after boot configured, you may need to logout first to get the login screen.
    Henk van Velden

  3. #3

    Default Re: Always booting to KDE Plasma instead of last session

    Quote Originally Posted by cenarius View Post
    I installed Xfce alongside existing KDE Plasma installation. If I logout from KDE session, login to Xfce and then do a reboot, it will boot into KDE again. To my understanding it should boot to last session - Xfce. Why is this not working and how do I make it boot to Xfce by default?
    As hcvv already wrote, this is a function of your display (login) manager.
    I suppose you are using SDDM, the default one on a KDE installation...
    And I assume you are talking about the Autologin.

    Run Configure Desktop->Startup and Shutdown->Login Screen (SDDM). You can choose the session for Autologin there on the "Advanced" tab. Note that you may have to "enable" Autologin first to be able to change the session. That setting is rather taken from /etc/sysconfig/displaymanager in openSUSE and not correctly displayed by the control module.

    The session you select on the Login Screen is only used as default session for manual logins, i.e. the chooser will by default show the same one when you go to the login screen next time.

    If you want to disable Autologin altogether, do so in YaST->Security and Users->User and Group Management->Expert Options (button in the bottom-right corner)->Login Options, or just edit /etc/sysconfig/displaymanager with a text editor, the option is called "DISPLAYMANAGER_AUTOLOGIN".

  4. #4

    Default Re: Always booting to KDE Plasma instead of last session

    It was the autologin indeed. Thank you for great help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •