Results 1 to 3 of 3

Thread: How to clear krunner (browser bookmark) cache?

  1. #1

    Question How to clear krunner (browser bookmark) cache?

    I have disabled Bookmarks after pressing ALT+F2 but typing in the start menu search field still shows me browser bookmarks too (although I restarted)

    I suppose this is some kind of cache. How do I clear this? I don't want to see browser bookmarks in Launcher.

  2. #2

    Default Re: How to clear krunner (browser bookmark) cache?

    I logged out, deleted /var/tmp/kdecache-<myusername> but the browser bookmarks still appear when I type in the Search of the start menu Launcher.

    Is there any other setting?

  3. #3

    Default Re: How to clear krunner (browser bookmark) cache?

    I found the answer here:

    - copy the file /usr/share/kde4/services/plasma-runner-bookmarks.desktop to ~/.kde4/share/kde4/services/ (or ~/.kde/share/kde4/services/ depending on your distro)

    - then search for the line "X-KDE-PluginInfo-EnabledByDefault=true" and change this in

    Code:
    X-KDE-PluginInfo-EnabledByDefault=false
    - call "kbuildsycoca4 --noincremental" (I'm not sure if this is needed, but it can't harm...)


    After a logout/login (or reboot) the bookmark searching should be disabled in Kickoff.
    And this will even survive system upgrades.
    Hopefully someone else may find it useful too.

    It was nice talking to myself anyway

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •