Results 1 to 9 of 9

Thread: knetworkmanager forgets the wlan password - in opensuse 13.2

  1. #1

    Default knetworkmanager forgets the wlan password - in opensuse 13.2

    dear opensuse-community,


    i cannot store the password for wlan in the opensuse 13.2

    why ?

    we have the following options;:


    do not save (ask everytime)
    1. In a file (uncrypted)
    2. In digital envelope (crypted)

    well - first i have to make clear which systems runs here:

    KNetworkManager, or plasmoid-networkmanagement?

    i run the following codes

    Code:
    rpm -qa "*etwork*"
    and
    Code:
    plasmoidviewer --list | grep -i net
    see the results:


    Code:
    martin@linux-o61y:~> rpm -qa "*etwork*"
    NetworkManager-pptp-0.9.10.0-2.2.2.i586
    yast2-network-3.1.110.1-3.1.i586
    NetworkManager-openvpn-0.9.10.0-2.1.4.i586
    glib-networking-lang-2.42.1-4.1.noarch
    NetworkManager-0.9.10.0-3.14.1.i586
    libproxy1-networkmanager-0.4.11-12.1.4.i586
    NetworkManager-vpnc-0.9.10.0-2.1.4.i586
    glib-networking-2.42.1-4.1.i586
    libNetworkManagerQt1-0.9.8.2-3.1.3.i586
    kdenetwork4-filesharing-14.12.3-16.1.i586
    martin@linux-o61y:~>
    and the following

    Code:
    martin@linux-o61y:~> plasmoidviewer --list | grep -i net
    plasmoidviewer: command not found
    martin@linux-o61y:~>

    what can i do now!?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    hello again -

    the system forgets the passwd - even in one session. Imagine that i have to enter the passwd after the system has fallen to sleep after ten minutes.
    this is not normal - i think that i can fix this - if i know how....

    do you have any idea how to do the fix?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  3. #3
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    I don't use wireless so I cant test stuff out but have you configured kwallet? It may be what NM will use to store the passwords.
    openSUSE Leap (42.1) 64 bit
    Plasma 5.4

  4. #4

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    hello - many thanks for the reply.

    guess that i have to configure kwalllet

    while looking for some manuals i found the following text:


    http://ubuntuforums.org/showthread.php?t=361403

    When using KDE applications which require password access (such as Kopete or kftp) kdewallet often offers to
    remember the password in a wallet in exchange for you entering a singular password each time you open that application.

    Often these applications will download kdewallet as a dependency should it be accquired from the repositories.
    Anyway, it's very easy to stop this little popup each time you open a KDE application, simply follow these steps:

    Run "kdewalletmanager" from terminal or Alt + F2
    Open the configuration dialogue (Settings > Configure), and uncheck "Enable the KDE Wallet subsystem"
    Close the two open dialouges, and try your favorite KDE application.

    Sorted! Should've worked instantly.
    welll how to apply this ubuntu manual on opensuse 13.2

    i would love to configure kwallet
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  5. #5

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    Quote Originally Posted by dilbertone View Post
    welll how to apply this ubuntu manual on opensuse 13.2

    i would love to configure kwallet
    The same should work in openSUSE, although kwallet should normally be enabled by default (it should open a dialog for setting up a password at first use, you can set an empty one if you want).

    You can find its options in "Configure Desktop" (KDE's systemsettings)->Personal Account Details->Wallet too.

    Another option: enable "Allow other users to connect with this network" in the connection settings, the password will be stored systemwide then and *not* in kwallet.

    Regarding the rest of your questions from the first post:
    on 13.2 you should normally have plasma-nm. But this does *not* have the options you mention (it only supports storing the password in kwallet):
    do not save (ask everytime)
    1. In a file (uncrypted)
    2. In digital envelope (crypted)
    This actually rather sounds like the older plasmoid-networkmanagement, that's not even included in 13.2.

    Are you sure you are using a full 13.2? Or did you upgrade and still have stuff from 13.1 or earlier installed?
    Would explain your problems too, I suppose.
    But then, it doesn't show up in the rpm output, so you are probably using plasma-nm.
    So, where exactly do you have those options?

  6. #6

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    hello dear wofi

    many many thanks for the answer - well i have installed a fresh 13.2

    but i do not know why i do not have the plasmaoid...

    can you tell me / give me some (more) commands that i can run here - so that we can clear up the situation?

    that would be great. dear wolfi i love to hear from you


    untill soon -

    best regards
    dilbert
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  7. #7

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    hello dear wolfi

    first of all - many many thanks for your continued help. i have to admit - you are right - in that


    Another option: enable "Allow other users to connect with this network" in the connection settings, the password will be stored systemwide then and *not* in kwallet.

    on 13.2 you should normally have plasma-nm. But this does *not* have the options you mention (it only supports storing the password in kwallet):
    do not save (ask everytime)
    1. In a file (uncrypted)
    2. In digital envelope (crypted)



    This actually rather sounds like the older plasmoid-networkmanagement, that's not even included in 13.2.
    right - the above mentioned dialoge notes are mentioned in the version 13.1 -

    i have another notebook - with opensuse 13.2
    in the version 13.2 i have the serious issues that - i did not activate kwallet since this (kwallet) does process a massive request of passwords itself

    this makes me allmost crazy-
    therefore i have disabled kwallet

    but now i cannot access some wlan - since i face plenty password requests in a very very short time.

    what can i do - i need to have a good practice of running kwallet.


    CAN YOU advice me...!?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    When kwallet asks for it's password the first time just don't enter one leave blank. DO NOT just disable it

  9. #9

    Default Re: knetworkmanager forgets the wlan password - in opensuse 13.2

    Quote Originally Posted by gogalthorp View Post
    When kwallet asks for it's password the first time just don't enter one leave blank. DO NOT just disable it
    Correct. Plasma-nm *needs* kwallet for storing the password.
    You can set an empty password even afterwards, in kwalletmanager.

    An empty password *might* be a security concern, but it's not much different from storing it in plain text in the config file anyway (actually it's even better security wise because it is at least obscured).

    Or, as I wrote, enable "Allow other users to connect with this network" in the connection settings, the password will be stored system-wide then without using kwallet (albeit also just obscured, not encrypted, but only root could read it).

    There's also the option to open the wallet automatically on login with your login password (i.e. you won't have to enter it a second time) similar to how gnome-keyring works, but that needs the installation of kwallet_pam from some additional repo and some manual config change.
    Last edited by wolfi323; 02-Nov-2015 at 13:23.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •