Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: search in dolphin doesn't work

  1. #1

    Default search in dolphin doesn't work

    on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.2 KDE= 4.14.9
    if I search for a file in dolfin (ctrl >f) nothing appear even if the search name exist, in system settings>desktop search advanced and desktop search indexing is enabled and running from weeks.
    is there a way to have search working?? :-)
    manythanks :-) ciao :-) pier

  2. #2

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by pier_andreit View Post
    on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.2 KDE= 4.14.9
    if I search for a file in dolfin (ctrl >f) nothing appear even if the search name exist, in system settings>desktop search advanced and desktop search indexing is enabled and running from weeks.
    is there a way to have search working?? :-)
    *Disable* file indexing and it should work...
    Or use kfind.

    OTOH, Baloo (i.e. indexed search) should work too, *if* the files are actually indexed.
    Use "balooctl status" to check. Verify in the settings that the folders you want to search in are not excluded from the index.

    Also, which dolphin version are you using?
    15.08 (KF5 based) will *not* work with KDE4's Baloo.

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,926

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by wolfi323 View Post
    *Disable* file indexing and it should work...
    Or use kfind.

    OTOH, Baloo (i.e. indexed search) should work too, *if* the files are actually indexed.
    Use "balooctl status" to check. Verify in the settings that the folders you want to search in are not excluded from the index.

    Also, which dolphin version are you using?
    15.08 (KF5 based) will *not* work with KDE4's Baloo.
    Or give Krusader a try. It has got great search GUI in my opinion.
    Best regards,
    Greg

  4. #4

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by wolfi323 View Post
    *Disable* file indexing and it should work...
    Or use kfind.
    uh ...disabling file indexing it works... why this ??
    Quote Originally Posted by wolfi323 View Post
    OTOH, Baloo (i.e. indexed search) should work too, *if* the files are actually indexed.
    Use "balooctl status" to check. Verify in the settings that the folders you want to search in are not excluded from the index.
    yes the baloo was running and indexing, in the setting the folders I want to search was included in index...
    Quote Originally Posted by wolfi323 View Post
    Also, which dolphin version are you using?
    15.08 (KF5 based) will *not* work with KDE4's Baloo.
    I'm using this:
    Dolphin
    Version 15.04.0
    Using KDE Development Platform 4.14.9

  5. #5

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by glistwan View Post
    Or give Krusader a try. It has got great search GUI in my opinion.
    ... will , but, why clicking in the kickoff I only find the krusader root mode and not the user mode??
    manythanks, ciao pier

  6. #6

    Default AW: Re: search in dolphin doesn't work

    Quote Originally Posted by pier_andreit View Post
    uh ...disabling file indexing it works... why this ??
    Because dolphin just uses grep then.

    yes the baloo was running and indexing, in the setting the folders I want to search was included in index...
    Ok, but were the files you were searching actually indexed?

    Do the numbers that "balooctl status" tells you sound reasonable?

    I'm using this:
    Dolphin
    Version 15.04.0
    Using KDE Development Platform 4.14.9
    Ok, this should work, provided that you have baloo-file (and maybe baloo-kioslaves and baloo-tools too, I'm not sure) installed. And not baloo5-file.

  7. #7

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by pier_andreit View Post
    ... will , but, why clicking in the kickoff I only find the krusader root mode and not the user mode??
    It should be in "System"->"File Management", just like Krusader-root mode and dolphin.

    Maybe your cache is outdated?
    Try running "kbuildsycoca4" (as user), or logout/login.

  8. #8
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,926

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by pier_andreit View Post
    ... will , but, why clicking in the kickoff I only find the krusader root mode and not the user mode??
    manythanks, ciao pier
    Not sure. It is by default in Aplications -> System -> File manager
    http://paste.opensuse.org/29728893

    After that I just check "show a luncher when not running" and forget where it is
    Best regards,
    Greg

  9. #9

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by glistwan View Post
    Not sure. It is by default in Aplications -> System -> File manager
    http://paste.opensuse.org/29728893
    yes, it is there, but when I type krusader in the search box in kickoff only root mode appear

    Quote Originally Posted by glistwan View Post
    After that I just check "show a luncher when not running" and forget where it is
    ...where??

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,926

    Default Re: search in dolphin doesn't work

    Quote Originally Posted by pier_andreit View Post
    yes, it is there, but when I type krusader in the search box in kickoff only root mode appear

    ...where??
    You right click on the application in the task manager and then there is a checkbox (Show A Launcher When Not Running).
    It's a standard KDE feature. For some reason I can't take a screen shot. Here is a video on it although right now or in openSUSE is not in the advanced section :
    https://www.youtube.com/watch?v=dV6BJZLl9-E
    Best regards,
    Greg

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •