Page 3 of 14 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 131

Thread: Release candidate 42.1 RC1 -- post your comments

  1. #21
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,666

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Be careful with shared folders in Virtualbox 5.0.6: I found mine owned by "root" on a NTFS partition.
    Not sure that this is due to VirtualBox, since the new Nautilus file manager on Gnome 3.18 in TW is doing odd things, and my Dolphin in Leap RC1 on VM isn't in good shape either.
    Just handle with care, and report back if you find anything interestin...
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  2. #22

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Quote Originally Posted by OrsoBruno View Post
    Be careful with shared folders in Virtualbox 5.0.6: I found mine owned by "root" on a NTFS partition.
    And how exactly is your NTFS partition mounted?
    ntfs-3g by default *ignores* all user information, so it is impossible that a folder is "owned by root".

  3. #23

    Default Re: Release candidate 42.1 RC1 -- post your comments

    And could you please be a more specific about "nautilus doing odd things" and "dolphin isn't in a good shape either"?
    Although even grave bugs in those applications shouldn't make your folders be owned by root.

  4. #24
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,666

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Quote Originally Posted by wolfi323 View Post
    And could you please be a more specific about "nautilus doing odd things" and "dolphin isn't in a good shape either"?
    Although even grave bugs in those applications shouldn't make your folders be owned by root.
    Sorry for a false alarm (possibly...), on double-checking seems nothing related to RC1 or VBox 5.0.6.

    Nautilus 3.18.0 is no more able to delete files within my DATA mount (see below), the oddest thing so far.
    Nautilus 3.16.x offered to "permanently delete", being unable to trash them.
    But I'm possibly discovering other "improvements" in 3.18, so stay tuned...
    I might open another thread if I find something of general interest.

    Dolphin in RC1 at first worked, without even the problem described in comment #11.
    Then began showing that problem and now, after I uninstalled some LXDE stuff, doesn't start at all.
    But I might have done something stupid while "betatesting", so disregard the latter for now.

    Quote Originally Posted by wolfi323 View Post
    And how exactly is your NTFS partition mounted?
    ntfs-3g by default *ignores* all user information, so it is impossible that a folder is "owned by root".
    Just for the records, the "offending" DATA partition is mounted via fstab like the following:
    Code:
    UUID=186A4827393587A5 /home/DATA ntfs nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=DATA 0 0
    everything therein seems like
    Code:
    bruno@LT_B:/home/DATA/bruno> ls -l
    total 192
    drwxrwxrwx 1 root root     0 ott 11 17:08 bin
    drwxrwxrwx 1 root root     0 dic 11  2014 Desktop
    drwxrwxrwx 1 root root 40960 ott 12 10:52 Documents
    drwxrwxrwx 1 root root 86016 ott 20 14:55 Downloads
    drwxrwxrwx 1 root root     0 nov 17  2014 Music
    ...
    which is indeed equivalent to *ignoring* all user information, as you said.

    I was likely misled by links to those "physical" directories having different permissions, apparently depending on the time they were originally created, and I thought that possibly VBox might have tampered with them.
    Code:
    bruno@LT_B:~> ls -l
    total 4
    lrwxrwxrwx 1 bruno users   20 gen  3  2015 bin -> /home/DATA/bruno/bin
    lrwxrwxrwx 1 root  root    24 gen  1  2015 Desktop -> /home/DATA/bruno/Desktop
    lrwxrwxrwx 1 root  root    26 gen  1  2015 Documents -> /home/DATA/bruno/Documents
    lrwxrwxrwx 1 root  root    26 gen  1  2015 Downloads -> /home/DATA/bruno/Downloads
    lrwxrwxrwx 1 bruno users   22 gen  3  2015 Music -> /home/DATA/bruno/Music
    ...
    Last edited by OrsoBruno; 20-Oct-2015 at 07:24. Reason: clarification
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #25

    Default Re: Release candidate 42.1 RC1 -- post your comments

    During installation of Leap KDE I chose my native language (fi) as locale and it seem to pick my keyboard locale right. However, after install it didn't work anymore but seem to use english keyboard locale. In Yast > Languages right language was chosen but in in KDE System settings > Locale there wasn't any language in "Preferred languages". After I added my language there the keyboard locale was picked right. In System settings > Spellcheck only english was available.
    I got those kmix/kmixctrl/kdeinit/kded -segfaults too at start but fix suggested here solved it.

  6. #26

    Default Re: Release candidate 42.1 RC1 -- post your comments

    I also enabled all the debug -repos which not all seem to be valid:
    Code:
    Retrieving repository 'openSUSE-Leap-42.1-Update-Debug' metadata .....................................................................................................................[error]
    Repository 'openSUSE-Leap-42.1-Update-Debug' is invalid.
    [repo-debug-update|http://download.opensuse.org/debug/update/leap/42.1/oss] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-Leap-42.1-Update-Debug' because of the above error.
    Retrieving repository 'openSUSE-Leap-42.1-Update-Debug-Non-Oss' metadata .............................................................................................................[error]
    Repository 'openSUSE-Leap-42.1-Update-Debug-Non-Oss' is invalid.
    [repo-debug-update-non-oss|http://download.opensuse.org/debug/update/leap/42.1/non-oss/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'openSUSE-Leap-42.1-Update-Debug-Non-Oss' because of the above error.

  7. #27

    Default Re: Release candidate 42.1 RC1 -- post your comments

    For users having problems with hplip-systray (Error like "no system tray found" on startup).

    Edit file "/etc/xdg/autostart/hplip-systray.desktop" and change the Exec-Entry like this:

    Code:
    [Desktop Entry] 
    Version=0.6 
    Type=Application 
    Name=HP System Tray Service 
    GenericName=Printer Status Applet 
    Comment=HP System Tray Service 
    Exec=sh -c "sleep 15; exec hp-systray -x"
    Icon=/usr/share/hplip/data/images/128x128/hp_logo.png 
    Terminal=false 
    Categories=Application;Utility; 
    X-KDE-StartupNotify=false 
    StartupNotify=false
    


  8. #28

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Quote Originally Posted by Cerule View Post
    However, after install it didn't work anymore but seem to use english keyboard locale. In Yast > Languages right language was chosen but in in KDE System settings > Locale there wasn't any language in "Preferred languages". After I added my language there the keyboard locale was picked right.
    The locale settings are independent of the keyboard layout, so I don't really fully understand your problem.

    You can change the *keyboard* layout in YaST->Hardware->System Keyboard Layout or KDE's Systemsettings->Input Devices->Keyboard.

    The ones you mentioned shouldn't have any influence on the keyboard layout.

    In System settings > Spellcheck only english was available.
    That's unrelated to either the locale settings or the keyboard layout settings.

    Make sure you have the corresponding myspell dictionary packages installed.

    If you "install" the language in YaST->Software Management->View->Languages, it should also install the necessary myspell packages.

    There is still a problem in Tumbleweed about this that only the english language packages will be installed regardless what language is selected during installation, but I'm not sure if this bug is also present in Leap.
    Actually, that bug has been fixed already, it's just not in the repo yet (for Tumbleweed that is).

  9. #29

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Quote Originally Posted by wolfi323 View Post
    The locale settings are independent of the keyboard layout, so I don't really fully understand your problem.

    You can change the *keyboard* layout in YaST->Hardware->System Keyboard Layout or KDE's Systemsettings->Input Devices->Keyboard.

    The ones you mentioned shouldn't have any influence on the keyboard layout.
    Yeah I confused locale settings to keyboard layout settings.Anyway, the layout was picked up right during installation but lost after it and I had to add layout in the latter place you mentioned.

  10. #30
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,666

    Default Re: Release candidate 42.1 RC1 -- post your comments

    Quote Originally Posted by Cerule View Post
    Yeah I confused locale settings to keyboard layout settings.Anyway, the layout was picked up right during installation but lost after it and I had to add layout in the latter place you mentioned.
    Now that keyboard layout was mentioned, I noticed that in the sddm greeter layout seems stuck at US-English.
    But at the first key pressed (e.g. the first password letter) the "flag" correctly switches to "IT".
    Never had problems once logged in to Plasma5: maybe only a visual glitch?
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Page 3 of 14 FirstFirst 1234513 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •