Results 1 to 4 of 4

Thread: How to compile Dolphin emulator from source?

  1. #1
    corgi NNTP User

    Question How to compile Dolphin emulator from source?

    Here are the dependencies for Dolphin emulator:

    Code:
         git
        cmake
        gcc
        libwxbase3.0-dev
        libwxgtk3.0-dev
        libgtk2.0-dev
        libxext-dev
        libreadline-dev
        libgl1-mesa-dev
        libevdev-dev
        libudev-dev
    I've installed git, cmake and gcc, but I have no idea how to get the rest. What/which packages for openSUSE contains all I need?

    --

    Fortunately updating Dolphin is incredibly easy after I get this done

    Code:
       $ git clone https://github.com/dolphin-emu/dolphin.git

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,196
    Blog Entries
    15

    Default Re: How to compile Dolphin emulator from source?

    Hi
    Have a look at the spec file on OBS?
    https://build.opensuse.org/package/v....spec?expand=1

    Just ping the maintainers via email and ask if they can update?
    https://build.opensuse.org/package/v...anges?expand=1

    Else, branch/copy and update yourself on OBS...?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    corgi NNTP User

    Question Re: How to compile Dolphin emulator from source?

    It is much better to compile myself. Dolphin updates frequently, even several times a day and the stable builds are severely outdated.
    I didn't understand that was my question answered? How to install dependencies?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,196
    Blog Entries
    15

    Default Re: How to compile Dolphin emulator from source?

    Hi
    From the spec file 'BuildRequires';
    Code:
    BuildRequires:  alsa-devel
    BuildRequires:  bluez-devel
    BuildRequires:  cmake
    BuildRequires:  gcc-c++
    BuildRequires:  glew-devel
    BuildRequires:  libSDL-devel
    BuildRequires:  libSOIL-devel
    BuildRequires:  libao-devel
    BuildRequires:  libpulse-devel
    BuildRequires:  lzo-devel
    BuildRequires:  openal-devel
    BuildRequires:  pkgconfig(xrandr)
    BuildRequires:  portaudio-devel
    BuildRequires:  sfml-devel
    BuildRequires:  update-desktop-files
    BuildRequires:  wxWidgets-devel
    BuildRequires:  zlib-devel
    The xrandr one is just xrandr-devel.

    Ask the maintainers to setup a _service file to download the latest version from git and call it an unstable build (since it is rc...).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •