Results 1 to 9 of 9

Thread: gdm is broken

  1. #1

    Unhappy gdm is broken

    Hi everyone, I installed opensuse tumbleweed yesterday but when log out it appear black window (checking service maybe) and nothing happen and when i check /var/log/gdm the folder is empty what should i do it really painful to reboot the pc every time
    please help me
    thank you in advance

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,617
    Blog Entries
    3

    Default Re: gdm is broken

    Switch to "lightdm". You might need to install it first.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,823
    Blog Entries
    15

    Default Re: gdm is broken

    Hi
    Press ctrl+alt+F2, login as root user then restart the X server;
    Code:
    init 3
    init 5 && exit
    Press ctrl+alt+F7 (or maybe F8) and gdm will restart....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: gdm is broken

    Quote Originally Posted by nrickert View Post
    Switch to "lightdm". You might need to install it first.
    will i already installed lightdm but when i type
    Code:
    sudo systemctl enable lightdm
    it will give me: Failed to execute operation: No such file or directory

  5. #5

    Default Re: gdm is broken

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Press ctrl+alt+F2, login as root user then restart the X server;
    Code:
    init 3
    init 5 && exit
    Press ctrl+alt+F7 (or maybe F8) and gdm will restart....
    after init 5 && exit it take me back to the session without gdm

  6. #6

    Default Re: gdm is broken

    Quote Originally Posted by elia View Post
    will i already installed lightdm but when i type
    Code:
    sudo systemctl enable lightdm
    it will give me: Failed to execute operation: No such file or directory
    In openSUSE, all display managers are started by the generic display-manager.service, which should be enabled already anyway.
    There is no explicit lightdm.service.

    Just set the display manager you want in /etc/sysconfig/displaymanager, in this case change the already existing line to:
    Code:
    DISPLAYMANAGER="lightdm"

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,823
    Blog Entries
    15

    Default Re: gdm is broken

    Quote Originally Posted by elia View Post
    after init 5 && exit it take me back to the session without gdm
    Hi After pressing ctrl+alt+F7, no mouse cursor? Hmm, just tested here with Tumbleweed, with and without autologin running, worked either way.... Tumbleweed all up to date? Follow wolfi323's info for lightdm then....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: gdm is broken

    it work after changing account type from standard to administrator
    thanks for you guys
    and forgive me if i disturb you

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: gdm is broken

    Do you mean root? that is what the administrator account is called in Linux And yes you must be root to make system changes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •