Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Ethernet down after resume. Tumbleweed

  1. #1

    Question Ethernet down after resume. Tumbleweed

    Hi, a few days ago I've switched from OpenSuSE 13.2 to Tumbleweed.

    When i suspend my laptop (close the lid) and resume it afterwards, the ethernet (not WiFi) is unavailable, i.e. it does not reconnect.

    I've tried restarting Network Manager server, but all it does is add second Network Manager applet in systray.

    Google searched suggests editing /etc/pm/config.d/unload_modules and adding SUSPEND_MODULES="$SUSPEND_MODULES [module_name]", but I don't have "pm" under /etc. I've tried creating the missing directories and the unload_modules, add the SUSPEND_MODULES bit, but it didn't help.

    Anyone knows how to fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Ethernet down after resume. Tumbleweed

    Some more information is required to help diagnose this. To start with...following a resume, capture the output from
    Code:
    ip link
    Code:
    systemctl status NetworkManager
    Code:
    journalctl -u NetworkManager
    If you don't have internet connectivity on this machine, then you could cupy/paste output to a text file and transfer via memory stick.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Ethernet down after resume. Tumbleweed

    If sleep hooks really do turn out to be needed (for module unloading/reloading), then it needs to be done using systemd methods...

    https://wiki.archlinux.org/index.php..._and_hibernate

  4. #4

    Default Re: Ethernet down after resume. Tumbleweed

    Quote Originally Posted by deano_ferrari View Post
    Some more information is required to help diagnose this. To start with...following a resume, capture the output from
    Code:
    ip link
    Code:
    systemctl status NetworkManager
    Code:
    journalctl -u NetworkManager
    If you don't have internet connectivity on this machine, then you could cupy/paste output to a text file and transfer via memory stick.
    Hi there, I've run the command you specified right after boot, and then suspended the laptop and run them again. I run them in this order:
    Code:
    journalctl -u NetworkManager
    systemctl status NetworkManager
    ip link
    output from
    Code:
    journalctl -u NetworkManager
    is over 14 MB!

    I did run diff of the files and looks that only difference is in
    Code:
    systemctl status NetworkManager
    and is as follows:

    Output before suspending:
    Code:
    <            └─1500 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-p5p1.pid -lf /var/lib/NetworkManager/dhclient-e93c78d1-edfc-41a8-a9bc-0eb12eee4f7c-p5p1.lease -cf /var/lib/NetworkManager/dhclient-p5p1.conf p5p1


    Output after resume:

    Code:
    >            └─3296 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-p5p1.pid -lf /var/lib/NetworkManager/dhclient-e93c78d1-edfc-41a8-a9bc-0eb12eee4f7c-p5p1.lease -cf /var/lib/NetworkManager/dhclient-p5p1.conf p5p1


    Also, I issued
    Code:
    sudo dhclient p5p1
    and received
    Code:
    ls: cannot access /var/run/netconfig//p5p1/: No such file or directory
    and in indeed, there is only NetworkManager.netconfig in /var/run/netconfig.

    I've placed output of the commands you suggested in my dropbox -> https://www.dropbox.com/sh/x5uueexhhi0da8w/AACx2W80xG97NwYy-8SYVMKPa?dl=0

    Does this give you any clues?

  5. #5

    Default Re: Ethernet down after resume. Tumbleweed

    Quote Originally Posted by deano_ferrari View Post
    If sleep hooks really do turn out to be needed (for module unloading/reloading), then it needs to be done using systemd methods...

    https://wiki.archlinux.org/index.php..._and_hibernate
    Thank you for the link. I've verified that running
    Code:
    sudo /usr/sbin/modprobe -r r8169 && sudo /usr/sbin/modprobe r8169
    after resume fixes the issue. Unfortunately, it is not clear to me how to achieve this using service file.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Ethernet down after resume. Tumbleweed

    Quote Originally Posted by RaveNBlack View Post
    Thank you for the link. I've verified that running
    Code:
    sudo /usr/sbin/modprobe -r r8169 && sudo /usr/sbin/modprobe r8169
    after resume fixes the issue. Unfortunately, it is not clear to me how to achieve this using service file.
    Create a service file eg etc/systemd/system/r8169-reload.service

    Code:
    [Unit]
    Description=Reload wireless driver after system resume
    After=suspend.target
    
    [Service]
    Type=oneshot
    ExecStart=/usr/sbin/modprobe -r r8169
    ExecStart=/usr/sbin/modprobe r8169
    
    [Install]
    WantedBy=suspend.target
    Then enable and start the service
    Code:
    systemctl enable r8169-reload.service
    Code:
    systemctl start r8169-reload.service
    Hope that does the trick.

  7. #7

    Default Re: Ethernet down after resume. Tumbleweed

    Quote Originally Posted by deano_ferrari View Post
    Create a service file eg etc/systemd/system/r8169-reload.service

    Code:
    [Unit]
    Description=Reload wireless driver after system resume
    After=suspend.target
    
    [Service]
    Type=oneshot
    ExecStart=/usr/sbin/modprobe -r r8169
    ExecStart=/usr/sbin/modprobe r8169
    
    [Install]
    WantedBy=suspend.target
    Then enable and start the service
    Code:
    systemctl enable r8169-reload.service
    Code:
    systemctl start r8169-reload.service
    Hope that does the trick.
    Thank you for the file, unfortunately, when i try to enable the service (with sudo) I get this message "Failed to execute operation: Bad message".
    I don't see the service Yast service list and my network card still not available after resume.

    Starting the service (with sudo) on the other hand, does reload the kernel module and fixes the issue.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Ethernet down after resume. Tumbleweed

    Strange, implementing that service works for me without issue. My NIC uses the same driver, although I don't suffer the resume problem you've described.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,016
    Blog Entries
    1

    Default Re: Ethernet down after resume. Tumbleweed

    Try enabling the service manually with
    Code:
    mkdir /etc/systemd/system/suspend.target.wants
    Code:
    ln -s /etc/systemd/system/r8169-reload.service /etc/systemd/system/suspend.target.wants/r8169-reload.service
    Start it with
    Code:
    systemctl start r8169-reload
    and then try suspending/resuming again.
    Last edited by deano_ferrari; 15-Oct-2015 at 01:48.

  10. #10

    Default Re: Ethernet down after resume. Tumbleweed

    Quote Originally Posted by deano_ferrari View Post
    Try enabling the service manually with
    Code:
    mkdir /etc/systemd/system/suspend.target.wants
    Code:
    ln -s /etc/systemd/system/r8169-reload.service /etc/systemd/system/suspend.target.wants/r8169-reload.service
    Start it with
    Code:
    systemctl start r8169-reload
    and then try suspending/resuming again.
    Thanks for the advice. I've created the symbolic link but it didn't seem to help. Trying to enable the service throws the same error. It does not reload kernel module on resume, but does reload kernel module if I manually start the service as before.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •