Results 1 to 3 of 3

Thread: YaST DHCP Server + Client problem on Virtual Machine

  1. #1

    Default YaST DHCP Server + Client problem on Virtual Machine

    Hello.

    I have problem, I just started with servers, so I don't have a lot of experience and I have problem which I can't solve myself.

    Important: I'm doing everything on virtual machines: VMware Workstation 12 Player !

    I have running DHCP server on openSUSE Linux Enterprise 11, which is configured to give everyone IP from 192.168.174.20 to 192.168.174.100.
    Server is running good, DHCP have the same IP of SUSE Linux.
    Network Card in my settings of Virtual Machine I have configured to NAT, and it's eth0 card. (DHCP is also working on eth0 card)

    I installed Debian 8.2 on another Virtual Machine, and I'm trying to set it up so that SUSE can assign IP from xxx.xxx.xxx.20 to xxx.xxx.xxx.100

    Well, unfortunately, for now I'm stuck. Debian always gets the same IP adress from DHCP server others than mine. Debian also has NAT and eth0 card.

    Debian has dhcp-client package, and after configured it, system gets the same IP adress...
    Debian gets 192.168.174.134....

    Once I managed to somehow "fix" DHCP client on Debian, and got first adress from the pool (192.168.174.20)
    I don't know how I managed to "fix" it, but I wrote the following commands:
    - dhclient eth0
    - ifup eth0
    - ifdown eth0
    - ifup eth0

    Then I realized, that my Debian got IP adress from my DHCP Server !

    Unfortunately, I've done that just for one time.

    What am I doing wrong?

    Please help me.

    P.S: Sorry for my english, I'm not native speaker in that language.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,359

    Default Re: YaST DHCP Server + Client problem on Virtual Machine

    Quote Originally Posted by AlTosterino View Post
    ... openSUSE Linux Enterprise 11,
    There is not such a thing.

    There is openSUSE (at the moment the supported versions are 13.1, 13.2 and Tumbleweed) and there is SUSE Linux Enterprise Server/Desktop.

    I assume that you have SUSE Linux Enterprise Desktop or Server 11. But these are the openSUSE forums. The SLES/SLED forums are at: https://forums.suse.com/forum.php

    You better go there (the same username/password as here).
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,905
    Blog Entries
    2

    Default Re: YaST DHCP Server + Client problem on Virtual Machine

    If you're connecting your Guests to the default NAT virtual network, VMware Workstation provides NAT with the address range you describe, you <should not> configure any Guest connected to this NAT network to also run DHCP.

    If you want to run your own DHCP server, you need to either connect to a Hosts-Only network (which won't have access to the Internet) or create your own custom NAT without a running DHCP server.

    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •