Results 1 to 5 of 5

Thread: update problem

  1. #1

    Default update problem

    Recently, I got the notification that vboxgtk (etc) needed to be updated. (openSUSE-2015-622) When I try to do the update, I get a message:

    vboxgtk-lang-0.8.2-6.1.5-noarch requires vboxgtk-0.8.2 but that requirement can not be met.

    Now I have vboxgtk-0.8.2-6.1.5 installed on the system (as Apper reports).

    How do I fix this problem?

    Thank you,

    Mark

  2. #2

    Default Re: update problem

    Quote Originally Posted by MarkNei View Post
    How do I fix this problem?
    Uninstall vboxgtk-lang manually, and the update should succeed.
    Or uninstall vboxgtk completely, you should get the official Qt GUI (virtualbox-qt) then automatically instead.

    Background:
    vboxgtk is completely broken (it doesn't even start), and it hasn't been further developed since 2012. Therefore it got dropped from the distribution shortly before 13.2 was released (but is still in 13.2).
    People complained that they still get the not-working vboxgtk installed by default if they select virtualbox, so we added a conflict in the latest update.
    Unfortunately, if vboxgtk-lang is also installed, virtualbox-qt cannot replace vboxgtk automatically, as vboxgtk-lang requires vboxgtk...

  3. #3

    Default Re: update problem

    Hi,

    You suggested that I remove the vboxgtk packages manually. I'm not a new-bie, but please tell me what steps I should use to remove the packages. I tried using apper, but that didn't work.

    Thanks,

  4. #4

    Default Re: update problem

    Quote Originally Posted by MarkNei View Post
    You suggested that I remove the vboxgtk packages manually. I'm not a new-bie, but please tell me what steps I should use to remove the packages. I tried using apper, but that didn't work.
    Actually you need to remove vboxgtk-lang, that's the one that causes the problem.
    vboxgtk will be replaced automatically anyway.

    You should be able to remove it with Apper, YaST->Software Management, or commands like "zypper rm vboxgtk-lang" or "rpm -e vboxgtk-lang".

  5. #5

    Default Re: update problem

    Thank you....that did it.

    Mark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •