Results 1 to 3 of 3

Thread: OpenSuse 13.2 Package Failed To Install

  1. #1

    Default OpenSuse 13.2 Package Failed To Install

    Hello,
    I was hoping someone can help me rid this error:
    When updating via the apper software updater (the bug on the panel)

    I get the following:

    Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/urllib3-1.12-py2.7.egg-info: cpio: rename failed - Is a directory
    error: python-urllib3-1.12-8.1.noarch: install failed
    error: python-urllib3-1.12-7.1.noarch: erase skipped

    Looking in /usr/lib there are 4 files with random #at the end
    eg

    urllib3-1.12-py2.7.egg-info;5616f317

    and there is a directory named
    urllib3-1.12-py2.7.egg-info

    with what appears to be a package in it

    What is the best course of action to take to rid the error?

    thansk
    john kilbert

  2. #2

    Default AW: OpenSuse 13.2 Package Failed To Install

    Quote Originally Posted by kilbert View Post
    What is the best course of action to take to rid the error?
    Delete that directory.
    RPM has problems if it wants to install a file/symlink which already exists as a directory.

    The freshly to be installed package contains all necessary files/directories anyway.

  3. #3

    Default Re: OpenSuse 13.2 Package Failed To Install

    Thanks!
    That appeared to work
    Have a nice night

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •