Results 1 to 9 of 9

Thread: Update conficts

  1. #1
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    119

    Default Update conficts

    I have several online update conflicts!


    #### YaST2 conflicts list - generated 2015-10-06 12:58:50 ####

    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by ark-15.08.1-1.2.x86_64

    [ ] break ark-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install ark-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by baloo5-widgets-15.08.1-8.1.x86_64

    [ ] break baloo5-widgets-15.08.1-8.1.x86_64 by ignoring some of its dependencies

    [ ] do not install baloo5-widgets-15.08.1-8.1.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kcharselect-15.08.1-1.2.x86_64

    [ ] break kcharselect-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install kcharselect-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kde-print-manager-15.08.1-16.1.x86_64

    [ ] break kde-print-manager-15.08.1-16.1.x86_64 by ignoring some of its dependencies

    [ ] do not install kde-print-manager-15.08.1-16.1.x86_64



    nothing provides libexiv2.so.14()(64bit) needed by kdebase4-runtime-15.08.1-1.4.x86_64

    [ ] break kdebase4-runtime-15.08.1-1.4.x86_64 by ignoring some of its dependencies

    [ ] do not install kdebase4-runtime-15.08.1-1.4.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kompare-15.08.1-1.3.x86_64

    [ ] break kompare-15.08.1-1.3.x86_64 by ignoring some of its dependencies

    [ ] do not install kompare-15.08.1-1.3.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by konsole-15.08.1-1.2.x86_64

    [ ] break konsole-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install konsole-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by konsole-part-15.08.1-1.2.x86_64

    [ ] break konsole-part-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install konsole-part-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kruler-15.08.1-1.2.x86_64

    [ ] break kruler-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install kruler-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by libkerfuffle15-15.08.1-1.2.x86_64

    [ ] do not install libkerfuffle15-15.08.1-1.2.x86_64

    [ ] break libkerfuffle15-15.08.1-1.2.x86_64 by ignoring some of its dependencies



    nothing provides libexiv2.so.14()(64bit) needed by libkexiv2-11-15.08.1-1.2.x86_64

    [ ] break libkexiv2-11-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install libkexiv2-11-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by libkomparediff2-5-15.08.1-1.2.x86_64

    [ ] break libkomparediff2-5-15.08.1-1.2.x86_64 by ignoring some of its dependencies

    [ ] do not install libkomparediff2-5-15.08.1-1.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by dolphin-part-15.08.1-3.2.x86_64

    [ ] break dolphin-part-15.08.1-3.2.x86_64 by ignoring some of its dependencies

    [ ] do not install dolphin-part-15.08.1-3.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by dolphin-plugins-15.08.1-1.4.x86_64

    [ ] do not install dolphin-plugins-15.08.1-1.4.x86_64

    [ ] break dolphin-plugins-15.08.1-1.4.x86_64 by ignoring some of its dependencies



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kate-15.08.1-2.5.x86_64

    [ ] do not install kate-15.08.1-2.5.x86_64

    [ ] break kate-15.08.1-2.5.x86_64 by ignoring some of its dependencies



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kate-plugins-15.08.1-2.5.x86_64

    [ ] break kate-plugins-15.08.1-2.5.x86_64 by ignoring some of its dependencies

    [ ] do not install kate-plugins-15.08.1-2.5.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kcalc-15.08.1-1.5.x86_64

    [ ] do not install kcalc-15.08.1-1.5.x86_64

    [ ] break kcalc-15.08.1-1.5.x86_64 by ignoring some of its dependencies



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kio-extras5-15.08.1-1.3.x86_64

    [ ] do not install kio-extras5-15.08.1-1.3.x86_64

    [ ] break kio-extras5-15.08.1-1.3.x86_64 by ignoring some of its dependencies



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kmix-15.08.1-2.3.x86_64

    [ ] break kmix-15.08.1-2.3.x86_64 by ignoring some of its dependencies

    [ ] do not install kmix-15.08.1-2.3.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kpat-15.08.1-2.3.x86_64

    [ ] break kpat-15.08.1-2.3.x86_64 by ignoring some of its dependencies

    [ ] do not install kpat-15.08.1-2.3.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kwrite-15.08.1-2.5.x86_64

    [ ] break kwrite-15.08.1-2.5.x86_64 by ignoring some of its dependencies

    [ ] do not install kwrite-15.08.1-2.5.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by libdolphinvcs5-15.08.1-3.2.x86_64

    [ ] break libdolphinvcs5-15.08.1-3.2.x86_64 by ignoring some of its dependencies

    [ ] do not install libdolphinvcs5-15.08.1-3.2.x86_64



    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by libkf5kdegames6-15.08.1-1.9.x86_64

    [ ] do not install libkf5kdegames6-15.08.1-1.9.x86_64

    [ ] break libkf5kdegames6-15.08.1-1.9.x86_64 by ignoring some of its dependencies




    #### YaST2 conflicts list END ###

  2. #2

    Default Re: Update conficts

    Quote Originally Posted by GJElde View Post
    I have several online update conflicts!
    And what repos have you configured?
    Code:
    zypper lr -d
    Neither Qt5.5 nor KDE Applications 15.08.1 are part of openSUSE 13.2...

  3. #3
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    119

    Default Re: Update conficts

    Quote Originally Posted by wolfi323 View Post
    And what repos have you configured?
    Code:
    zypper lr -d
    Neither Qt5.5 nor KDE Applications 15.08.1 are part of openSUSE 13.2...
    # | Alias | Naam | Ingeschakeld | GPG-controle | Vernieuwen | Prioriteit | Type | URI | Service
    ---+------------------------------------+-------------------------------------------+--------------+--------------+------------+------------+--------+------------------------------------------------------------------------------+--------
    1 | Compiz | Compiz | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    2 | KDE_Applications | KDE Applications | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    3 | KDE_Extra | KDE Extra | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    4 | Packman Repository | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/ |
    5 | VLC | VLC | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.videolan.org/SuSE/13.2/ |
    6 | Virtualization | Virtualization | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    7 | X11_XOrg | X11 XOrg | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    8 | download.opensuse.org-13.2-non-oss | Installatiebron voor bijwerken (niet-Oss) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |
    9 | download.opensuse.org-4.3 | openSUSE BuildService - LibreOffice | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    10 | download.opensuse.org-Apps | openSUSE BuildService - GNOME:Apps | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    11 | download.opensuse.org-Wine | openSUSE BuildService - Wine CVS Builds | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    12 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    13 | download.opensuse.org-non-oss | Hoofd-installatiebron (niet-opensource) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    14 | download.opensuse.org-oss | Hoofd-installatiebron (opensource) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    15 | download.opensuse.org-oss_1 | Hoofd-installatiebron (broncode) | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/source/...13.2/repo/oss/ |
    16 | download.opensuse.org-packages | openSUSE BuildService - Java pakketten | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    17 | download.opensuse.org-update | Hoofd-installatiebron voor bijwerken | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    18 | nntpgrab | nntpgrab | Ja | (r ) Ja | Ja | 99 | rpm-md | http://www.nntpgrab.nl/releases/openSUSE_13.1 |
    19 | openSUSE-13.2-0 | openSUSE-13.2-0 | Nee | ---- | Nee | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-224BB_R8WS6GAD1029T8 |
    20 | openSUSE-13.2-DVD-x86_64.iso | openSUSE-13.2-DVD-x86_64.iso | Ja | (r ) Ja | Nee | 99 | yast2 | iso:///?iso=openSUSE-13.2-DVD-x86_64.iso&url=file:///diversen/backup/CD%201/ |
    21 | opensuse-guide.org-repo | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
    22 | packman | packman | Nee | ---- | Nee | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/ |
    23 | repo-debug | openSUSE-13.2-Debug | Nee | ---- | Ja | 99 | NONE | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    24 | repo-debug-update | openSUSE-13.2-Update-Debug | Nee | ---- | Ja | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
    25 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Nee | ---- | Ja | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ |
    26 | security | security | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |

  4. #4
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    119

    Default Re: Update conficts

    This is the problem i think

    2 | KDE_Applications | KDE Applications | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |


    I add the qt 5.5 repo , but is did not worked.....

    So i have to wait for 42.1.
    Than a fresh install.......

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,048
    Blog Entries
    14

    Default Re: Update conficts

    Quote Originally Posted by GJElde View Post
    This is the problem i think
    The problem is that your packages are coming from > 20 repos. We cannot see whether you "dupped" from these repos, or just picked individual packages from those. Adding the QT5.5 repo could fix this, but your making the list of repos even bigger, and hence actually making it more difficult to keep all dependencies satisfied.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Update conficts

    Quote Originally Posted by GJElde View Post
    This is the problem i think

    2 | KDE_Applications | KDE Applications | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    Yes.

    I add the qt 5.5 repo , but is did not worked.....

    So i have to wait for 42.1.
    Not really.
    KDE:Applications for 13.2 is built against KDE:Frameworks5 since recently, as many packages did not build any more with the outdated Frameworks packages included in the standard repos.
    So you need to add that repo too (along with KDE:Qt5), and it should work.

    Another note:
    I see you have both Packman and the VLC repo in your list. That's not a good idea, those repos are incompatible (they contain the same stuff in different versions).
    I would suggest to *remove* the VLC repo (#5), everything in there (and more) is available in Packman too.

  7. #7
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    119

    Thumbs up Re: Update conficts

    Quote Originally Posted by wolfi323 View Post
    Yes.


    Not really.
    KDE:Applications for 13.2 is built against KDE:Frameworks5 since recently, as many packages did not build any more with the outdated Frameworks packages included in the standard repos.
    So you need to add that repo too (along with KDE:Qt5), and it should work.
    I did and most off the conflicts are solved.

    Another note:
    I see you have both Packman and the VLC repo in your list. That's not a good idea, those repos are incompatible (they contain the same stuff in different versions).
    I would suggest to *remove* the VLC repo (#5), everything in there (and more) is available in Packman too.
    Thanks for the suggestion.


    Thanks all for the help......

  8. #8

    Default Re: Update conficts

    Quote Originally Posted by GJElde View Post
    I did and most off the conflicts are solved.
    Most?
    Does that mean there still are some?

  9. #9
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    119

    Default Re: Update conficts

    Quote Originally Posted by wolfi323 View Post
    Most?
    Does that mean there still are some?
    Just these 3......if i am right, not sure.....

    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by kio-extras5-15.08.1-1.3.x86_64
    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by dolphin-part-15.08.1-3.2.x86_64
    nothing provides libQt5Core.so.5(Qt_5.5)(64bit) needed by baloo5-widgets-15.08.1-8.1.x86_64

    here the update history, i think it were the last 3 or 4..

    2015-10-07 12:40:49|install|kio-extras5|15.08.1-61.1|x86_64|root@linux-002k|Frameworks5|f1b629f7cd49a1b834b64f26398ea2be6d0bcc8db1403cc8eb226747b72f87ef|
    2015-10-07 12:40:49|install|libKF5BalooEngine5|5.14.0-72.1|x86_64||Frameworks5|da226816d25cc4416914818e692096d56f7368013fc4f488f914e2912fd8de71|
    2015-10-07 12:40:49|install|libKF5Baloo5|5.14.0-72.1|x86_64||Frameworks5|6bd1413bfa8605c46fd8cad967ad0e791cdbaa694918b5df0eb8f0ce02ffd48e|
    2015-10-07 12:40:50|install|baloo5-widgets|15.08.1-8.1|x86_64|root@linux-002k|KDE_Applications|f37e430a7aaa0af09c995f137167d7cf62835b7d0c7671340374a55476f215e4|
    2015-10-07 12:40:50|install|dolphin-part|15.08.1-3.3|x86_64|root@linux-002k|KDE_Applications|55d59713a199f00ad927ec49df3c92da5912681f636d4c1d7c36a5fb02ac1b74|


    I overruled them....
    No problems yet...

    And when 42.1 is out, i do a complete fresh install.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •