Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Renaming 'Documents' to 'documents' (lowercase)

  1. #1

    Question Renaming 'Documents' to 'documents' (lowercase)

    Hi,

    I have renamed my /home/user/Documents to /home/user/documents (lowercase)

    However after some time I notice some program creates again an empty Documents directory and I can't find which one.

    How can I tell openSUSE to keep it lowercase and not create again Documents?
    Generally is it possible to tell it to keep all default home directories lowercase (during OS install or right after it)?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by heyjoe View Post
    Hi,

    I have renamed my /home/user/Documents to /home/user/documents (lowercase)

    However after some time I notice some program creates again an empty Documents directory and I can't find which one.

    How can I tell openSUSE to keep it lowercase and not create again Documents?
    Generally is it possible to tell it to keep all default home directories lowercase (during OS install or right after it)?
    Are you aware of the fact that linux is case sensitive?
    Of course this can be done, one way or another. Question remains: what's wrong with the default?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    How can I tell openSUSE to keep it lowercase and not create again Documents?
    Generally is it possible to tell it to keep all default home directories lowercase (during OS install or right after it)?
    If you are using KDE, you can set the path to the "Documents" folder in "Configure Desktop"->"User Account Details"->"Paths".

    Other desktop environments might offer a similar setting, or modify ~/.config/user-dirs.dirs with a text editor.
    Last edited by wolfi323; 06-Oct-2015 at 03:25.

  4. #4

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by Knurpht View Post
    Are you aware of the fact that linux is case sensitive?
    Sure.

    Quote Originally Posted by wolfi323 View Post
    If you are using KDE, you can set the path to the "Documents" folder in "Configure Desktop"->"User Account Details"->"Paths".

    Other desktop environments might offer a similar setting, or modify ~/.config/user-dirs.dirs with a text editor.
    Yes, I have done that already. It is lowercase in there but the capitalized directory keeps on self-creating.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by heyjoe View Post
    Sure.


    Yes, I have done that already. It is lowercase in there but the capitalized directory keeps on self-creating.
    Did you logout and login after changing this? These are settings read on the desktop's start AFAIK.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    In /etc/xdg/user-dirs.default this is set too.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by heyjoe View Post
    Yes, I have done that already. It is lowercase in there but the capitalized directory keeps on self-creating.
    Can you post your ~/.config/user-dirs.dirs?
    Maybe some other path is still set to ~/Documents/.

    Quote Originally Posted by Knurpht View Post
    In /etc/xdg/user-dirs.default this is set too.
    Yes, but that's just the default, and is overridden by ~/.config/user-dirs.dirs.

  8. #8

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by Knurpht View Post
    Did you logout and login after changing this? These are settings read on the desktop's start AFAIK.
    The machine has been rebooted hundreds of times since then.

    In /etc/xdg/user-dirs.default this is set too.
    Code:
    cat /etc/xdg/user-dirs.default 
    cat: /etc/xdg/user-dirs.default: No such file or directory
    Quote Originally Posted by wolfi323 View Post
    Can you post your ~/.config/user-dirs.dirs?
    Code:
    cat ~/.config/user-dirs.dirs
    XDG_DESKTOP_DIR="$HOME/desktop/"
    XDG_DOCUMENTS_DIR="$HOME/documents"
    XDG_DOWNLOAD_DIR="$HOME/"
    XDG_MUSIC_DIR="$HOME/music"
    XDG_PICTURES_DIR="$HOME/pictures"
    XDG_PUBLICSHARE_DIR="$HOME/Public"
    XDG_TEMPLATES_DIR="$HOME/Templates"
    XDG_VIDEOS_DIR="$HOME/videos"

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,396

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by heyjoe View Post
    However after some time I notice some program creates again an empty Documents directory and I can't find which one.
    This most probably done by the desktop environment you use (at login into that desktop). You did not explain which one you use
    Quote Originally Posted by heyjoe View Post
    How can I tell openSUSE to keep it lowercase and not create again Documents?
    You can't. It is not an openSUSE feature, as said above it is the desktop.
    Quote Originally Posted by heyjoe View Post
    Generally is it possible to tell it to keep all default home directories lowercase (during OS install or right after it)?
    Home dirctories normaly have the username as file name. Thus, when you, as system administrator, create a new user, do not use capitals in tthe username, then the home directory will also not have them in it's name.

    This last one is btw a different question from the earlier ones. The earlier ones are in the realm of the individual user and (s)he can try to bend his/her environments to her/his liking. The last question hasn't anything to do with the desktop, but with system administration.

    BTW, while it may be possible, depending on the desktop, to change names of standard desktop directories like Documents, Downloads, etc. (after all they are different when you use a different language), it may be opening a can of worms.
    Henk van Velden

  10. #10

    Default Re: Renaming 'Documents' to 'documents' (lowercase)

    Quote Originally Posted by hcvv View Post
    This most probably done by the desktop environment you use (at login into that desktop). You did not explain which one you use
    I use KDE.

    Thus, when you, as system administrator, create a new user, do not use capitals in tthe username, then the home directory will also not have them in it's name.
    I understand that. Perhaps the question was not clear: I am asking about the directories inside the home directory.

    it may be opening a can of worms.
    Could you explain?

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •