Results 1 to 9 of 9

Thread: About "Read-only file system" error

  1. #1

    Default About "Read-only file system" error

    Hi everybody,

    Today (02.10.2015) i installed last software update and after restarted system. when i tried to start mysql (mariadb) service by systemctl start mysql.service i received fallowing error :

    Job for mysql.service failed. See "systemctl status mysql.service" and "journalctl -xn" for details.

    after the error, i checked journalctl -xn and i received these messages

    -- Logs begin at Tue 2015-08-11 00:37:23 EEST, end at Fri 2015-10-02 22:18:19 EEST. --
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] InnoDB: The system tablespace must be writable!
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Plugin 'InnoDB' init function returned error.
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] mysqld: File '/var/lib/mysql/aria_log_control' not found (Errcode: 30 "Read-only file syste
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] mysqld: Got error 'Can't open file' when trying to use aria control file '/var/lib/mysql/ar
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Plugin 'Aria' init function returned error.
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Plugin 'Aria' registration as a STORAGE ENGINE failed.
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Unknown/unsupported storage engine: InnoDB
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [ERROR] Aborting
    Oct 02 22:18:19 linux-0f67.site mysql-systemd-helper[3035]: 151002 22:18:19 [Note] /usr/sbin/mysqld: Shutdown complete


    after that i checked aria_log_control file and it was exist in /var/lib/mysql/ directory but i received this error. I checked permissions this directory by ls -l /var/lib/mysql , i displayed

    total 176156
    -rw-rw---- 1 mysql mysql 16384 Oct 2 17:39 aria_log.00000001
    -rw-rw---- 1 mysql mysql 52 Oct 2 17:39 aria_log_control
    -rw-rw---- 1 mysql mysql 79691776 Oct 2 17:39 ibdata1
    -rw-rw---- 1 mysql mysql 50331648 Oct 2 17:39 ib_logfile0
    -rw-rw---- 1 mysql mysql 50331648 Aug 11 08:23 ib_logfile1
    -rw-r----- 1 mysql mysql 1675 Aug 11 08:29 linux-0f67.site.err
    -rw-rw---- 1 mysql mysql 0 Aug 11 08:23 multi-master.info
    drwx------ 1 mysql root 2600 Sep 28 11:36 mysql
    -rw-r--r-- 1 root root 4 Sep 28 11:36 mysql_upgrade_info
    drwx------ 1 mysql mysql 1476 Sep 30 06:49 ORDERMANAPP
    drwx------ 1 mysql mysql 852 Aug 17 15:26 ORDERMANCOMP
    drwx------ 1 mysql mysql 3296 Sep 28 11:36 performance_schema
    drwx------ 1 mysql root 0 Aug 11 08:23 test

    is the permissions true ? and if it is true, why the error happens and İ failed to start mysql service ? I never seen this error before todey's software update install.

    Thanks, regards.

  2. #2

    Default Re: About "Read-only file system" error

    Quote Originally Posted by ykasap View Post
    is the permissions true ?
    Yes.

    and if it is true, why the error happens and İ failed to start mysql service ? I never seen this error before todey's software update install.
    Apparently your / filesystem is mounted read-only.
    Check the output of "mount".

    One of the changes of the latest systemd update is that it respects the "ro" boot option now and does indeed mount the root partition read-only if that option is present. Before it was just ignored.
    Enter YaST->System->Boot Loader->Kernel-Parameter and remove the option if it is there, and the problems should be fixed.

    If that's not the case, probably the filesystem is corrupt/has errors.
    "dmesg" should tell.
    Last edited by wolfi323; 02-Oct-2015 at 13:04.

  3. #3

    Default Re: About "Read-only file system" error

    Hi wolfi323,

    Thanks for your explanations. I looked kernel parameters on YaST->System->Boot Loader but i didn't see the option.

    Optional kernel command line parameter :

    resume=/dev/disk/by-uuid/b1c99bf9-83ad-40b2-9013-a14bb23bd2eb splash=silent quiet showopts

    and

    failsafe kernel command line parameter :

    showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe

    and use graphical console and use serial console options exist in the same window.

    Quote Originally Posted by wolfi323 View Post
    Yes.


    Apparently your / filesystem is mounted read-only.
    Check the output of "mount".

    One of the changes of the latest systemd update is that it respects the "ro" boot option now and does indeed mount the root partition read-only if that option is present. Before it was just ignored.
    Enter YaST->System->Boot Loader->Kernel-Parameter and remove the option if it is there, and the problems should be fixed.

    If that's not the case, probably the filesystem is corrupt/has errors.
    "dmesg" should tell.

  4. #4

    Default Re: About "Read-only file system" error

    Quote Originally Posted by ykasap View Post
    Optional kernel command line parameter :
    They are ok.

    Hm, so does mount show '/' as "ro"?
    Does dmesg show any signs of filesystem corruption?

    Does maybe "sudo mount / -o remount,rw" help?

    A bug report is here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=948555

    The reporter did have "ro" on the kernel command line, and removing it fixed his problem.
    But the last commenter doesn't mention that, so maybe there's a more general problem...

    Apparently the update has been withdrawn too, so try to downgrade systemd and udev to version 210-25.16.1.
    I hope the above mount will enable you to do this.

  5. #5

    Default Re: About "Read-only file system" error

    Yes, mount "/" as ro
    dmesg didn't show any corruption but it receives "[ 57.852820] systemd-readahead[426]: Failed to open pack file: Read-only file system" message on one place.

    I tried to sudo mount / -o remount,rw command but i got

    sudo: unable to mkdir /var/lib/sudo: Read-only file system
    sudo: unable to mkdir /var/lib/sudo: Read-only file system

    errors. Maybe according to bug report, downgrading system under 210-25.19.1, read only mount problem will fix. My last question how can I downgrade system under to 210-25.19.1 on esiest way ?

    Thanks for your help.

    Quote Originally Posted by wolfi323 View Post
    They are ok.

    Hm, so does mount show '/' as "ro"?
    Does dmesg show any signs of filesystem corruption?

    Does maybe "sudo mount / -o remount,rw" help?

    A bug report is here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=948555

    The reporter did have "ro" on the kernel command line, and removing it fixed his problem.
    But the last commenter doesn't mention that, so maybe there's a more general problem...

    Apparently the update has been withdrawn too, so try to downgrade systemd and udev to version 210-25.16.1.
    I hope the above mount will enable you to do this.

  6. #6

    Default Re: About "Read-only file system" error

    Quote Originally Posted by ykasap View Post
    Yes, mount "/" as ro
    dmesg didn't show any corruption but it receives "[ 57.852820] systemd-readahead[426]: Failed to open pack file: Read-only file system" message on one place.
    So it is read-only quite early in the boot already.

    I tried to sudo mount / -o remount,rw command but i got

    sudo: unable to mkdir /var/lib/sudo: Read-only file system
    sudo: unable to mkdir /var/lib/sudo: Read-only file system
    Ok, sudo doesn't work with a read-only root.
    Login as root (preferably in text mode), and run "mount / -o remount,rw" then instead.

    Maybe according to bug report, downgrading system under 210-25.19.1, read only mount problem will fix.
    Yeah, should help.

    My last question how can I downgrade system under to 210-25.19.1 on esiest way ?
    Well, if the above remount works, you can just use YaST e.g.
    Select the packages systemd and udevd and choose "Update Unconditionally", or choose the version on the "Versions" tab below the package list.

    If the above doesn't work, I don't think there is an "easy" way, as you obviously need to be able to write to the file system.
    As I didn't see a problem with the update myself (I don't have the update installed here because it already was retracted when I came home, but I did install it on another system and rebooted, I had no problems there), I'm not sure what goes wrong or how to fix it either.

    One option would be to boot from a LiveCD or similar, download the old packages from the update repo, and install them with rpm using the "--root" parameter.
    Or maybe you could even chroot to the installed system and use zypper or YaST then (I'm not completely sure that will work).

    Or if you don't have a LiveCD handy:
    - download the packages
    - then boot with "rd.break" to interrupt the boot process before the system is switched to the actual root on the hard disk
    - remount / read-write with "mount /sysroot -o rw,remount"
    - switch to the installed system with "chroot /sysroot"
    - install the packages with "rpm -U --oldpackage xxx.rpm" (you may need to mount the partition where you downloaded the packages to first of course)
    The update repo is here:
    http://download.opensuse.org/update/13.2/

    Or maybe ask the guy in the bug report how he downgraded.
    You can login at bugzilla with the same username/password as here.

  7. #7

    Default Re: About "Read-only file system" error

    I have the same problem. It is possible to boot to working system if in grub menu I press "e" to edit the command line and remove the `ro` option in the options line (then press F10 to boot). Now I just have to figure out how to persist this change so I don't have to edit the line every time I boot.

  8. #8

    Default Re: About "Read-only file system" error

    Quote Originally Posted by juhope View Post
    I have the same problem. It is possible to boot to working system if in grub menu I press "e" to edit the command line and remove the `ro` option in the options line (then press F10 to boot). Now I just have to figure out how to persist this change so I don't have to edit the line every time I boot.
    For the record, using yast software manager and searching for systemd and udevd and marking "update unconditionally" for packages that have newer versions installed than are in repositories seems to have fixed this for me.

  9. #9

    Default Re: About "Read-only file system" error

    Hi wolfi323 and juhope,

    Thanks for your help. I solved this problem and able to start mysql service again

    Fist i tried to make update unconditionally systemd and udevd packages on yast software management (I have no udevd packages). Progress started and new packages downloaded from repo site but these new packages didn't install and error popup shown. I thougth later why the packages installation failed and I figured out "/" directory was read only mounted. In terminal window i logged as root and run mount / -o remount,rw command to make root directory as rewritable. After that run update unconditionally systemd packages on yast and reboot system, everything has been OK.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •