Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Autodesk Maya 2015 Graphics Card issue

  1. #1

    Default Autodesk Maya 2015 Graphics Card issue

    Hello, I am new to OpenSUSE and have installed Autodesk Maya 2015. It works pretty well, although I can't get Viewport 2.0 to work, it gives me this error message:

    // Warning: Viewport 2.0 is not supported by your current graphics configuration or graphics driver version.
    The application is reverting to the legacy default viewport, please correct your graphics configuration or set the "Default viewport" preference to "Legacy Default Viewport" to prevent this error from recurring. //

    I know my graphics hardware supports this feature, because I ran the Windows version of Autodesk Maya on the same computer without a problem. So this must be a driver / configuration problem.

    I have put information about the graphics card etc below. Can anybody recommend what I should do to configure my graphics appropriately? I tried to download NVIDA drivers the last time I had OpenSUSE installed but it messed everything up. Any advice would be appreciated.

    Thanks!



    My Graphics Card: NVIDIA GeForce GT650M
    Computer: Asus N56VZ

    Some information from terminal about my graphics hardware etc:
    /sbin/lspci -nnk | grep VGA -A2
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
    Subsystem: ASUSTeK Computer Inc. N56VZ [1043:2103]
    Kernel driver in use: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 650M] [10de:0fd1] (rev a1)
    Subsystem: ASUSTeK Computer Inc. N56VZ [1043:2103]
    Kernel driver in use: nouveau

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Did you install the the NVIDIA driver??

    https://en.opensuse.org/SDB:NVIDIA_drivers

    You will want the GO4 flavour of driver

    Note if this is a notebook and has Optimus hardware (Intel+NVIDIA GPU) You need to use bumblebee see info on the page above. DO NOT USE THE REGULAR NVIDIA DRIVER!


    My guess is that it is Optimus (most notebooks with hybrid graphics are) It is hard to say for sure from the published specs

  3. #3

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Oh great thank you. I have an Intel i7 and the NVIDA GPU. So that means I can download bumblebee and it should be ok?

    When I searched on Yast Software Manager I found 'bumblebee' and 'bbswitch'. Do I need both or just the one named bumblebee?

    Edit: No I didn't install any graphics drivers. The only ones on here are the ones that came automatically with the OpenSUSE installation.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Did you follow the bumblebee instruction on the page I referenced?

    You can install the nvidia-bumblebee package which is a special set up to install a modified nvidia package that will work with optimus setups

    DO NOT INSTALL THE REGULAR NVIDIA DRIVER!!!!

  5. #5

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Quote Originally Posted by gogalthorp View Post
    Did you follow the bumblebee instruction on the page I referenced?

    You can install the nvidia-bumblebee package which is a special set up to install a modified nvidia package that will work with optimus setups

    DO NOT INSTALL THE REGULAR NVIDIA DRIVER!!!!
    Code:
    Retrieving repository 'Bumblebee' metadata ..............................[error]
    Repository 'Bumblebee' is invalid.
    [Bumblebee|http://download.opensuse.org/repositories/X11/Bumblebee/openSUSE_13.2] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Disabling repository 'Bumblebee' because of the above error.
    Empty destination in URI: hd:///?device=/dev/disk/by-id/scsi-1USB_DISK_2.0-part2
    I have Bumblebee and bbswitch installed now. I just got to the part where I should enable nvida-bumblebee X11. There is nothing at the URL it is trying to get metadata from. Do you know anything about this?

  6. #6

    Default Re: Autodesk Maya 2015 Graphics Card issue

    I'm not sure what's happened now. I've been up all night trying to get this graphics card running properly but still nothing promising. This is what I'm getting every time I do the checks to see if it's running:

    Code:
    Error (3.2.1): [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
    I've enabled video and bumblebee for my user and installed everything needed from Yast as far as I'm aware.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Well I don't have an Optimus system so can't check. Did you get the nvidia-bumblebee packages installed or not it is unclear??? Did you first remove an trace of the normal nvidia driver package? You must remove all before installing nvidia-bumblebee. You can do that from yast-software management

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,861
    Blog Entries
    14

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Quote Originally Posted by mrddee View Post
    I'm not sure what's happened now. I've been up all night trying to get this graphics card running properly but still nothing promising. This is what I'm getting every time I do the checks to see if it's running:

    Code:
    Error (3.2.1): [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
    I've enabled video and bumblebee for my user and installed everything needed from Yast as far as I'm aware.
    Did you logout and login after adding your user to these groups? If not, do so, or reboot.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,861
    Blog Entries
    14

    Default Re: Autodesk Maya 2015 Graphics Card issue

    You first have to check whether bumblebee runs:
    Code:
    systemctl status bumblebeed.service
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: Autodesk Maya 2015 Graphics Card issue

    Quote Originally Posted by Knurpht View Post
    You first have to check whether bumblebee runs
    I just checked. It seems to be running but I can't access the graphics card?
    I double checked the user and rebooted my computer and it definitely has access to video and bumblebee.

    Is there perhaps something else I need to activate? When I check the status of optirun it tells me 'discrete video card is off'.

    Code:
    david@linux-c75e:~> systemctl status bumblebeed.service
    bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
       Active: active (running) since Thu 2015-10-01 20:09:46 CEST; 17min ago
     Main PID: 1436 (bumblebeed)
       CGroup: /system.slice/bumblebeed.service
               └─1436 /usr/sbin/bumblebeed
    
    david@linux-c75e:~> optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    david@linux-c75e:~>  optirun glxspheres
    [ 1150.119355] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
    
    [ 1150.119393] [ERROR]Aborting because fallback start is disabled.
    david@linux-c75e:~>

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •