Results 1 to 8 of 8

Thread: LibreOffice not inheriting the system font, icon, menu setting.

  1. #1

    Default LibreOffice not inheriting the system font, icon, menu setting.

    Desktop: KDE

    Unlike every other application I have opened, LibreOffice does not appear to inherit the system font, icons and menus. Tools->Options->LIbreOffice->View->Use system font for user interface is selected; Tools->Options->LIbreOffice->View->Scaling doesn't really cut it. What do I need to do to get LibrreOffice using the system settings like every other application?

  2. #2

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Are you using the standard KDE4 included in 13.2?
    Then make sure you have the package "libreoffice-kde4" installed, LO should respect the KDE4 settings then.

    And also make sure you don't have "ibus" installed, this disables libreoffice-kde4 for certain reasons...

  3. #3

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Standard openSUSE 13.2, currently reported version is KDE 4.14.9; already had libreoffice-kde4 installed; ibus has never been installed.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,476
    Blog Entries
    14

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    You need the gtk2-engine + gtk3-engine + kcm-gtk-config packages to be installed. Plus f.e. gtk2-theme-oxygen and gtk3-theme-oxygen.
    Use Configure Desktop to change the gtk theme to oxygen-gtk and you'll have Firefox and others in your KDE style.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Installing packages didn't make any difference.

  6. #6

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Quote Originally Posted by Knurpht View Post
    You need the gtk2-engine + gtk3-engine + kcm-gtk-config packages to be installed. Plus f.e. gtk2-theme-oxygen and gtk3-theme-oxygen.
    Use Configure Desktop to change the gtk theme to oxygen-gtk and you'll have Firefox and others in your KDE style.
    This is only relevant if you use LibreOffice with the GNOME integration.
    I.e. you have libreoffice-gnome installed, and either:
    • run LO inside GNOME, not KDE
    • uninstall libreoffice-kde4

    or

    • install ibus which disables the KDE integration.


    You could try to uninstall libreoffice-kde4 (and install libreoffice-gnome if it is not installed) and see if it is better then.

    But TBH, I'm not sure I understand the original problem completely.
    Could you maybe post a screenshot to clarify?
    And please also post what libreoffice packages you have installed:
    Code:
    rpm -q libreoffice*
    Just to be clear: LibreOffice e.g. has its own icon sets, it doesn't use the one from the "system". By default it tries to use a matching one to the one that is configured for your Desktop, but this might not exist and it would have to fall back to a different one.
    So it would also be interesting what are your desktop settings actually, i.e. what icon theme and widget style.

    And also, what exactly do you mean with KDE?
    The standard KDE4 or the new Plasma5?

    Does it "work" with a fresh user account?
    Last edited by wolfi323; 01-Oct-2015 at 14:03.

  7. #7

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Quote Originally Posted by Addanc View Post
    Desktop: KDE

    Unlike every other application I have opened, LibreOffice does not appear to inherit the system font, icons and menus. Tools->Options->LIbreOffice->View->Use system font for user interface is selected; Tools->Options->LIbreOffice->View->Scaling doesn't really cut it. What do I need to do to get LibrreOffice using the system settings like every other application?

    I had the same/similar problem, i.e. KDE-integration completely gone for LibreOffice (but not for OpenOffice!).

    De-installing ibus *did* the trick for me (like Wolffi suggested). Don't know how this found its way onto my system (13.1) but now that it's gone LO-integration is fine again.

    libreoffice-kde4 must be installed, of course.

    Regards!

  8. #8

    Default Re: LibreOffice not inheriting the system font, icon, menu setting.

    Quote Originally Posted by Imaginator View Post
    I had the same/similar problem, i.e. KDE-integration completely gone for LibreOffice (but not for OpenOffice!).
    Yeah, I suppose OpenOffice doesn't respect the same environment variables as LibreOffice any more...

    De-installing ibus *did* the trick for me (like Wolffi suggested). Don't know how this found its way onto my system (13.1) but now that it's gone LO-integration is fine again.
    IIANM, libreoffice-gnome pulls it in.
    But it's just "recommended", so you can uninstall it...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •