Results 1 to 10 of 10

Thread: Can't install Rubyripper GUI

  1. #1
    corgi NNTP User

    Question Can't install Rubyripper GUI

    I can't install Rubyripper GUI from the repository, I get this error:



    The command line version can be installed, however I haven't used it. I'm looking for graphical interface.
    I've tried breaking dependencies but the program doesn't start. I don't really want to look for alternatives, since I want a "identical" CD rip.

    I have never installed software from source.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Can't install Rubyripper GUI

    Hi
    You need to ask the packager (since it's a home repo) to fix the build...
    https://build.opensuse.org/package/s...Kent/ruby-gtk2
    See the changelog for email address.....
    https://build.opensuse.org/package/v...anges?expand=1
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    corgi NNTP User

    Question Re: Can't install Rubyripper GUI

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to ask the packager (since it's a home repo) to fix the build...
    https://build.opensuse.org/package/s...Kent/ruby-gtk2
    See the changelog for email address.....
    https://build.opensuse.org/package/v...anges?expand=1
    So "Kyrill Detinov (Lazy_Kent)" is the packager? How do I contact him?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Can't install Rubyripper GUI

    Quote Originally Posted by corgi View Post
    So "Kyrill Detinov (Lazy_Kent)" is the packager? How do I contact him?
    Hi
    Either via the email address in the second link, since he is also a forum moderator, send him a PM
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: Can't install Rubyripper GUI

    Do you know that it isn't already in the special openSUSE Ruby repo?
    Or, available if you download it from the official Ruby repos?

    If you encounter errors like what you describe, I doubt you're setting up your Ruby environment correctly.

    In my write-up, it describes how to set up and use the openSUSE Ruby repo, or optionally set up to use Ruby from the official Ruby repos using a Ruby versioner (rbenv) so that you can "scope" or run different Ruby versions on your machine

    https://en.opensuse.org/User:Tsu2/Install_Ruby

    TSU

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Can't install Rubyripper GUI

    Quote Originally Posted by tsu2 View Post
    Do you know that it isn't already in the special openSUSE Ruby repo?
    Hi
    The mighty command line tool osc It tells everything you need to know about packages on OBS...

    Code:
    osc se rubyripper
    
    No matches found for 'rubyripper' in projects
    ####################################################################
    matches for 'rubyripper' in packages:
    
    # Project                            # Package
    home:Lazy_Kent                       rubyripper
    home:roman-neuhauser:arch-community  rubyripper
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: Can't install Rubyripper GUI

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The mighty command line tool osc It tells everything you need to know about packages on OBS...

    Code:
    osc se rubyripper
    
    No matches found for 'rubyripper' in projects
    ####################################################################
    matches for 'rubyripper' in packages:
    
    # Project                            # Package
    home:Lazy_Kent                       rubyripper
    home:roman-neuhauser:arch-community  rubyripper

    As I described,
    If a working build doesn't exist in OBS anywhere, it's likely available as a ruby gem.
    Set up the Ruby environment created from the official Ruby repos as I describe in my article and download and install the gem.

    Ruby as it's set up in openSUSE is a convenience, but the Ruby repos in general should be considered the most complete source for Ruby apps.

    TSU

  8. #8
    corgi NNTP User

    Question Re: Can't install Rubyripper GUI

    Do I start by running this command("Install Ruby from the Ruby repos")?

    Code:
    git clone git://github.com/sstephenson/rbenv.git .rbenv
    And I get the latest 0.6.2 version of the Rubyripper GUI in the end right?

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Can't install Rubyripper GUI

    On Tue 29 Sep 2015 01:16:01 PM CDT, corgi wrote:


    Do I start by running this command("Install Ruby from the Ruby repos")?


    Code:
    --------------------
    git clone git://github.com/sstephenson/rbenv.git .rbenv
    --------------------


    And I get the latest 0.6.2 version of the Rubyripper GUI in the end
    right?


    Hi
    You only need to install the ruby version of gtk2. AFAIK if the ruby
    environment is installed you just need to run;

    Code:
    gem install gtk2
    https://rubygems.org/gems/gtk2/versions/3.0.5

    Wait for tsu2 to comment though before proceeding.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.44-52.18-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: Can't install Rubyripper GUI

    Quote Originally Posted by corgi View Post
    Do I start by running this command("Install Ruby from the Ruby repos")?

    Code:
    git clone git://github.com/sstephenson/rbenv.git .rbenv
    And I get the latest 0.6.2 version of the Rubyripper GUI in the end right?
    When you clone rbenv to the location of your choice,
    The next step will be to download a complete ruby environment/version of your choice.
    This new environment is completely self-contained and is installed in its own separate location in a subdirectory of rbenv so that it doesn't cause conflicts with Ruby from the OSS and you can even download multiple Ruby versions if you want which will all be stored separately in a similar way.
    Once your chosen Ruby has been downloaded, you can then execute the standard gem commands to query, install and otherwise manage gems from the Ruby repositories. When you use the gem package management system, it's completely separate from the YAST/zypper management system but shouldn't be an issue because your gems will run in the context of the chosen Ruby environment set by rbenv.

    If an app has been packaged as a Ruby gem, it will exist in the Ruby repositories.
    If a gem is popular enough, then a Maintainer may re-package the app and make it available either in a private OBS, the OSS, non-OSS or openSUSE Ruby repositories which are all separate and different than the official Ruby repos. These openSUSE packages can be found not by running the "gem" command but by "zypper se gem." But unless someone decides to package for openSUSE, it won't necessarily be found in our repos so there will be times when you need to use the official Ruby repos.

    Just follow my writeup installing rbenv and Ruby 2.2.1 (or later) from the official Ruby repos and you should be fine.
    BTW - It's simple to undo access to the Ruby Repos in the future if you wish... Simple delete the entire contents of rbenv, remove the path statements created in /etc/profile.d/ and reboot.

    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •