Results 1 to 6 of 6

Thread: libreoffice calc, backspace does not delete text in fields and dialogs

  1. #1

    Default libreoffice calc, backspace does not delete text in fields and dialogs

    I have an annoyance I noticed while using libreoffice calc. When I delete text in say the Name Box field it does not actually delete the text from view. It makes it hard because what you type types over the letters/numbers already there. The Name Box field works, however. I can backspace in the field then type A1:A5 and it will select A1-A5. But its hard to read when typing because it just types over what's there. I upgraded to the latest version in Libreoffice:4.4 repo --version 4.4.5.2-- to see if it corrected it. It did not. Don't have this problem in any other programs....might be in all of libreoffice programs, but I've only noticed it in libreoffice-calc

    Thanks for any ideas. Might try the 5.0.2.1 version in Libreoffice:Factory
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  2. #2

    Default Re: libreoffice calc, backspace does not delete text in fields and dialogs

    upgraded to libreoffice:factory repo --version 5.0.2.1.0. Still the same problem. Wondering if it's a dependency of it that is causing the issue.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  3. #3
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    427

    Default Re: libreoffice calc, backspace does not delete text in fields and dialogs

    I've got some other rendering issues in LO5 myself.
    Try this workaround:

    Code:
    SAL_USE_VCLPLUGIN=gen loffice"
    and tell us please, if it helps. Instead of "gen" you could also try "gtk2"; it looks better.

    Hendrik

  4. #4

    Default Re: libreoffice calc, backspace does not delete text in fields and dialogs

    Thanks for your time Hendrik

    I opened up a terminal (konsole) and typed
    Code:
    SAL_USE_VCLPLUGIN="gen loffice"
    libreoffice
    In libreoffice, chose spreadsheet and checked the Name Box, still didn't delete contents away from view

    I tried
    Code:
    SAL_USE_VCLPLUGIN="gtk2 loffice"
    as well as
    Code:
    SAL_USE_VCLPLUGIN="gtk3 loffice"
    neither had any impact on the Name Box.
    However, I just found out that resizing the window deletes the previous contents from view. Not a great workaround (resizing every time) but better than what I originally had.
    Have any more workarounds I can try for this problem? Oh and just to clarify, this problem is in 4.3.7.2, 4.4.5.2 and 5.0.2.1
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  5. #5
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    427

    Default Re: libreoffice calc, backspace does not delete text in fields and dialogs

    Sorry for my typos, but try it without quotation mark(s):

    Code:
     SAL_USE_VCLPLUGIN=gen loffice
    
    and maybe with "gtk" instead of "gtk2".

    That resizing solves this problem, indicates, that it is the one for my workaround.

    See
    https://bugzilla.suse.com/show_bug.cgi?id=941035
    and
    https://bugs.documentfoundation.org/...g.cgi?id=93194

    Hendrik

  6. #6

    Default Re: libreoffice calc, backspace does not delete text in fields and dialogs

    sorry took so long to reply. I used gen and it worked, but sure is ugly. gtk and gtk2 did not work. kde4, however, is my favorite. Thank you for your help

    this works great:
    Code:
    #>SAL_USE_VCLPLUGIN=kde4 loffice
    I should have figured out that loffice was the command and not part of the value of SAL_USE_VCLPLUGIN. oops
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •