Results 1 to 2 of 2

Thread: Apache + Wordpress + Permissions = Losing insanity!

  1. #1

    Unhappy Apache + Wordpress + Permissions = Losing insanity!

    Hey guys,

    I am trying out OpenSUSE for web development after going through about 20 other distros, and am really liking it so far!! Everything set up easily and quick, then came trying to set up a Wordpress site....

    I have installed LAMP, and everything was going well until I tried to enable mod_rewrite. That was about 8 hours ago. And I'm still trying to enable it, except now I can't access any of my sites, I just get access forbidden errors. PLEASE can someone help me - I have SOO much work to get through and I can't even access my sites!!

    This is my conf at the moment:

    default-server.conf

    HTML Code:
    <Directory "/srv/www/htdocs">
    Options None
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    
    Alias /icons/ "/usr/share/apache2/icons/"
    
    <Directory "/usr/share/apache2/icons">
    Options Indexes MultiViewsa
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    
    
    ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"
    
    <Directory "/srv/www/cgi-bin">
    AllowOverride None
    Options +ExecCGI -Includes
    Order allow,deny
    Allow from all
    </Directory>
    
    <IfModule mod_userdir.c>
    UserDir public_html
    Include /etc/apache2/mod_userdir.conf
    </IfModule>
    
    Include /etc/apache2/conf.d/*.conf
    httpd.conf


    HTML Code:
    # forbid access to the entire filesystem by default
    <Directory />
        AllowOverride All
        Require all granted
    </Directory>
    I don't know how to go forward from here. I feel like I should just start over from the beginning, but how do I completely remove LAMP? I followed this tutorial:

    https://en.opensuse.org/SDB:LAMP_setup

    If anyone can help me, I will appreciate it beyond words!!!!!!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,290

    Default Re: Apache + Wordpress + Permissions = Losing insanity!

    Hello,

    I am not sure about your specific problem, but take note that the allow/deny statements are depricated in favour of the require statement. http://httpd.apache.org/docs/2.4/mod...uthz_host.html

    There is backwards compatibilty through the module http://httpd.apache.org/docs/2.4/mod...ss_compat.html

    I am not sure if that module is included by defaylt. in the Apache version that comes with openSUSE13.2. In any caswe, I think that it is better to use the new technique when you start a new project.

    HTH
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •