Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: I cant update the system - kio-extras5 requires libmtp.so.9

  1. #1

    Question I cant update the system - kio-extras5 requires libmtp.so.9

    When the system presents new updates and I try to update I get the following error message:


    Code:
    kio-extras5-5.3.2-19.4.i586 requires libmtp.so.9, but this requirement can not be provided
    I checked the software manager and libmtp package is installed.
    I have to do more to be able to install system updates?

    I am using OpenSuse 13.2 with kde.

  2. #2

    Default Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Quote Originally Posted by rafaelfrazao View Post
    I am using OpenSuse 13.2 with kde.
    OpenSUSE comes with KDE4, but your error message is about a KF5 package.
    Did you install Plasma5 on purpose? From where?

    Can you please post your repo list?
    Code:
    zypper lr -d
    Also, your error message is about the 32bit package. Are you running a 32bit or 64bit system?

  3. #3

    Question Re: I cant update the system - kio-extras5 requires libmtp.so.9

    I am using 64.
    About plasma, I think that is installed, but I dont know the source.

    Code:
     sudo zypper lr -d
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                          | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------+--------
     1 | Office                    | Office                             | No      | ----      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Office/openSUSE_13.2/                              |        
     2 | Packman Repository        | Packman Repository                 | No      | ----      | No      |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                                     |        
     3 | graphics                  | Graphics Project (openSUSE_13.1)   | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_13.1/                            |        
     4 | libdvdcss repository      | libdvdcss repository               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                         |        
     5 | openSUSE-13.2-0_1         | openSUSE-13.2-0                    | Yes     | ( p) Yes  | No      |    1     | yast2  | iso:///?iso=openSUSE-13.2-DVD-x86_64.iso&url=file:///home/suse/openSUSE-13.2-DVD-x86_64.iso/ |        
     6 | repo-debug                | openSUSE-13.2-Debug                | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                               |        
     7 | repo-debug-update         | openSUSE-13.2-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                              |        
     8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                                      |        
     9 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                                 |        
    10 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                                     |        
    11 | repo-source               | openSUSE-13.2-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                              |        
    12 | repo-update               | openSUSE-13.2-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                    |        
    13 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

  4. #4

    Default Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Quote Originally Posted by rafaelfrazao View Post
    I am using 64.
    Hm, why is it trying to install the 32bit version of that package then?
    There is no libmtp9-32bit package and that causes your error message.
    But you shouldn't install the 32bit kio-extras5 anyway.

    What does "sudo zypper -v in -f kio-extras5-5.3.2-19.4.x86_64"

    About plasma, I think that is installed, but I dont know the source.
    You *think* it is installed? You should know if you installed it, or which desktop you are using, no?
    What does "rpm -qa | grep workspace" say?

    According to your repo list, it (and kio-extras5) must come from the standard 13.2 repos though.

    Code:
     sudo zypper lr -d
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                          | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------+--------
     3 | graphics                  | Graphics Project (openSUSE_13.1)   | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_13.1/                            |
    Looks ok in general, except this one is for 13.1. You should change the URL to say "openSUSE_13.2" instead.
    But that's unrelated to your problem I suppose.
    Although it could cause some conflict that makes zypper want to install the 32bit kio-extras5 as work-around.

  5. #5

    Question Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Code:
    sudo zypper -v in -f kio-extras5-5.3.2-19.4.x86_64
    ....
    The following 2 packages are going to be upgraded:
      kio-extras5       5.1.2-9.15 -> 5.3.2-19.4
      kio-extras5-lang  5.1.2-9.15 -> 5.3.2-19.4
    
    
    
    
    The following package is going to change architecture:
      kio-extras5  5.1.2-9.15 -> 5.3.2-19.4  i586 -> x86_64
    ....
    No erros at end of the process. The system install the correct package.

    The second command:

    Code:
    rpm -qa | grep workspacekdebase4-workspace-branding-openSUSE-13.2-4.2.8.x86_64
    kdebase4-workspace-4.11.20-29.5.x86_64
    kdebase4-workspace-addons-4.11.20-29.5.x86_64
    kdebase4-workspace-libs-4.11.20-29.5.x86_64
    kdebase4-workspace-liboxygenstyle-4.11.20-29.5.x86_64
    kdebase4-workspace-plasma-calendar-4.11.20-29.5.x86_64
    kdebase4-workspace-ksysguardd-4.11.20-29.5.x86_64

  6. #6

    Default Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Quote Originally Posted by rafaelfrazao View Post
    Code:
    The following package is going to change architecture:
      kio-extras5  5.1.2-9.15 -> 5.3.2-19.4  i586 -> x86_64
    ....
    Oh. You had the 32bit package (i586) installed right from the start.
    That was your problem. The older version 5.1.2 probably didn't require libmtp9 yet.

    The second command:

    Code:
    rpm -qa | grep workspace
    kdebase4-workspace-branding-openSUSE-13.2-4.2.8.x86_64
    kdebase4-workspace-4.11.20-29.5.x86_64
    kdebase4-workspace-addons-4.11.20-29.5.x86_64
    kdebase4-workspace-libs-4.11.20-29.5.x86_64
    kdebase4-workspace-liboxygenstyle-4.11.20-29.5.x86_64
    kdebase4-workspace-plasma-calendar-4.11.20-29.5.x86_64
    kdebase4-workspace-ksysguardd-4.11.20-29.5.x86_64
    You use KDE4.
    Then you shouldn't actually need kio-extras5, unless you installed some additional KF5 based applications.
    But your repo list doesn't indicate that, 13.2 doesn't include any...

  7. #7

    Question Re: I cant update the system - kio-extras5 requires libmtp.so.9

    I got it. Now, everything is ok.. Right?

  8. #8

    Default Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Quote Originally Posted by rafaelfrazao View Post
    I got it. Now, everything is ok.. Right?
    Yes.
    Unless you have other problems too...

  9. #9

    Unhappy Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Yes.. Unfortunately I have:
    (I was travelling - Sorry for late answer)



  10. #10

    Default Re: I cant update the system - kio-extras5 requires libmtp.so.9

    Quote Originally Posted by rafaelfrazao View Post
    Yes.. Unfortunately I have:
    Those are definitely unrelated to kio-extras5 or libmtp though.

    Rather look like graphics driver problems.
    What graphics card/driver are you using?

    Does disabling desktop effects help?
    (press Shift+Alt+F12)
    Or booting to "recovery mode"? (2nd entry in "Advanced Options" in the boot menu)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •