Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: How to play local stored flashvideo.swf ?

  1. #21
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,104
    Blog Entries
    15

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by terjejh View Post
    I did, and tried to open the .swf file again with Firefox. But the same happends. FF starts VLC which plays without visible video output. (black screen with vlc icon).

    I tried to search for 'flash' in FF 'about: preferences#applications' and got:

    • Content type - Actions
    • Flash-video - VLC plugin (in Firefox)
    • Shockwave Flash file - Shockwave flash (in Firefox)


    Why is the VLC player the only option to use (not Shockwave flash) when I try to open the local .swg file from FF ?

    ----------
    Terje J. H.
    Hi
    OK, so as a test copy the mimeapps.list
    to your home directory as a backup, edit the file so there is only one line with application/x-shockwave-flash

    Restart the shel and firefox and try opening, if it doesn't work, check the FF preferences again and if the VLC plugin is still present delete and try firefox again.

    You could then restore the original mimeapps.list file back and see if it comes back...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #22

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, so as a test copy the mimeapps.list
    to your home directory as a backup, edit the file so there is only one line with application/x-shockwave-flash

    Restart the shel and firefox and try opening, if it doesn't work, check the FF preferences again and if the VLC plugin is still present delete and try firefox again.

    You could then restore the original mimeapps.list file back and see if it comes back...
    I tried, but still not possible to display the .swf flash-video file with VLC.

    I did also disable the VLC web plugin in FF 'about:addons.
    Then the default VLC media player was default in FF preferences.
    I have the VLC Media player selected as the default (preferred) video application in Gnome control center.

    By the way, VLC won't display .swf flash video file stored locally, at least not on my system (and not on malcolmlewis' system ?)

    ----------
    Terje J. H

  3. #23
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,104
    Blog Entries
    15

    Default Re: How to play local stored flashvideo.swf ?

    On Wed 16 Sep 2015 08:46:01 PM CDT, terjejh wrote:


    malcolmlewis;2728493 Wrote:
    > Hi
    > OK, so as a test copy the mimeapps.list to your home directory as a
    > backup, edit the file so there is only one line with
    > application/x-shockwave-flash
    >
    > Restart the shel and firefox and try opening, if it doesn't work,
    > check the FF preferences again and if the VLC plugin is still present
    > delete and try firefox again.
    >
    > You could then restore the original mimeapps.list file back and see if
    > it comes back...

    I tried, but still not possible to display the .swf flash-video file
    with VLC.

    I did also disable the VLC web plugin in FF 'about:addons.
    Then the default VLC media player was default in FF preferences.
    I have the VLC Media player selected as the default (preferred) video
    application in Gnome control center.

    By the way, VLC won't display .swf flash video file stored locally, at
    least not on my system (and not on malcolmlewis' system ?)

    ----------
    Terje J. H


    Hi
    I only used firefox to play the file. I only have the one entry in the
    mimetypes.list file.

    You need to check in preferences->applications and there should be a
    swf entry?

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel
    3.12.44-52.10-default If you find this post helpful and are logged into
    the web interface, please show your appreciation and click on the star
    below... Thanks!


  4. #24
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to play local stored flashvideo.swf ?

    On 2015-09-16 19:06, terjejh wrote:

    > I tried to search for 'flash' in FF 'about: preferences#applications'
    > and got:
    >
    >
    > - Content type - Actions
    > - Flash-video - VLC plugin (in Firefox)
    > - Shockwave Flash file - Shockwave flash (in Firefox)


    I only have the later in that list, although VLC plugin is installed.
    try removing "VLC plugin" from that list.


    > Why is the VLC player the only option to use (not Shockwave flash) when
    > I try to open the local .swg file from FF ?


    maybe because VLC is an application, and shokwave is not.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #25

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I only used firefox to play the file. I only have the one entry in the
    mimetypes.list file.
    You mean 'mimeapps.list'
    On my system, Firefox preferences doesn't change according to the content of ~/.local/share/applications/mimeapps.list
    I tried both the single entry in it and even deleted the file, but the FF 'about: preferences#applications' were all still the same.
    Code:
    cat /home/terje/.local/share/applications/mimeapps.list
    [Default Applications]
    application/x-shockwave-flash
    [Added Associations]
    And there is also a mimeapps.list in .config with full content ............
    Code:
    find ~ -name mimeapps.list
    /home/terje/.local/share/applications/mimeapps.list
    /home/terje/.config/mimeapps.list
    The FF prefs change according to which 'about:add-ons' (Tools > Extensions) that are installed and enabled/ask/disabled

    You need to check in preferences->applications and there should be a
    swf entry?
    No, my FF has no 'swf' entry, only two entries for 'flash' as I wrote in #20
    Try FF 'about: preferences#applications' and search for 'swf'. If you hit 'swf', which Action is set for it?

    Here is the content list for my FF 40.0.3 extensions, beyond the languages:
    Code:
    [Extension] Copy Extensions to Clipboard 4.0.1-signed [installed in the current profile directory] 
    [Extension] Flash and Video Download 1.75  [installed in the current profile directory] 
    [Extension] Flash Video Downloader - YouTube HD Download [4K] 8.0.1  [installed in the current profile directory] 
    [Extension] Save Images 1.1.0.1-signed  [installed in the current profile directory] 
    [Extension] YouTube Flash Video Player 40.0  [installed in the current profile directory] 
    [Extension] YouTube™ Flash-HTML5 0.1.0.1-signed  [installed in the current profile directory] 
    [Extension] YouTube™ Flash® Player 1.3.1-signed  [installed in the current profile directory] 
    [Extension][INACTIVE] Flash Block 4.20.13.1-signed  [installed in the current profile directory] 
    [Extension][INACTIVE] Flashblock 1.5.18.1-signed  [installed in the current profile directory] 
    [Plugin] Adobe Reader 9.5   [installed somewhere global to the system] 
    [Plugin] Gnome Shell Integration   [installed somewhere global to the system] 
    [Plugin] IcedTea-Web Plugin (using IcedTea-Web 1.5.1 (suse-4.1-x86_64))   [installed somewhere global to the system] 
    [Plugin] NPAPI Plugins Wrapper 1.4.4   [installed somewhere global to the system] 
    [Plugin] OpenH264 video-kodek er levert av Cisco Systems, Inc. 1.4 [part of the current application] 
    [Plugin] PackageKit   [installed somewhere global to the system] 
    [Plugin] Shockwave Flash 11.2.202.508  [installed somewhere global to the system] 
    [Plugin] Skype Buttons for Kopete   [installed somewhere global to the system] 
    [Plugin][INACTIVE] VLC Web Plugin   [installed somewhere global to the system] 
    [Theme] Standard 40.0.3  [part of the current application]
    When I play the swf file ok over Internet, the (f) icon started is similar like the YouTube Flash Player icon...

    In case you use
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.44-52.10-default
    this differ from my openSUSE 13.2, Gnome 3.14.3 Kernel 3.16.7and Firefox 40.0.3

    ---------
    Terje J. H

  6. #26

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by robin_listas View Post
    On 2015-09-16 19:06, terjejh wrote:

    > - Content type - Actions
    > - Flash-video - VLC plugin (in Firefox)
    > - Shockwave Flash file - Shockwave flash (in Firefox)


    I only have the later in that list, although VLC plugin is installed.
    try removing "VLC plugin" from that list.
    You can have the VLC web plugin installed and disabled (not always enabled)
    As I wrote later, I disabled it, and then the VLC media player (as default gnome video application) took over that place in FF preferences.


    > Why is the VLC player the only option to use (not Shockwave flash) when
    > I try to open the local .swg file from FF ?

    maybe because VLC is an application, and shokwave is not.
    application/x-shockwave-flash

    -------
    Terje J. H

  7. #27
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to play local stored flashvideo.swf ?

    On 2015-09-17 01:16, terjejh wrote:
    >
    > robin_listas;2728530 Wrote:
    >> On 2015-09-16 19:06, terjejh wrote:
    >>
    >>> - Content type - Actions
    >>> - Flash-video - VLC plugin (in Firefox)
    >>> - Shockwave Flash file - Shockwave flash (in Firefox)

    >>
    >> I only have the later in that list, although VLC plugin is installed.
    >> try removing "VLC plugin" from that list.
    >>

    > You can have the VLC web plugin installed and disabled (not always
    > enabled)
    > As I wrote later, I disabled it, and then the VLC media player (as
    > default gnome video application) took over that place in FF preferences.


    Go to preferences, applications. In the search box, type flash. Then on
    the right hand panel, you can change the action: automatically select
    something, or ask.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #28
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,104
    Blog Entries
    15

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by terjejh View Post
    this differ from my openSUSE 13.2, Gnome 3.14.3 Kernel 3.16.7and Firefox 40.0.3
    Hi
    In openSUSE 42.1M2 with FF 40.0.3 and "[Plugin] Shockwave Flash 11.2.202.508" the about:preferences#applications for SWF file is 'Action' Use Shockwave Flash (in Firefox).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #29

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by robin_listas View Post
    On 2015-09-17 01:16, terjejh wrote:
    >
    > robin_listas;2728530 Wrote:
    >> On 2015-09-16 19:06, terjejh wrote:
    >>
    >>> - Content type - Actions
    >>> - Flash-video - VLC plugin (in Firefox)
    >>> - Shockwave Flash file - Shockwave flash (in Firefox)

    >>
    >> I only have the later in that list, although VLC plugin is installed.
    >> try removing "VLC plugin" from that list.
    >>

    > You can have the VLC web plugin installed and disabled (not always
    > enabled)
    > As I wrote later, I disabled it, and then the VLC media player (as
    > default gnome video application) took over that place in FF preferences.


    Go to preferences, applications. In the search box, type flash. Then on
    the right hand panel, you can change the action: automatically select
    something, or ask.
    I also have had that all the time, where the default VLC or Gnome-videos won't play .wsf and the 'Use other..' option contains nothing useful (opens the file browser)

    -----------
    Terje J. H

  10. #30

    Default Re: How to play local stored flashvideo.swf ?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    In openSUSE 42.1M2 with FF 40.0.3 and "[Plugin] Shockwave Flash 11.2.202.508" the aboutreferences#applications for SWF file is 'Action' Use Shockwave Flash (in Firefox).
    Hm. I have 42.1 installed in triple-boot with 13.2 and TW using shared /home for all roots. I booted to 42.1 and tested it too. Do to shared FF profiles I had much the same application preferences, though not VLC installed default, and Gnome-videos (Totem) was the default video player. Shockwave Flash file use also uses Gnome-videos as default player, but It requires a missing flash plugin. The SWF file type still lacks here too. Next I installed the default VLC media player from the suse repo, but as expected it doesn't play the swf file.

    --------------
    Terje J. H

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •