Results 1 to 8 of 8

Thread: OpenCascade - from multiple repository install weird - how to correct to get to run properly

  1. #1

    Default OpenCascade - from multiple repository install weird - how to correct to get to run properly

    hi there
    I have being trying to install opencasade all morning and it being giving problems opensuse 13.2 64- but i seam to have figured it out. you have several issues so you can pass the info on to the maintainers of opencascade for opensuse

    Alternate Version Installed Version
    Version: 6.9.0-7.11 6.9.0-7.11
    Build Time: Tue 25 Aug 2015 10:28:52 PM CDT Tue 25 Aug 2015 10:28:52 PM CDT
    Install Time: Fri 11 Sep 2015 11:35:52 AM CDT
    Package Group: Productivity/Graphics/CAD Productivity/Graphics/CAD
    License: LGPL-2.1 with additional exception LGPL-2.1 with additional exception
    Installed Size: 633.1 MiB 633.1 MiB
    Download Size: 116.7 MiB 0 B
    Distribution:
    Vendor: obs://build.opensuse.org/homeolyconvex obs://build.opensuse.org/homeolyconvex
    Packager:
    Architecture: x86_64 x86_64
    Build Host:
    URL: http://www.opencascade.org/ http://www.opencascade.org/
    Source Package: OpenCASCADE-6.9.0-7.11 OpenCASCADE-6.9.0-7.11
    Media No.:
    Authors:
    all vendors have the same issue


    1) when you install opencascade the first problem is your the run icon is linked to opt/opencasdade/bin/drawexe that is incorrect it suppose to be opt/opencascade/draw.sh

    2) the second problem - you have no pluggins in opt/opencascade/src - easily correctable you have to download the windows version install it and then copy over all the missing directories and incolmplete directories
    IE:
    opt/opencascade/src
    opt/opencascade/test
    opt/opencascade/dox
    opt/opencascade/sample

    3) third problem all your libaries are listed wrong for the program to work ie /opt/opencascade/lib64 all the library have an extra .0 you have to go through all of them and rename them ie: libFWOSPlugin.so.0 > libFWOSPlugin.so. now there is probably and easier way to to this but once you have them renamed - reinstall the program again and every will work afterwards.

    okay hope that helps anyone struggling to get opencascade to work for them

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenCascade - from multiple repository install weird - how tocorrect to get to run properly

    On 2015-09-11 19:26, sash99 wrote:
    > Vendor:
    > obs://build.opensuse.org/homeolyconvex
    > obs://build.opensuse.org/homeolyconvex



    That's a home repo, which often are experiments of somebody.
    You found problems with it, so you yave to tell that person.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3

    Default Re: OpenCascade - from multiple repository install weird - how tocorrect to get to run properly

    Quote Originally Posted by robin_listas View Post
    On 2015-09-11 19:26, sash99 wrote:
    > Vendor:
    > obs://build.opensuse.org/homeolyconvex
    > obs://build.opensuse.org/homeolyconvex



    That's a home repo, which often are experiments of somebody.
    You found problems with it, so you yave to tell that person.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    no worries - I tried from several repos all have the same issue ie:://build.opensuse.org/science
    all the newest version of opencascade 6.9.0 - *** and require the same work around .. just passing the around the info

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,100
    Blog Entries
    15

    Default Re: OpenCascade - from multiple repository install weird - how to correct to get to run properly

    Hi
    Your problem appears to be not installing the opencascade-devel package. The shared library naming is correct somelib.0.* the devel package contains the somelib.so files which is correct and the samples, src, etc in /opt/OpenCASCADE....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: OpenCascade - from multiple repository install weird - how to correct to get to run properly

    thank you - did not know the opencascade devel was a require prerequisite, one would of thought it would install automatically if it is required for it to function properly.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenCascade - from multiple repository install weird - how tocorrect to get to run properly

    On 2015-09-12 00:26, sash99 wrote:
    >
    > thank you - did not know the opencascade devel was a require
    > prerequisite, one would of thought it would install automatically if it
    > is required for it to function properly.


    Your assumption is correct.

    It is a packaging error somewhere: either require the devel package, or
    sort the files differently.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,100
    Blog Entries
    15

    Default Re: OpenCascade - from multiple repository install weird - how tocorrect to get to run properly

    Quote Originally Posted by robin_listas View Post
    On 2015-09-12 00:26, sash99 wrote:
    >
    > thank you - did not know the opencascade devel was a require
    > prerequisite, one would of thought it would install automatically if it
    > is required for it to function properly.


    Your assumption is correct.

    It is a packaging error somewhere: either require the devel package, or
    sort the files differently.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)
    Hi
    No, somelib.so files belong in the development package likewise development files and development examples.

    If you feel it's an error, raise a bug or branch the package with your suggested changes along with recommendations or requires.

    https://bugzilla.opensuse.org/enter_...Cascade:%20Bug
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: OpenCascade - from multiple repository install weird - how to correct to get to run properly

    We don't have maintainer for opencascade, so if you want to help - welcome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •