Results 1 to 4 of 4

Thread: libopenssl-devel requires older version of libopenssl

  1. #1

    Default libopenssl-devel requires older version of libopenssl

    I need to install libopenssl-devel in order to build torque+maui but it requires an earlier version of libopenssl than is the repository. It does offer to let me download but I'm using a virtual private server secured by SSL keys so rolling back is not an option for security reasons. Is there any way I can resolve this ?

  2. #2

    Default Re: libopenssl-devel requires older version of libopenssl

    I've found this security update: http://lists.opensuse.org/opensuse-s.../msg00023.html

    Which should address the issue via updating libopenssl and the devel to the same version but when I try and zypper in the patch, I get:

    'openSUSE-2015-447=1' not found in package names. Trying capabilities.
    No provider of 'openSUSE-2015-447=1' found.

    Am I missing a repository ? I only have the default ones currently

  3. #3

    Default Re: libopenssl-devel requires older version of libopenssl

    Okay, after some more looking I've discovered that the mirror we use doesn't have a bunch of the 13.2 stuff up yet. I'm trying to revert to the official repositories now , and that worked fine for the updates but there's no repo file in http://download.opensuse.org/distrib.../repo/non-oss/ , how do I add this as a repository ?

  4. #4

    Default AW: Re: libopenssl-devel requires older version of libopenssl

    Quote Originally Posted by Kalanyr View Post
    Okay, after some more looking I've discovered that the mirror we use doesn't have a bunch of the 13.2 stuff up yet. I'm trying to revert to the official repositories now , and that worked fine for the updates but there's no repo file in http://download.opensuse.org/distrib.../repo/non-oss/ , how do I add this as a repository ?
    With YaST->Software Repositories, or:
    Code:
    zypper ar -f URL ALIAS
    (the '-f' turns on auto-refresh)

    Or you can also just edit or copy (and then modify the copy) the existing repo file in /etc/zypp/repos.d/.

    PS: the link you posted is the Non-OSS repo, that does not contain libopenssl.
    You rather want this for the update repo:
    http://download.opensuse.org/update/13.2/
    Last edited by wolfi323; 05-Sep-2015 at 02:02.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •