Results 1 to 9 of 9

Thread: Zypper: The following package updates will NOT be installed

  1. #1
    Join Date
    Sep 2014
    Location
    Palm Springs CA
    Posts
    11

    Default Zypper: The following package updates will NOT be installed

    This happens a lot when I use sudo zypper update. Today, there were 78 updates not installed.

    Why is this happening and is there something I can do about it?

    Thanks

  2. #2

    Default Re: Zypper: The following package updates will NOT be installed

    Quote Originally Posted by klwilcoxon View Post
    Why is this happening and is there something I can do about it?
    This means that those packages are available in some other repo in a higher version. But zypper will not install them because it doesn't switch packages to versions from other repos by default. And normally that's a good thing.

    You can use "zypper dup" to just install the highest versions regardless from which repo they are from, but depending on the packages and repos this might not be a good idea.
    And/or check those packages manually (in YaST e.g. with the "Versions" tab) and install them from the repo you want them from, and from then on ignore the message.

    For more detailed help, please post the exact zypper message (i.e. the list of packages that are "NOT installed") and your repo list:
    Code:
    zypper lr -d

  3. #3
    Join Date
    Sep 2014
    Location
    Palm Springs CA
    Posts
    11

    Default Re: Zypper: The following package updates will NOT be installed

    Quote Originally Posted by wolfi323 View Post
    This means that those packages are available in some other repo in a higher version. But zypper will not install them because it doesn't switch packages to versions from other repos by default. And normally that's a good thing.

    You can use "zypper dup" to just install the highest versions regardless from which repo they are from, but depending on the packages and repos this might not be a good idea.
    And/or check those packages manually (in YaST e.g. with the "Versions" tab) and install them from the repo you want them from, and from then on ignore the message.

    For more detailed help, please post the exact zypper message (i.e. the list of packages that are "NOT installed") and your repo list:
    Code:
    zypper lr -d

    The following 127 package updates will NOT be installed:
    amarok apper appmenu-qt bluedevil bluedevil-lang choqok cln coreutils-debuginfo cpio-debuginfo device-mapper-debuginfo digikam digikam-doc e2fsprogs-debuginfo fcoe-utils-debuginfo gettext-runtime-mini-debuginfo glibc-debuginfo glibc-locale-debuginfo gpg2-debuginfo
    graphviz-gnome-debuginfo grub2-debuginfo gtk2-engine-oxygen gtk2-theme-oxygen hwinfo-debuginfo installation-images-debuginfodeps-openSUSE k3b kaffeine kio_iso kipi-plugins kipi-plugins-acquireimage kipi-plugins-geolocation kipi-plugins-lang konversation
    konversation-lang kpartx-debuginfo ktorrent kvkbd lensfun-data libapparmor1-debuginfo libasound2-debuginfo libassuan0-debuginfo libbluedevil2 libcairo2-debuginfo libcom_err2-debuginfo libcurl4-debuginfo libdrm2-debuginfo libepub0 libext2fs2-debuginfo libgbm1-debuginfo
    libgdk_pixbuf-2_0-0-debuginfo libgnutls30-debuginfo libgpg-error0-debuginfo libgraphite2-3-debuginfo libHBAAPI2-debuginfo libhbalinux2-debuginfo libhdf5-10 libhdf5_hl10 libidn11-debuginfo liblensfun0 libmediawiki1 libopencv2_4 libpng16-16-debuginfo libpulse0-debuginfo
    libpwquality1-debuginfo libqalculate5 libQt5Core5-debuginfo libQt5DBus5-debuginfo libQt5Gui5-debuginfo libQt5Widgets5-debuginfo libruby2_2-2_2-debuginfo libsnappy1-debuginfo libsolv-tools-debuginfo libspeex1-debuginfo libsqlite3-0-debuginfo libstorage6-debuginfo
    libstorage-ruby-debuginfo libtag-extras1 libtelepathy-qt4-2 libtiff5-debuginfo libwayland-client0-debuginfo libwayland-server0-debuginfo libwicked-0-6-debuginfo libwrap0-debuginfo libyui-ncurses6-debuginfo libyui-ncurses-pkg6-debuginfo libyui-qt-pkg6-debuginfo
    libzypp-debuginfo lvm2-debuginfo Mesa-libEGL1-debuginfo Mesa-libGL1-debuginfo Mesa-libglapi0-debuginfo moodbar multipath-tools-debuginfo nfs-client-debuginfo nscd-debuginfo ntp-debuginfo pam-debuginfo pam-modules-debuginfo perl-base-debuginfo perl-debuginfo
    perl-Digest-SHA1-debuginfo perl-gettext-debuginfo perl-XML-Bare-debuginfo perl-XML-Parser-debuginfo perl-YAML-LibYAML-debuginfo python-cffi-debuginfo python-cryptography-debuginfo ruby2.2-debuginfo ruby2.2-stdlib-debuginfo skanlite skanlite-doc skanlite-lang
    strace-debuginfo synaptiks vim-debuginfo wicked-debuginfo xf86-input-synaptics-debuginfo xf86-input-vmmouse-debuginfo xf86-input-wacom-debuginfo xfsprogs-debuginfo xorg-x11-server-debuginfo xorg-x11-Xvnc-debuginfo yast2-core-debuginfo yast2-perl-bindings-debuginfo
    yast2-pkg-bindings-debuginfo yast2-ruby-bindings-debuginfo yast2-storage-debuginfo yast2-x11-debuginfo




    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    --------------------+----------------------------------+------------------------+-----------------------+----------------------------+---------+----------+--------+----------------
    1 | KDE_Updates | KDE Updates | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    2 | download.opensuse.org-tumbleweed | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
    3 | repo-debug | repo-debug | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/debug |
    4 | repo-non-oss | repo-non-oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss |
    5 | repo-oss | repo-oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss |
    6 | repo-update | repo-update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed |




    Many thanks!

  4. #4

    Default Re: Zypper: The following package updates will NOT be installed

    Ok, this is one of your "problems":
    Quote Originally Posted by klwilcoxon View Post
    1 | KDE_Updates | KDE Updates | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    Some of the applications in Tumbleweed are also available there (in a newer version).
    You probably don't need to install them from KDE:Extra, as you will get them in Tumbleweed anyway some time later.
    If you do want to always have the latest versions immediately, run "sudo zypper dup --from KDE_Updates", and at least those packages should disappear from the list.

    The rest are *-debuginfo packages, where I don't understand at the moment why they are listed TBH. Maybe you installed them earlier from somewhere else (did you update from 13.2 or similar?), or the TW debug repo is out of date at the moment.
    Anyway, you could just as well uninstall those, they are not needed unless you want to debug crashes or similar.
    Last edited by wolfi323; 03-Sep-2015 at 13:30.

  5. #5
    Join Date
    Sep 2014
    Location
    Palm Springs CA
    Posts
    11

    Default Re: Zypper: The following package updates will NOT be installed

    Done and did. Thank you very much.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Zypper: The following package updates will NOT be installed

    Quote Originally Posted by klwilcoxon View Post
    Why is this happening and is there something I can do about it?
    In my case there are 88 packages not updating.

    It seems to be because most of them need a newer perl, but there is one package that requires the older perl. So perl is not updated and everything that needs the perl update is also held back.

    I'm not sure if that's the problem you are having.

    I'm assuming that this will probably be fixed in the next few days.

    If you do:

    Code:
    # zypper dup -D
    you should see more details about the conflicts. The "-D" option is for a dry run (don't actually change anything, just tell me what would happen).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Zypper: The following package updates will NOT be installed

    FYI the problem is still there:
    Code:
    Tumbleweed132:/home/john # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Problem: apache2-mod_perl-2.0.9-3.1.x86_64 requires perl = 5.20.1, but this requirement cannot be provided
      deleted providers: perl-5.20.1-3.12.x86_64
     Solution 1: Following actions will be done:
      keep obsolete yast2-apparmor-3.1.3-1.1.noarch
      keep obsolete perl-libwww-perl-6.13-1.1.noarch
      keep obsolete perl-XML-XPathEngine-0.14-5.2.noarch
     ---- and many more
      keep obsolete perl-DateTime-Format-ISO8601-0.08-1.2.noarch
      keep obsolete perl-5.20.1-3.12.x86_64
     Solution 2: deinstallation of apache2-mod_perl-2.0.9-3.1.x86_64
     Solution 3: break apache2-mod_perl-2.0.9-3.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c):
    I suppose I should hunt for a supplier of perl for apache2 or perhaps an upgrade for apache2
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Zypper: The following package updates will NOT be installed

    Quote Originally Posted by swerdna View Post
    FYI the problem is still there
    My system updated completely with recent updates. But I don't have apache installed, so I don't know how that would have been affected.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Zypper: The following package updates will NOT be installed

    Thanks. I don't want to break apache so I'll probably just have to wait until LAMP catches back up with the other packages in Tumbleweed again.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •