Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Plasma 5 repository broken libKF5Baloo dependency

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Plasma 5 repository broken libKF5Baloo dependency

    I cannot update my KDE Plasma 5 packages from the 13.2 repository
    http://download.opensuse.org/reposit...openSUSE_13.2/

    The problem comes when trying to install either of these two packages: plasma5-dekstop, plasma5-workspaceIt says nothing provides libKF5Baloo.so.5()(64bit), even though the package libKF5Baloo is installed.
    I have these under /usr/lib64/
    libKF5Baloo.so.1 -> libKF5Baloo.so.5.9.2
    libKF5Baloo.so.5.9.2


  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: Plasma 5 repository broken libKF5Baloo dependency

    Post complete Output of:
    Code:
    zypper in plasma5-desktop
    Code:
    zypper lr -d
    Please use Code-Tags.

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    Code:
    Problem: plasma5-desktop-5.3.95-97.4.x86_64 require libKF5Baloo.so.5 () (64bit), but this needed file does not exist
      uninstallable required packages: libKF5Baloo5-5.13.0-61.1.x86_64 [KDE_Frameworks]
     Solution 1: The following actions will be performed:
      Architecture Change from dolphin-party-15.07.90-1.1.x86_64 to dolphin-party-15.07.90-1.1.i586
      installation dolphin-party-15.07.90-1.1.i586 although the architecture is not correct
      installation baloo5 widgets-15.07.90-1.1.i586 although the architecture is not correct
      installation libdolphinvcs5-15.07.90-1.1.i586 although the architecture is not correct
      Architecture Change from dolphin-15.07.90-1.1.x86_64 to dolphin-15.07.90-1.1.i586
      Architecture Change from baloo5 widgets-15.07.90-1.1.x86_64 to baloo5 widgets-15.07.90-1.1.i586
      Architecture Change from libdolphinvcs5-15.07.90-1.1.x86_64 to libdolphinvcs5-15.07.90-1.1.i586
      downgrading of dolphin-plugins-15.07.90-3.1.x86_64 to dolphin-plugins-14.12.3-16.3.x86_64
      installation dolphin-plugins-14.12.3-16.3.x86_64 (with manufacturer change)
        obs: //build.opensuse.org/KDE -> openSUSE
     Solution 2: Do not install plasma5-desktop-5.3.95-97.4.x86_64
     Solution 3: Ignore any dependencies although plasma5-desktop-5.3.95-97.4.x86_64 will not work
    
    
    Choose the solution of the issue or cancel [1/2/3 / a] (a):
    Code:
    #  | Alias                     | Navn                               | aktivert | GPG-kontroll | Oppdater | Prioritet | Type   | URI                                                                         
      | Tjeneste
    ---+---------------------------+------------------------------------+----------+--------------+----------+-----------+--------+-----------------------------------------------------------------------------
    --+---------
     1 | Development_SCM_Git       | Development SCM Git                | Ja       | (r ) Ja      | Ja       |   95      | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/scm/openSUSE_13.2/  
      |          
     2 | Games                     | Games                              | Ja       | (r ) Ja      | Ja       |   95      | rpm-md | http://download.opensuse.org/repositories/games:/tools/openSUSE_13.2/       
      |          
     3 | KDE_Applications          | KDE Applications                   | Ja       | (r ) Ja      | Ja       |   70      | rpm-md | http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_13.2/  
      |          
     4 | KDE_Frameworks            | KDE Frameworks                     | Ja       | (r ) Ja      | Ja       |   70      | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/   
      |          
     5 | KDE_Qt5                   | KDE Qt5                            | Ja       | (r ) Ja      | Ja       |   70      | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/           
      |          
     6 | LibreOffice               | LibreOffice                        | Ja       | (r ) Ja      | Ja       |   90      | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_13.2
    / |          
     7 | Nvidia                    | Nvidia                             | Ja       | (r ) Ja      | Ja       |   80      | rpm-md | ftp://download.nvidia.com/opensuse/13.2/                                    
      |          
     8 | Packman                   | Packman                            | Ja       | (r ) Ja      | Ja       |   85      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_13.2/               
      |          
     9 | VideoLan_Client           | VideoLan Client                    | Ja       | ( p) Ja      | Ja       |   80      | rpm-md | http://download.videolan.org/pub/vlc/SuSE/13.2/                             
      |          
    10 | google-chrome             | google-chrome                      | Ja       | (r ) Ja      | Ja       |   99      | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                         
      |          
    11 | repo-debug                | openSUSE-13.2-Debug                | Nei      | ----         | Ja       |   99      | yast2  | http://download.opensuse.org/debug/distribution/13.2/repo/oss/              
      |          
    12 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Nei      | ----         | Ja       |   99      | rpm-md | http://download.opensuse.org/debug/update/13.2/                             
      |          
    13 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Nei      | ----         | Ja       |   99      | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/                     
      |          
    14 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Ja       | ( p) Ja      | Ja       |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                
      |          
    15 | repo-oss                  | openSUSE-13.2-Oss                  | Ja       | ( p) Ja      | Ja       |   99      | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                    
      |          
    16 | repo-source               | openSUSE-13.2-Source               | Nei      | ----         | Ja       |   99      | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/             
      |          
    17 | repo-update               | openSUSE-13.2-Update               | Ja       | (r ) Ja      | Ja       |   99      | rpm-md | http://download.opensuse.org/update/13.2/                                   
      |          
    18 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Ja       | ( p) Ja      | Ja       |   99      | rpm-md | http://download.opensuse.org/update/13.2-non-oss/    
    

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    You running 32 bit OS. it is saying that the architecture is not right for 64 bit package

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    Quote Originally Posted by gogalthorp View Post
    You running 32 bit OS. it is saying that the architecture is not right for 64 bit package
    I am not running a 32bit OS, its 64bit.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    Quote Originally Posted by gogalthorp View Post
    You running 32 bit OS. it is saying that the architecture is not right for 64 bit package
    I think you misread that. It is saying that only the 32-bit version of the software is available and is a mismatch for his system architecture.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    Thats correct. My system language is not English, so I used Google translate (because I'm lazy).


    Code:
    
    
    Code:
    Linux linuxBox 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux


  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,143

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    Quote Originally Posted by DJViking View Post
    Thats correct. My system language is not English, so I used Google translate (because I'm lazy).

    When you want the output of a command in English, precede the command with
    Code:
    LANG=C
    Example:
    Code:
    henk@boven:~> df -h | head -2
    Bestandssysteem Grootte Gebruikt Besch Geb% Aangekoppeld op
    /dev/sda2           20G     5,6G   13G  30% /
    henk@boven:~> LANG=C df -h | head -2
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sda2        20G  5.6G   13G  30% /
    henk@boven:~>
    Henk van Velden

  9. #9

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    libKF5Baloo5 is available in the KDE:Frameworks5 repo, also for 64bit:
    http://download.opensuse.org/reposit...1.1.x86_64.rpm

    Maybe try to install it explicitly, this might point to the actual problem:
    Code:
    sudo zypper in -f libKF5Baloo5
    Btw, I didn't have such a problem on my 64bit systems, but then I'm using my own repo with my own libKF5Baloo5 package.

    Another thing: Better remove the VLC repo! It is incompatible with Packman, and everything except libdvdcss2 (and much more) is available in Packman anyway.
    If you need libdvdcss2, just keep the installed package (it won't be removed when you remove the repo, and there are no updates to it anyway), or add the separate libdvdcss repo in YaST->Software Repositories->Add->Community Repositories instead.

  10. #10
    Join Date
    Mar 2009
    Location
    mostly lurking
    Posts
    38

    Default Re: Plasma 5 repository broken libKF5Baloo dependency

    I'm facing the same error.

    Could it be to do with dolphin and dolphin-part having a dependency on libkf5baloo.so.1
    while all the other dependencies are for libk********.so.5

    That is the only thing that sticks out as odd when I look at it.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •