Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: Getting "Another Firewall Active" message when no firewall running

  1. #11

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Update:

    Tested on my other machine (also openSUSE 13.2) - absolutely the same behavior and again 'iptables -L' gives the exact same output!

    I haven't installed emule or any particular Voip software.

    Just to note - this doesn't actually cause any problem if I click "Continue" and then turn on the firewall. But it kind of bothers me to see open ports by default like that.

  2. #12
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Getting "Another Firewall Active" message when no firewallrunning

    On 2015-08-30 22:36, heyjoe wrote:

    > Just to note - this doesn't actually cause any problem if I click
    > "Continue" and then turn on the firewall. But it kind of bothers me to
    > see open ports by default like that.


    Well, I always install with the firewall up during the installation,
    IIRC. I haven't had to activate it later, so I wouldn't see your situation.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #13

    Default Re: Getting "Another Firewall Active" message when no firewallrunning

    Quote Originally Posted by robin_listas View Post
    Well, I always install with the firewall up during the installation,
    IIRC. I haven't had to activate it later, so I wouldn't see your situation.
    I also install it during OS installation but I set it to disabled by default because my router already has a firewall.

    I activate openSUSE's firewall on the PC only on special occasions, e.g. when I need to NAT to a sub-LAN. The rest of the time it is off.

  4. #14
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Getting "Another Firewall Active" message when no firewallrunning

    On 2015-08-30 23:16, heyjoe wrote:
    > because my router already has a firewall.


    So does mine, but I never trust them.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #15
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Quote Originally Posted by heyjoe View Post
    Update:

    Tested on my other machine (also openSUSE 13.2) - absolutely the same behavior and again 'iptables -L' gives the exact same output!

    I haven't installed emule or any particular Voip software.

    Just to note - this doesn't actually cause any problem if I click "Continue" and then turn on the firewall. But it kind of bothers me to see open ports by default like that.
    It may be open in the firewall, but is something listening on the port? What about the netstat output?
    Henk van Velden

  6. #16

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Quote Originally Posted by hcvv View Post
    It may be open in the firewall, but is something listening on the port? What about the netstat output?
    Code:
    netstat -tulpn | grep 4000
    tcp        0      0 0.0.0.0:4000            0.0.0.0:*               LISTEN      3060/nxd            
    tcp        0      0 :::4000                 :::*                    LISTEN      3060/nxd
    What does this mean? The NoMachine NX daemon?

  7. #17
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Quote Originally Posted by heyjoe View Post
    Code:
    netstat -tulpn | grep 4000
    tcp        0      0 0.0.0.0:4000            0.0.0.0:*               LISTEN      3060/nxd            
    tcp        0      0 :::4000                 :::*                    LISTEN      3060/nxd
    What does this mean? The NoMachine NX daemon?
    Yes, the process 3060, which is a running nxd is listening to that port. And I bet that installing/configuring NX also created the IP table entries.

    Again, I do not know much about NX, but ny going step by step. I think we got somewhere.
    Henk van Velden

  8. #18

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Quote Originally Posted by hcvv View Post
    I think we got somewhere.
    Looks like it. Thanks for the netstat tip.

    Any idea how to find exactly where NX opens these ports?

  9. #19
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Have a look in /etc/sysconfig/SuSEfirewall2.d/services/ for a NoMachine port definition file.

  10. #20

    Default Re: Getting "Another Firewall Active" message when no firewall running

    Quote Originally Posted by deano_ferrari View Post
    Have a look in /etc/sysconfig/SuSEfirewall2.d/services/ for a NoMachine port definition file.
    I don't see it: http://paste.opensuse.org/1b0ed475

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •