Results 1 to 6 of 6

Thread: Yast crashes under Plasma 5

  1. #1

    Default Yast crashes under Plasma 5

    When I launch Yast, it seems to start fine. But when trying to get it to do something like Online Update or Software Management it dies. It will bring up the screen and go through reading the repositories and just quit. When I run it from the command line I get this:

    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:294
    /sbin/yast2: line 440: 7814 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    I'm running openSUSE 13.2 with Plasma 5. (64bit)
    Toshiba laptop with 8G memory.

  2. #2

    Default Re: Yast crashes under Plasma 5

    Quote Originally Posted by pmiker View Post
    I'm running openSUSE 13.2 with Plasma 5. (64bit)
    It shouldn't make a difference whether you use Plasma 5 or something else.

    But, where did you install Plasma 5 from? A possible reason for crashes are incompatible KF5/Qt5 packages.
    Please post your repo list:
    Code:
    zypper lr -d
    Another reason that would cause a crash when refreshing the repos is having libproxy4-config-kde4.
    Actually it shouldn't be installed as YaST conflicts with it exactly because of that, but verify that you don't have it installed anyway.

    Also, for clarification:
    Does the ncurses version work, or does that crash as well?
    Does only the software management module crash, or are the crashes more general?

    The file /var/log/YaST/y2log should contain more details about the crash, so please post the last lines immediately after a crash.

  3. #3

    Default Re: Yast crashes under Plasma 5

    Yast is now working. I still get Plasma crash messages but for now Yast seems ok.

    Here are my repositories:
    zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------+--------
    1 | Frameworks5 | Frameworks5 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    2 | Qt5 | Qt5 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.2/ |
    3 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | ( p) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_DVDRAM_GU90N_M5ADCGN3811 |
    4 | packman | packman | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/misc/pa...openSUSE_13.2/ |
    5 | repo-debug | openSUSE-13.2-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    6 | repo-debug-update | openSUSE-13.2-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
    7 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ |
    8 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    9 | repo-oss | openSUSE-13.2-Oss | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    10 | repo-source | openSUSE-13.2-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/...13.2/repo/oss/ |
    11 | repo-update | openSUSE-13.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    12 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | ( p) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |
    13 | videolan | videolan | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/vlc/SuSE/13.2/

    Sorry about the formatting.

  4. #4

    Default Re: Yast crashes under Plasma 5

    Quote Originally Posted by pmiker View Post
    Yast is now working. I still get Plasma crash messages but for now Yast seems ok.
    And what did you do to fix it?

    Here are my repositories:
    zypper lr
    # | Alias | Name | Enabled | GPG Check | Refresh
    ---+---------------------------+------------------------------------+-------------+-----------+--------
    1 | Frameworks5 | Frameworks5 | Yes | (r ) Yes | Yes
    2 | Qt5 | Qt5 | Yes | (r ) Yes | Yes
    Well, that's a possible source of problems.
    If you have KF5 packages from the standard repos installed, they might crash with Qt 5.5 and vice-versa.
    Make a full switch to those repos to be sure there's no incompatible mix installed:
    Code:
    sudo zypper dup --from 1 --from 2
    A side-note:
    4 | packman | packman | Yes | (r ) Yes | Yes
    ...
    13 | videolan | videolan | Yes | (r ) Yes | Yes
    Those two repos are incompatible and having both can/will lead to problems.
    I'd recommend to remove the videolan repo and make a full switch to Packman to be sure. Everything that's available from videolan is in Packman too, and much more.
    Code:
    sudo zypper rr 13
    sudo zypper dup --from 4

  5. #5

    Default Re: Yast crashes under Plasma 5

    I'm not sure what fixed it. Probably that I asked for help. I know restarting and logging out and in did not seem to help. But now it works.

    I had followed instructions on adding the first two repositories and I did do the zypper dup --from 1 --from 2.

    I'm removing the videolan and switching to packman. It took some effort to get videlan's codecs installed. I'll see if it works after a reboot

  6. #6

    Default Re: Yast crashes under Plasma 5

    VLC still works. Thanks for the advice. I just got back into linux after many years away. I appreciate the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •