Results 1 to 3 of 3

Thread: Cannot launch java applications.

  1. #1

    Default Cannot launch java applications.

    Hello, I have been using Linux for a while but I am new to opensuse. I have installed jre-8u60-linux-x64.rpm from the oracle website. I am trying to launch minecraft. If I run java -jar minecraft.jar in the konsole it works fine, however, if I try to launch it by clicking on the .jar file java starts to launch and the closes before it can start minecraft. I have made sure the jar is marked executable and I have tested other .jar files with the same effect. How would I go about fixing this so that I can make a panel launcher for minecraft. Thanks for your time.

  2. #2
    Join Date
    Sep 2008

    Default Re: Cannot launch java applications.

    in kde go to config center-> file association
    find jar and set java -jar as the preferred application
    also check update-alternatives as oracle's jre is a bit flaky you might be using openjdk

  3. #3

    Default Re: Cannot launch java applications.

    Thanks that fixed it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts