Firefox - Dark theme in KDE (solved)

Hi Everyone

When using a KDE dark theme and Firefox, the text was not black, on some web pages, and input text is faint etc.

Well here is what I did.

1 - Type 'kdesu dolphin' in terminal.

2 - Navigate to /usr/share/applications/firefox.desktop

3 - Open firefox.desktop with Kwrite.

4 - Look down to the line - Exec=firefox %u

5 - Now place a # in front of that line or remove it, it's up to you.

6 - Now inset a new line exactly as below including quote marks;

Exec=bash -c 'GTK2_RC_FILES=/usr/share/themes/Redmond/gtk-2.0/gtkrc firefox %u'

7 - Start Firefox, and yes it does look very plain and light when set against your dark theme, so in order to resolve this, I installed a Firefox dark them in my case NASA launch night.

Make sure the dark theme you have chosen is enabled. Restart Firefox.

Hope it helps.

All the best.

Steve