Results 1 to 5 of 5

Thread: Can't install megasync

  1. #1

    Default Can't install megasync

    Hello, I downloaded megasync rpm from their official website for opensuse 13.2, but click installation didn't work. So I used zypper to install it but the error is as follow:

    Code:
    Retrieving package megasync-2.1.1-1.1.x86_64                                                                                                            (1/1),   1.6 MiB (  5.1 MiB unpacked)
    megasync-openSUSE_13.2.x86_64.rpm:
        Header V3 DSA/SHA1 Signature, key ID 4d70f67a: NOKEY
        V3 DSA/SHA1 Signature, key ID 4d70f67a: NOKEY
    
    megasync-2.1.1-1.1.x86_64(Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
    Abort, retry, ignore? [a/r/i] (a):
    Where to get the key?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Can't install megasync

    I think this is the key
    https://mega.nz/linux/MEGAsync/openS...repomd.xml.key
    you can install it with rpm
    Code:
    wget https://mega.nz/linux/MEGAsync/openSUSE_13.2/repodata/repomd.xml.key
    sudo rpm --import repomd.xml.key
    ps you can add the mega repo and then get updates with apper
    Code:
    sudo zypper ar -f https://mega.nz/linux/MEGAsync/openSUSE_13.2/ MEGA
    ps you can ignore the key error too, but I think adding the repo is the way to go as you'll get updates.

  3. #3

    Default Re: Can't install megasync

    Quote Originally Posted by I_A View Post
    I think this is the key
    https://mega.nz/linux/MEGAsync/openS...repomd.xml.key
    you can install it with rpm
    Code:
    wget https://mega.nz/linux/MEGAsync/openSUSE_13.2/repodata/repomd.xml.key
    sudo rpm --import repomd.xml.key
    ps you can add the mega repo and then get updates with apper
    Code:
    sudo zypper ar -f https://mega.nz/linux/MEGAsync/openSUSE_13.2/ MEGA
    ps you can ignore the key error too, but I think adding the repo is the way to go as you'll get updates.
    Thank you. I added the repo and the key. The erro about the key does not go away though. I am not sure what it means. Does it mean it's not supposed to be safe with a broken key? 'Cause I have never encountered such error when installing programs.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Can't install megasync

    I think that's a mega issue it should be reported there.
    You can ignore that warning and megasync will be installed.
    You can link them this thread for more info.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,499
    Blog Entries
    2

    Default Re: Can't install megasync

    You can also disable checking for the repository key by using the --no-gpgcheck flag.
    So, in your situation you can do the following...

    First, remove your existing repository, the easiest way is
    Code:
    zypper lr # This lists your repos
    zypper rr reponumber # From the list of repos, determine the number of the repo you want to remove, in your case most likely 1
    zypper lr # Check to see whether the repo has been removed
    zypper ar -f --no-gpgcheck https://mega.nz/linux/MEGAsync/openSUSE_13.2/ MEGA # Add your repo
    zypper ref # Your repos should all refresh and you should not be prompted for a repo key for MEGA
    HTH,
    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •