Results 1 to 9 of 9

Thread: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

  1. #1

    Default 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Recently I upgraded my Opensuse 13.1 to 13.2. The upgrade went just fine. No errors.

    I use KDE, and in particular for this e-mail I use kmail.

    In 13.1, when I "check mail", the mail is processed through my filter rules in under a second (for even over 100 messages). Now, in 13.2, it can take a couple of minutes to process a couple of messages through the same filter rules. I ran "top" and saw that akonadi is maxing out the cpu. (see screenshot)

    Code:
    top - 11:49:55 up 2 days, 20:43,  8 users,  load average: 0.31, 0.08, 0.07
    Tasks: 216 total,   2 running, 214 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  4.5 us,  1.3 sy,  0.0 ni, 93.7 id,  0.5 wa,  0.0 hi,  0.0 si,  0.0 st
    KiB Mem:  16448392 total,  4011128 used, 12437264 free,   256196 buffers
    KiB Swap:  7132816 total,      324 used,  7132492 free.  2596496 cached Mem
    
    
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                                                                      
     2127 mark      20   0  777336 217632  60184 R 100.0 1.323  13:29.64 akonadi_mailfil                                                                                                              
        1 root      20   0   36052   5864   3392 S 0.000 0.036   0:03.96 systemd                                                                                                                      
        2 root      20   0       0      0      0 S 0.000 0.000   0:00.03 kthreadd                                                                                                                     
        3 root      20   0       0      0      0 S 0.000 0.000   0:01.56 ksoftirqd/0                                                                                                                  
        5 root       0 -20       0      0      0 S 0.000 0.000   0:00.00 kworker/0:0H           
    Would someone please suggest either steps to further narrow down this problem, or if it is a known issue, how to solve it?

    Many thanks,

    Mark

  2. #2

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Quote Originally Posted by MarkNei View Post
    Would someone please suggest either steps to further narrow down this problem, or if it is a known issue, how to solve it?
    I don't have such a problem here.

    Have you fully updated your system?
    It might be a bug in the kdepim4 version shipped with 13.2 which might have been fixed meanwhile.

    Also try to delete the file ~/.config/akonadi/agent_config_akonadi_mailfilter_agent_changes.dat .
    If those .dat files contain garbage, they can cause heavy resource usage (CPU and RAM) for the corresponding Akonadi resource.

  3. #3

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    PS: Although your problem seems to be related to the mail filter, you might also try to uninstall baloo-pim to disable indexing and see whether that helps.
    IIRC, indexing was disabled by default in 13.1's KDE 4.11 (which still used Nepomuk), but it is enabled by default in 13.2 (using Baloo).

  4. #4

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Well, I went into ~/.config/akonadi and looked at the files. Seems that all of the .dat files are written in a binary format. I delete them, and they are re-created with binary data. The problem went away, but has gradually returned. Strange, but true.

    Haven't tried removing baloo* because I didn't see a baloo package in the repo that would reinstall it if deleting it broke the system.

    Thanks,

    Mark

  5. #5

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Quote Originally Posted by MarkNei View Post
    Well, I went into ~/.config/akonadi and looked at the files. Seems that all of the .dat files are written in a binary format. I delete them, and they are re-created with binary data. The problem went away, but has gradually returned. Strange, but true.
    Yes, those are binary files. And they contain temporary data that has not been written back to the cache/storage yet, so it's not a good idea to just delete them all (although normally it shouldn't harm either).

    Haven't tried removing baloo* because I didn't see a baloo package in the repo that would reinstall it if deleting it broke the system.
    I ecplicitly told you to uninstall baloo-pim.
    And that *is* in the standard repo, just like other baloo* packages.
    Uninstalling them won't break your system, it will just disable file indexing completely (or, in the case of baloo-pim, indexing of PIM data).

    If you don't see a baloo package in the repo, you should better post your repo list:
    Code:
    zypper lr -d
    What also might help with Akonadi-related problems is to clean up the cache/database: (although I'm not sure whether this can help with such a problem as you describe)
    Code:
    akonadictl fsck
    alonadictl vacuum
    (run it as user)
    Last edited by wolfi323; 28-Aug-2015 at 16:31.

  6. #6

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Quote Originally Posted by wolfi323 View Post
    Yes, those are binary files. And they contain temporary data that has not been written back to the cache/storage yet, so it's not a good idea to just delete them all (although normally it shouldn't harm either).


    I ecplicitly told you to uninstall baloo-pim.
    And that *is* in the standard repo, just like other baloo* packages.
    Uninstalling them won't break your system, it will just disable file indexing completely (or, in the case of baloo-pim, indexing of PIM data).

    If you don't see a baloo package in the repo, you should better post your repo list:
    Code:
    zypper lr -d
    What also might help with Akonadi-related problems is to clean up the cache/database: (although I'm not sure whether this can help with such a problem as you describe)
    Code:
    akonadictl fsck
    alonadictl vacuum
    (run it as user)
    OK. As myself (the user) I ran
    $akonadictl fsck
    and then
    $akonadictl vacuum

    Neither command produced any output to the terminal, which I assume is a good thing.

    I have uninstalled baloo-pim (yes, I found it in my repos. Sorry).

    I'm going to run the system as it is for a couple of days and see how thing go.

    Many thanks for the help.

  7. #7

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Quote Originally Posted by MarkNei View Post
    OK. As myself (the user) I ran
    $akonadictl fsck
    and then
    $akonadictl vacuum

    Neither command produced any output to the terminal, which I assume is a good thing.
    Yes, that's normal.
    If you want to follow the progress, you'd need to run Akonadi itself in the terminal, e.g. with "akonadictl restart".

  8. #8

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    OK. I have been working with this problem for a while. In the past, I would hibernate the system at the end of the day. Then after startup in the AM, mail filtering is very slow. The slowness seems to be resolved when I reboot the system. So, I have stopped hibernating the system, and the filtering done within Kmail is still slower than it used to be, but it is now more or less acceptable. I say more or less, because I find that I can no longer hibernate the system, and filtering does slow down through the day.

    I have no idea where to go from here. I'm going to keep doing my usual thing and see if I can find out any more info.

    Thanks for your help to this point,

    Mark

  9. #9

    Default Re: 13.2 upgrade from 13.1 ....akonadi very slow. Takes 100% CPU

    Quote Originally Posted by MarkNei View Post
    OI have no idea where to go from here. I'm going to keep doing my usual thing and see if I can find out any more info.
    So the problem only occurs after resuming from hibernation?

    Does "akonadictl restart" (run as user) fix it then? Or stopping akonadi before hibernation? ("akonadictl stop")

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •