Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Cyrillic keyboard layout corrupts shortcut keys

  1. #1

    Question Cyrillic keyboard layout corrupts shortcut keys

    Whey I switch to cyrillic (Bulgarian) I can't use shortcut keys like CTRL+Z etc. I need to switch back to US and then back to BG, otherwise the hotkey simply doesn't work.

    Any idea how to overcome this travail?

    (using KDE and I see IBus in the tray)

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Check whether Z is available through Alt or Shift-ALt. On some layouts that do not include ASCII characters in the main keyboard layout, they are still available through Alt or Shift-Alt.

  3. #3

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Quote Originally Posted by john_hudson View Post
    Check whether Z is available through Alt or Shift-ALt. On some layouts that do not include ASCII characters in the main keyboard layout, they are still available through Alt or Shift-Alt.
    Checked Alt+Z, Alt+Shift+Z, Alt+Ctrl+Z - no luck.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    I'm on win7 and ctrl+з works the same as ctrl+z.
    I haven't tried it on opensuse, it could be one of those kde/qt keyboard issues linked to missing xlib functions, kind of like the unicode one that X is supposed to provide but does not.
    https://bugs.freedesktop.org/show_bug.cgi?id=26747

    At the moment I don't have any gtk2 or gtk3 DE's installed so can't test it there but it probobly works with lxde/mate/cinnamon/gnome.

  5. #5

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Quote Originally Posted by I_A View Post
    I'm on win7 and ctrl+з works the same as ctrl+z.

    I haven't tried it on opensuse, it could be one of those kde/qt keyboard issues linked to missing xlib functions, kind of like the unicode one that X is supposed to provide but does not.
    https://bugs.freedesktop.org/show_bug.cgi?id=26747

    At the moment I don't have any gtk2 or gtk3 DE's installed so can't test it there but it probobly works with lxde/mate/cinnamon/gnome.
    Same on my Win7, but the question is about Linux and KDE. This bug report seems quite old and it says Unicode input is impossible. Not sure how it might be related?

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Have checked the KDE Bulgarian keyboard layout and, as you say, none of the Alt keyboard options are used. It might be worth putting in a bug request to KDE asking them to add the US keyboard layout to the Alt options.

  7. #7

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Quote Originally Posted by john_hudson View Post
    Have checked the KDE Bulgarian keyboard layout and, as you say, none of the Alt keyboard options are used. It might be worth putting in a bug request to KDE asking them to add the US keyboard layout to the Alt options.
    Is there any particular site for KDE bugs?

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    did some more tests on opensuse 13.2 x64 kde 4.14.9
    цтрл+з works for me
    I tested it in libreoffice writer a non kde app, in firefox a gtk2 app, and in kate using a cyrilic keyboard layout the shortcut ctrl+з works, it even works here in this comment box.
    How did you setup the keyboard layout what DE are you using, I haven't installed kde5 can't say if it works there.
    about kde bugs they do have a bugzulla
    https://bugs.kde.org/

    ps I didn’t use the bulgarian layout, could be something bg related, I tested 2 different cyr layouts no problems for me.

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Quote Originally Posted by I_A View Post
    did some more tests on opensuse 13.2 x64 kde 4.14.9
    цтрл+з works for me
    I tested it in libreoffice writer a non kde app, in firefox a gtk2 app, and in kate using a cyrilic keyboard layout the shortcut ctrl+з works, it even works here in this comment box.
    How did you setup the keyboard layout what DE are you using, I haven't installed kde5 can't say if it works there.
    about kde bugs they do have a bugzulla
    https://bugs.kde.org/

    ps I didn’t use the bulgarian layout, could be something bg related, I tested 2 different cyr layouts no problems for me.
    tested with Bulgarian layout
    enabled bg layout, wrote some gibberish here, deleted it, pressed цтрл+з did an undo, цтрл+щ (ctrl+y or redo) worked too.

  10. #10

    Default Re: Cyrillic keyboard layout corrupts shortcut keys

    Quote Originally Posted by I_A View Post
    tested with Bulgarian layout
    enabled bg layout, wrote some gibberish here, deleted it, pressed цтрл+з did an undo, цтрл+щ (ctrl+y or redo) worked too.
    Testing here the same:

    Going to Configure Desktop > Help > About KDE says:

    Platform Version 4.14.9

    The way I set up layouts is through Configure Desktop > Keyboard > Layouts settings
    Switching Policy = Window
    Using Bulgarian (traditional phonetic) and English (US)

    In which applications цтрл+з works:

    Chrome (as I am typing this) - yes
    Firefox (tested in address bar) - yes
    LibreOffice Writer - yes
    AbiWord - yes

    kwrite - no
    phpStorm - no
    NetBeans - no

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •