Results 1 to 8 of 8

Thread: Unable to get VLC to load

Hybrid View

  1. #1

    Default Unable to get VLC to load

    Please bear w/ me as I'm pretty new to Linux and still learning every day. I installed Opensuse 13.2 and tried to install VLC using the Pacman repo shortly thereafter. Installation seemed to go okay, but whenever I try to open VLC nothing happens. When I try to use the "start" menu, I get a bouncing traffic cone, but the program doesn't load. I also don't get any errors that pop up this way. When I try to load the program via the Konsole I get the following error. I'm pretty stumped on how to fix this and was hoping someone can help me out.

    htpc@linux-i6xe:~> vlc
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [0000000001f3a7f8] core demux error: corrupt module: /usr/lib64/vlc/plugins/access/libdvdnav_plugin.so
    [0000000001e6a0b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [0000000001f763f8] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
    [0000000001f763f8] skins2 interface error: cannot instantiate qt4 dialogs provider
    [0000000001f763f8] [cli] lua interface: Listening on host "*console".
    VLC media player 2.2.1 Terry Pratchett (Weatherwax)
    Command Line Interface initialized. Type `help' for help.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,931

    Default AW: Unable to get VLC to load

    Please post in Code-Tags:
    Code:
    zypper lr -d
    Code:
    zypper se -si vlc

  3. #3

    Default Re: Unable to get VLC to load

    Thanks for your quick reply. I've posted the output for both entries.

    Output for "zypper lr -d":

    htpc@linux-i6xe:~> zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+-------------------------------+------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    2 | download.opensuse.org-oss | Main Repository (OSS) | Yes | ( p) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    3 | ftp.gwdg.de-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/ |
    4 | geeko.ioda.net-amd-fglrx | AMD/ATI Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/ |
    5 | openSUSE-13.2-0 | openSUSE-13.2-0 | No | ---- | Yes | 99 | yast2 | hd:///?device=/dev/disk/by-id/usb-TDKMedia_Trans-It_Drive_07B611035108669E-0:0-part2 |
    6 | repo-debug | openSUSE-13.2-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    7 | repo-debug-update | openSUSE-13.2-Update-Debug | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
    8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ |
    9 | repo-source | openSUSE-13.2-Source | No | ---- | Yes | 99 | NONE | http://download.opensuse.org/source/...13.2/repo/oss/ |
    10 | repo-update | openSUSE-13.2-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    11 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | ( p) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |


    Output for "zypper se -si vlc":

    htpc@linux-i6xe:~> zypper se -si vlc
    Loading repository data...
    Reading installed packages...


    S | Name | Type | Version | Arch | Repository
    --+--------------+---------+-------------+--------+-------------------
    i | libvlc5 | package | 2.2.1-288.2 | x86_64 | Packman Repository
    i | libvlccore8 | package | 2.2.1-288.2 | x86_64 | Packman Repository
    i | vlc | package | 2.2.1-288.2 | x86_64 | Packman Repository
    i | vlc-codecs | package | 2.2.1-288.2 | x86_64 | Packman Repository
    i | vlc-noX | package | 2.2.1-288.2 | x86_64 | Packman Repository
    i | vlc-noX-lang | package | 2.2.1-288.2 | noarch | Packman Repository
    i | vlc-qt | package | 2.2.1-288.2 | x86_64 | Packman Repository

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,931

    Default AW: Unable to get VLC to load

    Please post in Code-Tags.
    http://forums.devx.com/misc.php?do=bbcode

    Try:
    Code:
    zypper in -f vlc-noX vlc
    Code:
    zypper dup --from ftp.gwdg.de-suse

  5. #5

    Default Re: Unable to get VLC to load

    My bad about not using code tags. They should be working now. I tried both commands and this is my output when I try to launch VLC via Konsole: I restarted my computer so I can't give you my original output with the commands. It did appear that everything loaded correctly and I didn't notice any error messages. I ran the commands after reboot and listed the outputs below.

    Code:
    htpc@linux-i6xe:~> vlc
    VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
    [0000000001e1c0b8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [0000000001f29578] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
    [0000000001f29578] skins2 interface error: cannot instantiate qt4 dialogs provider
    [0000000001f29578] [cli] lua interface: Listening on host "*console".
    VLC media player 2.2.1 Terry Pratchett (Weatherwax)
    Command Line Interface initialized. Type `help' for help.
    my output for zypper in-f vlc-noX vlc

    Code:
    htpc@linux-i6xe:~> zypper in -f vlc-noX vlc
    Root privileges are required for installing or uninstalling packages.
    htpc@linux-i6xe:~> sudo zypper in -f vlc-noX vlc
    root's password:
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'vlc-2.2.1-288.2.x86_64' from repository 'Packman Repository'.
    Forcing installation of 'vlc-noX-2.2.1-288.2.x86_64' from repository 'Packman Repository'.
    Resolving package dependencies...
    
    
    The following 2 packages are going to be reinstalled:
      vlc vlc-noX 
    
    
    2 packages to reinstall.
    Overall download size: 3.5 MiB. Already cached: 0 B  No additional space will be used or freed after the operation.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package vlc-noX-2.2.1-288.2.x86_64                                                   (1/2),   3.3 MiB ( 11.6 MiB unpacked)
    Retrieving: vlc-noX-2.2.1-288.2.x86_64.rpm ......................................................................[done (777.4 KiB/s)]
    Retrieving package vlc-2.2.1-288.2.x86_64                                                       (2/2), 236.3 KiB (398.6 KiB unpacked)
    Retrieving: vlc-2.2.1-288.2.x86_64.rpm ........................................................................................[done]
    Checking for file conflicts: ..................................................................................................[done]
    (1/2) Installing: vlc-noX-2.2.1-288.2 .........................................................................................[done]
    (2/2) Installing: vlc-2.2.1-288.2 .............................................................................................[done]
    my output for zypper dup --from ftp.gwdg.de-suse

    Code:
    htpc@linux-i6xe:~> sudo zypper dup --from ftp.gwdg.de-suse
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    
    Nothing to do.

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,931

    Default AW: Unable to get VLC to load

    Delete your vlc-Folder:
    /home/user/.config/vlc

    That should be recreated by vlc.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to get VLC to load

    On 2015-08-22 20:06, VTBurton wrote:

    > my output for zypper in-f vlc-noX vlc


    And after that, does vlc work?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Unable to get VLC to load

    Did you update your openSUSE, there wore a few Qt updates the current vlc was build with the newish Qt it won't work with the old out of the box library's.
    do a zypper up and update your system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •