Results 1 to 4 of 4

Thread: problems with java, it thinks it is 1.5.0

  1. #1

    Default problems with java, it thinks it is 1.5.0

    I'm new to opensuse, but have been using Ubuntu for a while. I have my kids play minecraft on linux since the jar files often bring in malware, and having Oracle Java is important to us since we have found better results for us with Oracle Java than openjdk.

    First I went into the software manager and deleted everything openjdk.
    Then I followed the instructions at https://sites.google.com/site/easyli...a-for-opensuse but for the current 8u60
    Then I installed MultiMC as the launcher for minecraft and tried to launch minecraft
    The error I got was something about a field or path not existing
    So I deleted the java I had just installed, then reinstalled using the instructions at the Oracle site
    Still same error
    java -version returned 1.5.0, not 1.8.0-60 or whatever 8u60 is.
    So I found the usr/bin/java and deleted it after I found that I couldn't edit it.

    That is as far as I've gotten. I suspect that if I can make a new usr/bin/java and point it at the right target, then I can get java to work. The problem is that I don't know how to do it. Would anyone please tell me how to make it so that it points to the right java?

    BTW, I know just enough terminalese to be dangerous to my computers, so please keep that in mind.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: problems with java, it thinks it is 1.5.0

    On 2015-08-20 00:26, sgian wrote:
    > First I went into the software manager and deleted everything openjdk.


    You shouldn't.

    Just let the system install whatever java it wants, then install
    yourself also the oracle version.

    ou use update-alternatives to select the default one your system will use.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,144
    Blog Entries
    2

    Default Re: problems with java, it thinks it is 1.5.0

    Quote Originally Posted by sgian View Post
    I'm new to opensuse, but have been using Ubuntu for a while. I have my kids play minecraft on linux since the jar files often bring in malware, and having Oracle Java is important to us since we have found better results for us with Oracle Java than openjdk.

    First I went into the software manager and deleted everything openjdk.
    Then I followed the instructions at https://sites.google.com/site/easyli...a-for-opensuse but for the current 8u60
    Then I installed MultiMC as the launcher for minecraft and tried to launch minecraft
    The error I got was something about a field or path not existing
    So I deleted the java I had just installed, then reinstalled using the instructions at the Oracle site
    Still same error
    java -version returned 1.5.0, not 1.8.0-60 or whatever 8u60 is.
    So I found the usr/bin/java and deleted it after I found that I couldn't edit it.

    That is as far as I've gotten. I suspect that if I can make a new usr/bin/java and point it at the right target, then I can get java to work. The problem is that I don't know how to do it. Would anyone please tell me how to make it so that it points to the right java?

    BTW, I know just enough terminalese to be dangerous to my computers, so please keep that in mind.
    I don't even know if Java 1.5 runs, I see some compat files in the OSS but that's it.
    With Java 8, there is practically no difference between the openJDK and Oracle Java JRE. Unless you're relying on something the JDK provides, it should not make any difference which you use. Your prior experience with earlier versions of openJDK being different than Oracle JRE isn't relevant to comparing version 8 of each.

    You probably can re-install openjdk 8 by simply installing "java"
    Code:
    zypper in java
    After installing, check your java version. If it's not openjdk 8, then you can display each java that's installed and choose which to use with the following
    Code:
    update-alternatives --config java

    TSU

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: problems with java, it thinks it is 1.5.0

    On 2015-08-20 07:06, tsu2 wrote:
    > With Java 8, there is practically no difference between the openJDK and
    > Oracle Java JRE. Unless you're relying on something the JDK provides, it
    > should not make any difference which you use. Your prior experience with
    > earlier versions of openJDK being different than Oracle JRE isn't
    > relevant to comparing version 8 of each


    I haven't tried with 8, but version 6 or 7 I have seen applications that
    simply refuse to run if it is not Oracle Java. And it is not
    applications where I have a choice: they are official tax applications,
    IIRC.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •