Results 1 to 6 of 6

Thread: can't connect to VNC

  1. #1

    Exclamation can't connect to VNC

    Hi

    I am trying to activate VNC server on my OpenSuse 13. I found some tutorials (in fact, the same one on several websites), so I activated VNC with YaST (and opening the the ports in the firewall) and rebooted my PC. The problem is that I can't connect to the server in any way. When I'm trying to reach the port 5900 I have a "connection refused" and if I try the port 5901 the client timeout (or something like it, the message isn't really helpful).

    At first I thought it was something with my network configuration, but even if I try on the PC itself it refuses to work. I've run out of option.

    Thank you for your help.

  2. #2

    Default Re: can't connect to VNC

    On 08/18/2015 09:16 AM, Soraphiroth wrote:
    >
    > When I'm trying to reach the port 5900 I have a "connection refused" and


    Typically means the firewall is not blocking, but the no service is
    listening here.

    > if I try the port 5901 the client timeout (or something like it, the


    Typically means the firewall is blocking, and dropping packets without
    sending an ICMP packet out to tell the client that it was dropped.

    Try asking the server side what ports are bound for listening,
    specifically in the 5900 range:

    Code:
    ss -planeto | grep 'LISTEN ' | grep :59
    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3

    Default Re: can't connect to VNC

    The port 5901 is open, not the 5900. I already tried to deactivate the firewall and it changed nothing and as I said first, even on the localhost I can't connect the client.

  4. #4

    Default Re: can't connect to VNC

    Chances are good that you are getting a different error message when
    trying locally than you are from a remote system since the firewall, by
    defaults, should never block local connections. It would still help to
    see the listening lines from the command posted earlier. In addition to
    that, post the output of this command:

    Code:
    vncviewer localhost::5901
    From the command line you may get more output which is why that could be
    useful. For example, some VNC servers will prevent localhost connections
    (because they can be confusing to end users if they connect to their own
    sessions). If that's the case, you have two symptoms.

    Are there any other services on this machine that you are able to
    successfully access from a client machine? I ask to help confirm network
    settings are correct for round-trip traffic Knowing you can ping this VNC
    server from the client would also be a good indicator of proper setup of
    the network (ip/subnet-mask/gateway) settings..

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  5. #5

    Default Re: can't connect to VNC

    The symptoms when I'm trying to connect from localhost are exactly the same as another computer, an end of stream for the port 5901 and a connection refused for 5900. I can ping the server and I'm able to connect via ssh to it. I can also ping my client from the server.

  6. #6
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: can't connect to VNC

    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •