Results 1 to 9 of 9

Thread: Error updating kernel-source

  1. #1
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Error updating kernel-source

    Hello, I've encountered a problem when updating kernel-source. It's the same via Yast and zypper.
    Here are details:

    Code:
    zypper up kernel-source
    Retrieving repository 'OpenSuse Education' metadata ............................................................................................................................................................................[done]
    Building repository 'OpenSuse Education' cache .................................................................................................................................................................................[done]
    Retrieving repository 'Packman Multimedia' metadata ............................................................................................................................................................................[done]
    Building repository 'Packman Multimedia' cache .................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      kernel-source-3.16.7-24.1 
    
    1 new package to install.
    Overall download size: 0 B. Already cached: 77.1 MiB  After the operation, additional 471.3 MiB will be used.
    Continue? [y/n/? shows all options] (y): y
    In cache kernel-source-3.16.7-24.1.noarch.rpm                                                                                                                                                    (1/1),  77.1 MiB (471.3 MiB unpacked)
    Checking for file conflicts: ...................................................................................................................................................................................................[done]
    (1/1) Installing: kernel-source-3.16.7-24.1 ...................................................................................................................................................................................[error]
    Installation of kernel-source-3.16.7-24.1 failed:
    Error: Subprocess failed. Error: RPM failed:    installing package kernel-source-3.16.7-24.1.noarch needs 298MB on the / filesystem
    
    
    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,302
    Blog Entries
    2

    Default Re: Error updating kernel-source

    Why do need kernel-source?
    You generally use that to either re-build the kernel or parts of the kernel.

    Most often, Users only need the kernel headers to modify the kernel or build kernel modules, install using the following
    Code:
    zypper in kernel-devel
    After that, whenever your kernel is updated, the headers should also update automatically but sometimes they might get out of sync. Only if that happens then updating the system will re-sync versions
    Code:
    zypper up
    Do you still need kernel source?

    TSU

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,161

    Default Re: Error updating kernel-source

    Like you, I do not completely understand the meaning of the error message, but it could be that there is no amount of 298MB free.

    Easy to check with
    Code:
    df -h /
    Henk van Velden

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Error updating kernel-source

    With
    df -h /
    there was not enough space.
    As suggested in the posts there was no need to keep kernel-source. I removed it.

    Thanks
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Error updating kernel-source

    On 2015-08-17 13:26, GazetaCypr wrote:
    >
    > With
    >> df -h /

    > there was not enough space.
    > As suggested in the posts there was no need to keep kernel-source. I
    > removed it.


    You should consider free up some space, anyway.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: Error updating kernel-source

    On 08/17/2015 01:56 AM, GazetaCypr wrote:
    >
    > Hello, I've encountered a problem when updating kernel-source. It's the
    > same via Yast and zypper.
    > Here are details:
    >
    >
    > Code:
    > --------------------
    >
    > zypper up kernel-source
    > Retrieving repository 'OpenSuse Education' metadata ............................................................................................................................................................................[done]
    > Building repository 'OpenSuse Education' cache .................................................................................................................................................................................[done]
    > Retrieving repository 'Packman Multimedia' metadata ............................................................................................................................................................................[done]
    > Building repository 'Packman Multimedia' cache .................................................................................................................................................................................[done]
    > Loading repository data...
    > Reading installed packages...
    > Resolving package dependencies...
    >
    > The following NEW package is going to be installed:
    > kernel-source-3.16.7-24.1
    >
    > 1 new package to install.
    > Overall download size: 0 B. Already cached: 77.1 MiB After the operation, additional 471.3 MiB will be used.
    > Continue? [y/n/? shows all options] (y): y
    > In cache kernel-source-3.16.7-24.1.noarch.rpm (1/1), 77.1 MiB (471.3 MiB unpacked)
    > Checking for file conflicts: ...................................................................................................................................................................................................[done]
    > (1/1) Installing: kernel-source-3.16.7-24.1 ...................................................................................................................................................................................[error]
    > Installation of kernel-source-3.16.7-24.1 failed:
    > Error: Subprocess failed. Error: RPM failed: installing package kernel-source-3.16.7-24.1.noarch needs 298MB on the / filesystem
    >
    >
    > Abort, retry, ignore? [a/r/i] (a): a
    > Problem occured during or after installation or removal of packages:
    > Installation aborted by user
    >
    > Please see the above error message for a hint.
    >
    > --------------------
    >
    >

    Looks like you don't have enough space on /
    Check to see how full the file system is using

    code
    df -h


  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Error updating kernel-source

    Yes, thank you for your suggestion, I did free up some space. Now I've got 2.5GB of free space on /

    How to check what is not needed on disk (software, packages)?

    greetings
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  8. #8

    Default Re: Error updating kernel-source

    Quote Originally Posted by GazetaCypr View Post
    How to check what is not needed on disk (software, packages)?
    If you use btrfs as root filesystem (the default on 13.2) you should probably start with deleting some snapshots in YaST->Misc->Snapper.

    Regarding what software is not needed, only you yourself can decide that...
    If a package is required by some other package, YaST will tell you so.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,161

    Default Re: Error updating kernel-source

    Quote Originally Posted by GazetaCypr View Post
    Yes, thank you for your suggestion, I did free up some space. Now I've got 2.5GB of free space on /

    How to check what is not needed on disk (software, packages)?

    greetings
    Did you realy post that
    Code:
    df -h
    somewhere abov. (I doubt, but I may have missed it). When not, please do so. We are not clairvoyant and thus we can not even know if your usage is extreme or not.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •